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1 Introduction

The CSL™ Main Program (CSL) is a hardware and software system for the acquisition, acoustic analysis,
display, and playback of any acoustic signals characterized by changing spectra over time, including
speech signals. It is used for the recording and display of acoustic parameters of speech and voice
signals for linguistic, forensic, and communication sciences applications

Multi-Speech™ is a software only version of CSL. It is a comprehensive speech recording, analysis,
feedback, and measurement program which uses standard multimedia hardware to capture acoustic
signals and includes the same analysis features as CSL software. Multi-Speech software options include;
Auditory Feedback Tools, Voice Games, Motor Speech Profile, Real-Time Pitch, Real-Time Spectrogram,
Sona-Match, Multi-Dimensional Voice Program, Analysis of Dysphonia in Speech and Voice and iCAPE-V.

The CSL is compatible with the same optional modules of Multi-Speech, as well as Voice Range Profile,
and Real-Time EGG

CSL and Multi-Speech:

e Capture multiple channels of acoustic signals (up to four channels simultaneously) at a wide range of
sampling rates. (Note: typical application is to use only one channel at a time.)

e Provides tools for management and editing of speech/voice samples for analysis.

e Performs spectrogram, FFT, and LPC analysis and displays formants, pitch contours and energy
contour.

1-1 Intended Use

The Computerized Speech Lab, CSL, Model 4500b, is designed for the acoustic analysis of signals in a
wide variety of applications including assessment of disordered voice & speech and linguistic analysis,
and forensic acoustic applications. The typical operating environment is in a lab, office, sound booth,
medical examination room, or speech therapy treatment room. The CSL, Model 4500b system is suitable
for use in a patient environment.

1-2 Indications/Contraindication for Use

The CSL is a professional-level product designed for the office, lab, or clinic for assessment and therapy
of voice and speech. This product is not designed for O.R. use.

1-3 Undesirable Effects

The use of headphones for listening has the potential side effect of damage to the client’s hearing.
Consult the manufacturer’s instructions for safe use.

1-4  User Requirements

Users should be thoroughly trained in the procedures appropriate to the equipment.
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1-5 Hardware Considerations

For information about hardware specifications, installation, and operation, refer to the Computerized
Speech Lab (CSL™) Hardware and Installation Manual..

1-6  Warnings and Precautions

A\

Warning

You should read and understand the instructions in this manual before you perform
any procedures using CSL and Multi-Speech. Failure to do so may result in injury to
the patient or damage to the instrument.

Warning and Caution messages appear throughout this manual in the following formats:

JAN

Warning

Warning messages tell you about conditions that could result in death or serious
injury.

JAN

Caution

Caution messages tell you about problems that might result in minor or moderate
injury, or property-damage.

1-7  Symbols Used

Symbol Indicates Symbol Indicates

A\

7\
7
av

®

Instruction manual symbol. The Input
product is marked with this
symbol when it is necessary for
the user to refer to the instruction

manual.

Type B Applied Part Output

Type BF Applied Part Dangerous Voltage

Alternating Current “Off"” (Only for a Part of Equipment)

Direct Current “On" (Only for a Part of Equipment)

Protective Earth (Ground)

) VRP Mode
Terminal

B @ T QB

MUODO0000700
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Risks of Reciprocal Interference

This equipment is intended for use in a clinical environment by healthcare professionals only. It provides
reasonable protection against harmful interference in a typical clinical installation. However, there is no
guarantee that interference will not occur in a particular installation. If this equipment causes or receives
detectable interference, you can limit it by using one or more of the following measures:

e Reorient or relocate the affected device.
e |ncrease the separation between devices.

e Connect the equipment into a mains outlet on a different circuit from the device(s) causing the
interference.

e Consult the manufacturer or field technician for help.

During playback, amplitude levels are restricted to levels below that which would damage human ears.
Typical precautions for audio playback should be observed when using additional peripherals such as
headphones.

Maintenance and Calibration

There are no maintenance or calibration procedures for the CSL and Multi-Speech hardware. Although
the microphone does not wear out, it can be damaged. Consult the instructions provided with the
microphone for repair or replacement information.

Non-Medical Equipment

CSL meets the medical standard for UL60601-1 and EN60601-1

When the unit is installed in conjunction with other equipment to operate as a medical electrical system,
that system is to be tested at the end-user facility after installation to guarantee compliance with the
system leakage current requirements of IEC 60601-1-including the required use of a medically approved
(60601-1) safety isolation transformer.

MUODO0000700 10 Revision B
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1-11  Using this Manual

You should read and understand the instructions in this manual. The manual uses the following
conventions:

Convention Definition

@ Note Important information about a subject or the use of the device. Failure to
follow a note can result in configuration or installation issues.

Bold lettering Menu option or button, or text you should select or enter.

Italics Reference to other sections in this manual or to other documents.

1. Text Procedure with more than one step.

> Procedure with one step.

Start > Shutdown Path that shows menu selections in sequence.

@ Note You can use this manual in its print form or click in the application title bar to view a
version in .pdf format.

1-12 Contacting PENTAX Medical

If you have operational questions or cannot solve a problem by using this manual, contact your local
representative; if you are in the United States, contact PENTAX Medical directly (toll free at 800-431-5880
or e-mail customerservice@pentaxmedical.com).

1-12-1 Reproduction Policy

Data contained in this manual is copyrighted by PENTAX of America Inc., and is furnished solely for the
purpose of providing instructions for operation and maintenance of the apparatus described herein. Said
data shall not be used by the purchaser or the government for promotional procurement, development,
or manufacturing purposes, nor shall the data be reproduced or disclosed without permission from
PENTAX of America. In event of resale of the apparatus to the government, by the purchaser, the
purchaser shall notify the government of the limited right to use said data.

1-12-2 Warranty

For information on additional warranty coverage, please contact your local representative.
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2 System Components and Operating Requirements

CSL Main Program and Multi-Speech are designed to work with a variety of speech and auditory
recording tools.

| Warning

Do not connect the system to a wall outlet using an extension cord or an external multiple
Socket Outlet. Use only an approved medical grade power cord.

ﬁ Warning

To avoid risk of electric shock, connect this equipment only to a supply mains with
protective earth.

| Warning

This equipment is not suitable for use in the presence of a flammable anesthetic mixture with
air, oxygen, or nitrous oxide.

ﬁ Warning

To reduce the risk of fire and electric shock, do not expose electrical equipment to moisture
and dust.

| Caution

This product has no serviceable parts. Do not disassemble the unit.

Caution
Do not modify this equipment without authorization of the manufacturer.

Caution

> B

Accessories connected to the USB port must be certified to /EC 60950-1 Information
Technology Equipment-Safety—Part 1: General Requirements for data processing equipment,
and |EC 60601-1 Medical Electrical Equipment—Part 1: General Requirements for Safety for
medical equipment.
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2-1  System Components

&

Note All PCs used for this product must meet the following specifications and be used with

a suitable (60601-1 qualified) isolation transformer, Medical grade (60601-1) Power supply or

Medical Grade (60601-1 qualified) PC.

Note Addition of new hardware or software to the system can have unintended consequences.
Consult the manufacturer before installing new hardware or software to determine compatibility.

Note System components may be upgraded without notice.

CSL Model 4500b includes the following parts:

Figure 1. CSL Model 4500 parts

Unpack and inspect the CSL. The following parts should be included:

MUODO0000700

CSL external module with power cord
Lynx E44 audio card
DB-25 cable to connect CSL external module to E44 audio card

Cables (3): Audio card interface to male XLR and female XLR, male XLR to RCA, and female XLR
to RCA.

Security key

Speaker with cable

Shure dynamic hand-held microphone and XLR cable

Headphones

Two RCA female to %" phono male adaptors

Computerized Speech Lab (CSL) Hardware and Installation Manual

Software installation disc with the CSL software, required device drivers, and a PDF of the
software operating manual

Speech Products Software Installation Instructions

Note If for any reason parts are damaged or missing, immediately contact the factory or a
PENTAX Medical representative.
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2-2  System Requirements

Note All PCs used for this product must meet the following specifications and be used with
a suitable (60601-1 qualified) isolation transformer, Medical grade (60601-1) Power supply or
Medical Grade (60601-1 qualified) PC.

Note Addition of new hardware or software to the system can have unintended consequences.
Consult the manufacturer before installing new hardware or software to determine compatibility.

@ Note System components may be upgraded without notice.

2-2-1 Desktop Computer Minimum Requirements

The computer used with CSL must meet or exceed the following specifications:
e Full size AT style PC case (tower or desktop)

e Intel®Core™ i5 processor or better

e 4 Gb system RAM

e 250Gb HDD or larger

e DVD ROM/RAM drive

o 1 free full height PCle expansion slot

e 1 free USB 1.0 (or better) port

o VGA, HDMI or DP graphics card and monitor that supports a minimum
screen resolution of 1280x1024 (4:3) or 1440x900 (16x9)

e Certified to EN60950-1 and/or ULB0950-1

2-2-2 Laptop Computer Minimum Requirements for Multi-Speech

The laptop computer used with Multi-Speech must meet or exceed the following specifications:
e PC type laptop running Windows 10

e Intel®Core™ i5 processor or better

e 4 Gb System RAM

e 250Gb HDD or larger

e Stereo sound card with discrete 3.5mm microphone input (or adaptor)

e VGA, HDMI or DP graphics card and monitor that supports a minimum
screen resolution of 1280x1024 (4:3) or 1440x900 (16x9).

e 1 free USB 1.0 (or better) ports
¢ DVD ROM/RAM internal or USB external
e Certified to ENB60950-1 and/or ULB0950-1
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2-2-3 lIsolation Transformer Requirements;

e Medical grade PCs or used with a suitably rated Isolation Transformer
o Certified to UL/EN/ISOB0601-1 with leakage no greater than 100UA.

e Capacity (VA rating) to be higher than the steady state maximum load of both PC and Monitor
connected, Ideally double.

2-3  Audio Quality

Multi-Speech operates as a stand-alone program, using PC audio cards for input and output, while CSL
uses a professional-grade external sound acquisition module. Multi-Speech offers a low cost product
with an inexpensive audio card, but at lower performance levels than CSL's professional system.

The limitations of onboard audio input stem from the high level of noise from the fans and drives
operating inside a computer. A typical 16 bit audio card has an input SNR (signal-to-noise ratio) of about
40-60dB. Therefore, with a 16-bit sampling resolution, about half of the dynamic range is lost in noise.
CSL with the external module has a SNR greater than 80dB. Marketing claims are often based on
playback of motion pictures and other professionally recorded sound, and with many low cost cards, the
actual SNR from captured audio is higher than the marketing specifications can indicate.

The CSL external module uses professional sound reduction techniques to achieve very low noise levels.
A high quality microphone and external preamplifier can improve sound quality with Multi-Speech.

2-4 EMC Influences

The hardware used with CSL and Multi-Speech is intended to be used in an electromagnetic
environment in which radiated disturbances are controlled. Portable and mobile RF communication
equipment can affect medical electronic equipment. Care should be exercised in using medical devices
near potential sources of RF emissions

2-5 Leakage Current

The power supply for the PENTAX Medical CSL, Model 4500b, was tested and shown to be in
compliance with the leakage requirement of IEC60601-1.
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2-6  Environmental Conditions
CSL and Multi-Speech require the following environmental conditions:

Operating Conditions: e Temperature +10 °C to +40 °C
e Relative Humidity 20% to 80% (non-condensing)

e Atmospheric Pressure 700mb to 1060mb

Storage/Transportation Conditions e Temperature =10 °C to +60 °C
e Relative Humidity 20% to 80% (non-condensing)

e Atmosphere Pressure 700mb to 1060mb

This product is a medical device. In accordance with European Directive 2002/96/EC on
Waste Electrical and Electronic Equipment, this symbol indicates that the product must
not be disposed of as unsorted waste, but should be collected separately. Contact your
local PENTAX Medical distributor for correct disposal and recycling. By disposing of this
product correctly you will help ensure that the waste undergoes the necessary treatment,

I '<covery and recycling and thus prevent potential negative effects on the environment and
human health which could otherwise arise due to inappropriate waste handling.

@ Note Follow local, state, and federal guidelines for the proper disposal of waste products.

2-7 Cleaning and Disinfecting

Warning

Appropriate personal protective equipment (gloves, fluid impermeable gown, face shield,
and respiratory protection) must be worn during cleaning and disinfecting procedures.

Follow these guidelines for cleaning and disinfection:

e The keyboard, mouse, and microphone are non-invasive: they do not come into direct contact with
the mucus membranes of the patient’s mouth or nose. You can clean and disinfect them between
patient procedures, using commercially available detergents and surface disinfectants.

e All microphones, digital recorders, and other equipment used for recording audio or other breath
analysis must be properly sanitized according to instructions provided by the manufacturer for
cleaning and disinfection.
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Installation and Loading

The CSL Main Program and Multi-Speech are often used with an assortment of recording equipment.
Read all instructions and cautions included with CSL hardware components, all recording equipment
manufactured by PENTAX Medical or another supplier, and all software module instructions and cautions
before use. The CSL Main Program and Multi-Speech are often one analysis module connected to a
larger hardware and software configurations and additional safety and environmental conditions apply to
each specific component.

Launching CSL and Multi-Speech

To launch CSL and Multi-Speech, turn on components in the sequence indicated below, skipping any that
do not apply to your configuration.

1. Monitor

1. Host Computer

2. CSL External Module (CSL users only)
3. Preamplifier (if used with Multi-Speech)
4

External speakers

Connecting the Security Key

You need to install the security key in order to use the program:

Note Do not plug the security key into the computer until the application software and security
key driver are installed.

» Plug the security key into an available USB port on the host computer.

Launching the Application

To start the CSL Main Program or Multi-Speech software:
1. At the desktop, select the CSL icon @ or the Multi-Speech icon M.

You can also open the launch bar from the Windows Start menu.

M PENTAX Medical - Multi-Speech

Wulti-Speech

‘M Multi-Speech Main Program

Single-click a button to launch an application.

Figure 2. Multi-Speech Launch Bar

The launcher on your display can vary, and will include the CSL Main Program or Multi-Speech and other
installed PENTAX Medical speech software.
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4 Using CSL and Multi-Speech

This section introduces you to the core functionality of the CSL Main Program and Multi-Speech, its
windows and toolbars, data markers, audio capture, playback, and other basic functions.

4-1 Windows and Toolbar

When you begin the program, your screen should look similar to the following display. Below the title bar
and toolbar is the grey work area, where all open and minimized windows reside. The application defaults
to two open windows but supports up to eight.

Speak Aalas Tage [PA Macros Loy Opti Window Fap

LEREODL S 00 AARRX DL s vEHE ebkpkld e

st e T Sorces 4 Ackee,

Figure 3. Application window on start-up.

Initially, there are two windows open: Window A is the active window, and Window B is an inactive
window. Inactive windows can serve as the source window.
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4-1-1 Quick Access Toolbar

The toolbar icons located directly below the upper dropdown menus provide shortcuts to some of the
most commonly used features of CSL and Multi-Speech.

File Edit View Speak Analysis Tags IPA Macros Log Options Window Help
THRLERR DD 200 AABEEX USSP VEE ePhé o

Figure 4. Quick Access Toolbar.

Button | Description

New Window: Opens a new window with the dimensions of the current
active window. The new window opened becomes the Active.

~h Open Signal File: Load a file from disc. If the active window the file is being
opened into contains data, that data will be purged (deleted).

Save Signal: Calls a dialog box which allows you to save the waveform
signal in the active window to a file.

Print Full Screen Image: Calls a dialog box which allows you to send a
graphic image of the screen to a printer. From the dialog box, optionally add a
header and/or footer to the printed page, set the header/footer font, and
select a printer.

Print Active Window Image: Calls a dialog box which allows you to send a
high-resolution graphic image of the active window to a printer.

Save Active Window Image: Calls a dialog box which allows you to save a
high-resolution graphic image of the active window in bitmap, JPEG, GIF, or
PNG file format. From the dialog box, optionally adjust the image size.

Copy Signal: Copies signal data in the active window to the clipboard.

Paste Signal: Clears the active window, and then loads the signal data
previously saved to the clipboard.

Undo Last Edit in Active: Undoes the last edit made to the signal data in
the active window.

Activate Previous Window: Causes the previous window in alphabetical
order to be active. Windows are labeled A to Z.

Activate Next Window: Causes the next window in alphabetical order to be
active. Windows are labeled A to Z.

View All Data: Displays all graphic data associated with the active window.

View Selected Data: Displays graphic data in the selected region of the
active window.

/ﬂ/”@@aﬁr_f“ff !FIIEm Elj,ﬂ:ﬂl
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Button

Description

e

Cycle Analysis Plots: If the active window contains multiple analysis results,
the top plot is put to the back of the analysis results list and the previous plot
is brought to the front. Thus you can cycle through the analysis plots in a
window. Spectrograms cannot be brought forward and should be plotted in a
new window if needed.

Remove Top Plot: If the active window contains multiple analysis results, the
top plot is deleted and the previous plot is brought to the front.

Purge Active Window: Clears the contents of the active window and
removes any associated data.

& X | &

Mark at Cursor: Moves the green data mark in the active window (and any
linked windows) to the current cursor location. When the data mark is moved,
the x-axis box reports the current cursor location relative to the location of the
data mark. This is indicated by an R beside the numerical value.

Link Window: Links the active window to the default source window. Cursor
movement, data mark movement, selection area definition and show
operations are duplicated in linked windows.

]

Unlink Window: Unlinks the active window from any other windows it was
previously linked to.

Active > Source: Makes the active window the source window.

lm 0

{:.

Info: Displays an information box on the contents of the active window.

Numerical Results: Computes and displays numerical results for the
topmost analysis data in the active window.

Statistics: Computes and displays result statistics for the topmost analysis
data in the active window.

Record Signal: Starts the data capture routine.

Speak All: Generates audio output of all signal data associated with the
active window.

Speak Selected: Generates audio output of the selected signal data
associated with the active window.

Speak from Mouse Mode: Speech playback begins at the location of the
mouse click on the screen. Press and hold down Left mouse button to speak.
Speech playback ceases when you release the mouse button, or when the
end of the speech sample is reached.

Help: Starts Help.
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4-1-1 Windows Scrollbar
A scroll bar is displayed under the horizontal axis of some windows.

Note The window scroll bar may be displayed or hidden using the Display Scrollbar option in
the Window Attributes box.

When all data are shown in the window, the thumb fills the scroll bar. When a portion of the data are
shown, the thumb in the scroll bar shows the relative location of the currently displayed data.

4-1-2 Cursors

There are three types of cursors: the red data cursor, the green data mark, and the two blue selection
cursors. You can use these cursors are used to mark and select data.

Data Cursor

The Data cursor: is a red vertical line that identifies a specific location. Initially, the data cursor is at the
beginning of the data display.

To move the data cursor, you can:

e Left click the desired point in a window.

e Left click and hold the left mouse button in the current data cursor position and drag the cursor.
The x-axis records the position of the data cursor relative to the data mark.

" 5] CAUsers\PublictD iSpecchdata) i oo =

_8'003 v
138
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Time(sec)
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)
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Wl x 1162395t y: 1388 ss: 0.00000sec se: 1.68045sec ds: 1.68045 sec
Figure 5. Waveform Editor with Red Data Cursor

Note Some operations, such as audio playback and data display, can be performed on a
region of data that is defined relative to the data cursor.

Moy

You can also use predefined keyboard shortcuts to move the data cursor.

Use: In the active window to:

Home Move the data cursor to the start of displayed data.
End Move the data cursor to the end of the displayed data.
Left Move the data cursor one pixel to the left.

Right Move the data cursor one pixel to the right.

Ctrl+Left Move the data cursor ten pixels to the left.

Ctrl+Right Move the data cursor ten pixels to the right.

MUODO0000700 21 Revision B



PENTAX

MEDICAL

Data Mark

The Data Mark is a green vertical line that initially appears at the start of the display. The data mark
provides a reference location relative to the cursor.

e When you move the data mark away from the start of the file, the x-axis records the distance
between it and the data cursor. The letter R appears after the x-axis value when the data mark is
placed and influencing the x-axis value.

e Some operations, such as data display, can be performed on a region of data that is defined relative
to the data mark.

To move the data mark, you can:
e Hold down the [Ctrl] + left click the desired point.

e Move the mouse pointer to the left of the window where data begins. When the arrow becomes a
double-arrow (##) left click and drag the green line to the desired location.

e Left-click the desired point and select Mark at Cursor (1) from the toolbar. This moves the green
data mark to the location of the red data cursor.

e Use the Num + predefined shortcut to place the data mark at the current cursor location.

@ Note Only one data mark can exist in a window at any time.

The image below shows the data cursor placed slightly over 0.5 seconds before the red data mark.
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Figure 6. Data Cursor Relative to Data Mark
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Segment Marks
Segment Marks are two blue lines that represent the bounds of a data segment.
To place segment markers:
1. Shift + left click at one of the desired segment bounds.
A blue line appears and the mouse pointer becomes a double-arrow (4ik).
2. Hold the left mouse button and drag the blue line to the left or right.

One line moves with the mouse, and one remains where initially placed. The area between the two
blue lines makes up the segment.

To move segment bounds after you place the markers, hover the mouse over the desired line: when
the double-arrow returns, hold the left mouse button and move the segment marker.

@ Note Only two segment markers can exist at one time.

To toggle the display:

1. At the toolbar, select View Selected Data.

2. Select:
e todisplay data between the segment markers.
e 3, todisplay the entire data set.

The image below shows the two blue segment markers around a peak in the waveform.
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Figure 7. Waveform with Two Blue Segment Markers

The image below shows only the data between the blue segment markers, as shown below.
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Figure 8. Waveform Showing Only Data Between Segment Markers
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4-1-3 Moving a Cursor

All cursors can be easily moved to new locations by dragging them with the mouse.
To move a placed cursor (the data cursor, data mark, or selection cursors):

1. In the active window, move the mouse to the location of the cursor you wish to move. The mouse
arrow will become a double-arrow (#) when over any of the cursors.

2. Hold down the left mouse button and drag the cursor to the desired location within the active
window.

4-1-4 Removing Selection Cursors

You can remove the selection marks from the active and linked windows.
To remove the selection marks:

1. Toremove the selection marks in the active and linked windows, choose Remove Selection Cursors
from the Edit menu.

2. The selection start (ss) and selection end (se) boxes on the window status bar normally report the
start and end locations of the selected region of data. When selection marks are removed from a
window, these boxes are blank. If a scrollbar is displayed in the window, the blue indicators above
the scrollbar are removed.

3. Program operations that act on the selection area cannot be performed if selection marks have been
removed.

4. Atany time, you can re-insert the selection marks by choosing Select All Data from the Edit menu.

4-1-5 Color Selection Tool

Two color panels are present as small vertical bars on the bottom of each active window.

These determine the color of the current and next plot in the window. Effective use of the pen tool is
important when working with multiple plots per window. Refer to Section 5, Speech Pathology Data
Analysis, for more information.

For example, after generating a greyscale spectrogram, you can overlay the formant history in red, the
pitch contour in blue, and the energy contour in green to easily distinguish between them.

The screenshot below shows the lower portion of a window containing data with the color selection tool.
The color of the currently displayed data always matches that of the first color swatch.
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Figure 9. Pen Color Tool
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The first, blue swatch, corresponds to the color of the current top plot, which matches the visible
waveform displayed in the image. The second color displayed will be used for the NEXT plot in the
window.

To change the color of the current active plot:
1. Double-click on the left color swatch at the bottom of the active window.
2. Left click your desired color from the box that appears.
The topmost graphic in the window is redrawn with the newly selected “active” color.
To set the color of the next plot:
3. Double-click on the right color swatch at the bottom of the active window.
4. Left click your desired color from the box that appears.

The next plot drawn will use the selected color.

4-1-6 Keyboard Shortcuts

CSL Main Program and Multi-Speech come configured with a number of keyboard shortcuts which carry
out many of the more common functions. Many expert users carry out much of their interaction with the
software through keyboard shortcuts. Refer to Appendix G, Predefined Keys for a full list of defined key
combinations.

Note Custom hotkeys are not supported in version 4.0. If you reach a screen prompting you
to assign a keyboard shortcut, press Done to exit without making any changes.

4-2  Manipulating Data

4-2-1 DataTypes

There are three types of data which exist in the graphics work environment of a program window. These
are Waveform Data, Analysis Data, and Transient Data.

Waveform Data

Waveform data provide the basis for all other types of program data. All audio data that are captured by
the CSL Main Program and Multi-Speech using analog-to-digital (A/D) conversion are stored in binary
format as numerical values. These numerical values can be displayed in graphic format and played back
as audio data using digital-to-analog (D/A) conversion. Waveform data, displayed in graphic format, have
time represented along the horizontal axis and amplitude displayed along the vertical axis.

In addition to the analysis operations that can be performed on waveform data, it is also possible to
perform simple “editing” routines on these data.
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Analysis Data

Analysis operations can be performed once waveform data have been displayed in the source window.
Analysis data resulting from the analysis operations can be one of the following types:

e | PC-based Frequency Response (LPC)
e LPC Waterfall Array (LPCW)

e FFT-based Power Spectrum (FFT)

e FFT Waterfall Array (FFTW)

e Long-Term Average Power Spectrum (LTA)
e Inverse Spectrum (CEPSTRUM)

e Spectrogram (SPG)

e Formant History (FMT)

e Voiced Period Marks (IMPULSE)

e Pitch Extraction (PITCH)

e Energy Calculation (ENERGY)

The type of analysis data will be reflected in the window title at the top left corner of the window. The
title of each analysis type is recorded in the bracketed information above. All analysis data can be saved
to a file for later processing or plotting, except for the spectrogram and for waterfall arrays

Note Transient data, the output of an analysis calculation, is not supported by numerical
results or statistics. Therefore, the data cannot be saved to a file. The only types of transient
data are the spectrogram, the FFT waterfall array, and the LPC waterfall array.

Transient Data

The following audio file formats are supported:

e CSL Signal File format (.NSP)

e Wave Audio File format ((WAV)

e A number of Headerless Audio File formats (.RAW):

e 16-bit PCM

o 16-bit PCM (byte swap)
e 8-bit PCM

e p-Law (MU-Law)

o Alaw

e Dialogic ADPCM
e Intel ADPCM
e CSL Signal File Format Features

e File Extension: NSP
Maximum Number of Channels: 8
Tags In Data: YES
Comment Field: YES
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Wave Audio File Format Features

e File Extension: WAV
Maximum Number of Channels: 2
Tags in Data: NO
Comment Field: NO

Headerless Audio File Format Features

e File Extension: RAW
Maximum Number of Channels: 1
Tags In Data: NO
Comment Field: NO

The data format and sampling rate must be specified before headerless audio files can be loaded or
saved. If the wrong format is specified when opening a raw data audio file, the results are garbage. If
the wrong sampling rate is specified, the data are spoken at the wrong speed (i.e., too fast or too
slow).

It is recommended that headerless audio files be stored in separate folders that identify the file type
and subfolders that identify the sampling rate (for example, create a “MU-LAW" folder which
contains folders named “10000"”, “11025", etc.).

4-2-2 Viewing a Region of Data

You can view portions of displayed data. At the View menu, select:

View = All Data to show all data or click =% on the toolbar.
View > Selected Data to show the selected data or click #, on the toolbar.

View - Between Data Mark and Cursor to show only the data between the green data mark and
the red data cursor.

View - Start to Cursor to show only the data from the start to the current data cursor location.

View > Cursor to End to show only the data from the current data cursor location to the end.

4-2-3 Show Next Waveform Channel

By default, the active window displays the first channel of a multi-channel recording. You can toggle
between them or display all channels within a file.

To display a different channel in the active window:

1.
2.

Ensure that a multi-channel waveform is displayed in the active window.

To determine how many channels are contained in the signal and which channel is currently
displayed, select Information on Active Window from the Window menu.

To switch the display in the active window to the next channel, select Show Next Waveform
Channel from the View menu.

If the source window contains a multi-channel signal, you can split a single channel from it for display
in an empty active window. This action can be performed for every channel in the multi-channel
signal. The signals can be subsequently re-joined. Alternatively, you can display all channels of data in
a single window.
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To display all channels of signal data in the active window:

1. Ensure that the height of the window is sufficient to display multiple panes of signal data.
2. From the Options menu, select Waveform to display a Signal Display Options box.

3. If the Display all channels checkbox is not selected, click on it to select this option.
4

If the active window contains multi-channel signal data, click the Apply button to apply the new
setting to the window.

5. Click OK to close the Signal Display Options box.

Note that the active window is not divided into multiple panes if there is only a single channel of
signal data in the window.
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Figure 10. Introduction Window with small range of waveform data

In this example, the scrollbar is much smaller, and is set to only show data between 0.4 and 0.5
seconds, guided by the lines above. The red data mark will be placed at the start of the displayed
data.

“C:\Kaylab\Data\Analysis-Synthesis\test 1. NSP"
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Figure 11.  Window with larger range of waveform data.

This image doubles the amount of data shown, displaying the 0.2 seconds between 0.35 and 0.55 of
the waveform data. The red data mark remains at its previous location, though as data before Figure
10 is now displayed, the red line appears in the middle of the window, though at the same time as
before.
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4-2-4 Trimming Sampled Data

You can remove data both inside and outside a specified range, which causes the waveform to be
redrawn with new time dimensions. In addition, you can specify that the data within the named range be
removed, causing the waveform to be redrawn with the remaining data spliced together.

To trim signal data:
1. Ensure that a waveform is displayed in the source window.
2. Ensure that Window A is active.
3. At the menu, select Edit > Trim Waveform Data to show a list of trimming options.
4. Select:
¢ Remove Signal Outside Selection to remove data outside the selected region.

¢ Remove Signal In Selection to remove data in the selected region, with remaining data pasted
together.

¢ Remove Signal Start to Cursor to remove data from the start to the current data cursor
location.

¢ Remove Signal Cursor to End to remove data from the current data cursor location to the
end.

The remaining waveform data are redrawn with new time dimensions.

4-2-5 Data Plot Management

A single window can contain any number of compatible analysis results. Refer to Section 5, Speech
Pathology Data Analysis, for details of the many forms of analysis the CSL Main Program and Multi-
Speech can conduct.

%] Note Use different colors to identify different analysis types. See Section 4-1-5, Color
Selection Tool, for details on selecting and changing the colors of plotted data.

If a single window contains more than one analysis plot, you can rotate which appears on top. Additional
information can be viewed for the uppermost plot, and that plot only can be purged if desired.
To rotate and remove analysis results in the active window:
1. Ensure that the active window contains two or more analysis types.
Refer to Section 5, Speech Pathology Data Analysis, for details.
2. At the View menu, select Put Previous Plot onTop.

The next set of analysis data is moved to the top, and the window title changes to display the name
of the new top plot.

3. Continue clicking Put Previous Plot on Top. Until you reach the analysis you need.

To view information about the current top analysis, right-click inside the active window and pick
Information. To view details about the uppermost analysis, as shown in the screen below. The
specific data shown will vary according to the type of analysis plotted on top.
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Remove Current (Top) Plot

A window can contain any number of compatible analysis results. If multiple analysis results data are
present in a window, you can remove the top analysis data and display the previous data.

Note If the results of only one analysis are in a window, removing the topmost analysis data is
equivalent to purging the window.

To remove the topmost analysis results data from the active window:
1. Ensure that analysis results data are present in the active window.

2. Select Remove Current (Top) Plot from the View menu to remove the current analysis results,

The topmost analysis results are removed from the window and deleted from the analysis results
list. Data from a previous analysis are brought to the top of the list. The window title changes to
reflect the current analysis data. Removing the last analysis data from a window is the same as
purging the window.

3. Select Information on Active Window from the Window menu to display information about the
current analysis.
You can also display numerical results and result statistics for the current analysis data. Note that,
because spectrogram data are transient, statistics and numerical results are not available.

Note When you overlay multiple analysis results in a window, it can be helpful to display each
calculation in a different color.

FFT Analysis Information ? X

Source File : ‘ C:\Users\PublicDowmems\l\dulﬁ-Speeé\data\demo\s;I

Source Range
SignalId| A Minimum (dB) 8.45

Channel Maximum (dB) | 33.24

Smoothing None
Sampling Rate 11025
Analysis
Start (sec) 0.00000 Size (pts) 512

End (sec) 1.68045 Window
Pre-emphasis 0.000

Comment

IFU Example Image.

Cancel

Figure 12. Formant Analysis Information Window
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4-3 Recording a Signal

To record a signal:
1. Turn on your microphone
2. At the menu, select File > New (Record)

During recording, the Record button on the bottom of the active window is replaced with a nVU
meter and Stop button, and the waveform of the input signal is displayed in the active window. A
Scope Window can also be displayed beside the active window if selected under Options, Capture
and Waveform
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Figure 14. Window Containing Waveform Data
Select File and New (Record), and say “\We were away a year ago.”

If there is data in in the active window, a confirmation message appears. Click Yes to purge the
window contents in order to record new data.

5. To stop data capture, press the spacebar, Enter or Stop on the window status line.
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4-3-1 Recording Parameters

Recording parameters are determined by the Capture settings. To alter these settings:

1. Select Options from the Main Menu, then Capture.... A dialog box for setting capture (i.e., record)
parameters is presented, as in the following figure.

Capture Setup ? %
Channels Sampling (Hz) >~
Active A Length (sec) 8=
Channel 1 @ @ 11025 [ Trigger
Level (at 60 o
[[Jchannel 2 (O 22050 =
(O 44100 Length (msec 80 3
O Memory (mse 200 :
[Isingle Pass

[Juse Scroliing Display

Input Device

[ Nasometer II Model 6450 v ‘ Setup

Cancel

o

Figure 15. Multi-Speech capture parameters.

CSL4500 Device Setup 2] x|
u

12dB Boost (Analog) Left |Ch1 =

[ Channels 1+2 Right [che =
Ch Is 3+4

L{Bionesis37 Delay (msec) 0

Recalibrate | Advanced... |

[~ Echo During Capture

Cancel

[

Figure 16. Recording Parameters

4-3-2 Signal Options

The Options menu accessed via the Capture allows configuring of the following recording parameters:
¢ Input Channel(s) - Specifies the hardware input channel(s).

o Active Channel - Select input channel (s) to capture. If Display all channels is turned on when
capturing a multi-channel signal, the active window is divided into multiple panes during data
capture, one for each selected input channel. When capturing only one channel of data, the data
from the input channel is automatically monitored.

¢ Sampling Rate - Sets the number of samples per second that will be acquired during analog-to-
digital conversion of a signal.

e Length (sec) — Sets the desired length of a recording in seconds from 1 to 3,600 (1 hour).

e Single Pass — Select Single Pass to stop your recording after the time specified in Length (sec)
is reached. Recording will otherwise continue until stopped.

e Scrolling Display - If the program is set to display the waveform in the active window during
capture, then you can specify a scrolling or a stationary display.
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o Trigger - Specifies whether data capture begins immediately when Record is selected, or begins
when the decibel level selected below is reached.

e Trigger Level - In an input trigger is used for data capture, specifies the energy level of the data
needed to trigger data capture, in dB. The specified energy level must be maintained for the
duration of the trigger buffer (set by Trigger Length) for triggering to take effect.

o Trigger Length - If an input trigger is used for data capture, specifies the length of the trigger
buffer, in msec. This buffer length can be between 20 and 1000 msec, in intervals of 20 msec.
Note that the capture length setting must be at least twice as long as the trigger length.

o Trigger Memory - If an input trigger is used for data capture, specifies the amount of data prior
to triggering that is used for real-time analysis, in msec. Trigger Memory must be greater than
or equal to Trigger Length, and must be less than or equal to half the capture length.

4-3-3 Input Device Options

The lower left of the same Options and Capture Window lets you select the data acquisition device and if
using equipment supplied by PENTAX Medical (CSL Users) allows for additional options to be configured.
To select a data acquisition device:

1. At the Options menu, select Capture.

2. Select the desired input device from the dropdowns on the bottom of the window.

3. If PENTAX Medical supplied CSL box, the Setup box will be clickable, and display the options below:
4

If using a PENTAX Medical hardware device, you can set the input device options by clicking the
Setup box to the right of the Input Device dropdown box. Refer to the device options for your
PENTAX Medical hardware.

4-3-4 Speak Options

To configure options related to data acquisition:
» At the Options menu, select Speak.
You can set the following Signal data acquisition:
¢ Mode - Selects stereo or mono output mode.
e Muting - Specifies if one of the output channels should be muted.

¢ Repeat Delay - Specifies whether to repeat audio output more than once, and if so, how long to
pause between repetitions, in msec.

o Report - Specifies whether the cursor will scroll through the data during audio output.

e Splice - When two ranges of data are selected for audio output, Splice specifies whether to
divide the two ranges together so that there is no delay between them, or with a silent pause
the length of the gap between selected ranges.
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4-3-5 CSL Device Options

For data capture using CSL 4500b hardware, you can set the following device-specific capture options:
To configure device options:
1. At the Options menu, select Capture.

Click Setup to the right of the input device dropdown.

3. Select your CSL 4500b from the dropdowns on the bottom of the window.
The options below will be available to configure

Note CSL 4500b hardware requires that the digital recording device be in play
mode before data capture is started, in order for the digital sampling rate to be
detected. Refer to Appendix A, Installation of CSL Main Program and Multi-Speech
for more information on using an external recording device with CSL.

o Use Digital Input - Specifies digital input from DAT recorder or other digital recording device
with S/P DIF interface capability. If Use Digital Input is enabled, the 12dB Boost (Analog) option is
disabled.

e 12 dB Boost (Analog) - Increases the input level by 12 decibels of sound pressure (dB SPL) for
the selected pairs of channels. Note that these settings are disabled if the Use Digital Input
checkbox is selected.

e Echo During Capture - \When the Echo During Capture checkbox is selected, the input
source can be monitored via the output source during data capture. Use this option to listen to
the signal during tape input. When the checkbox is clear, the input source cannot be monitored
during data capture.

e Echo Left - Specifies which channel of input data is echoed to the left output channel when
Echo During Capture is turned on. Select one of the available input channels from the list. Note
that both the left and right output channels could echo the same input channel of data.

o Echo Right - Specifies which channel of input data is echoed to the right output channel when
Echo During Capture is turned on. Select one of the available input channels from the list. Note
that both the left and right output channels could echo the same input channel of data.

e Echo Delay - Sets the delay duration, in msec, when Echo During Capture is turned on. The
delay can be set from 0 msec to a maximum of 1000 msec, in increments of 1 msec. Type a
value in the edit box or click the up arrow or down arrow in the spinner box to increase or
decrease the current setting in increments of 1 msec.

o Recalibrate - Used to recalibrate DC offsets of the A/D and D/A converters. Calibration occurs
automatically when the driver first loads. Recalibration is recommended 15 to 30 minutes after
your computer has been turned on.
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Listening to a Signal

The available speak operations include speaking part or all of the signals.

1. To play all of the signal, select Speak on the Main Menu, then All Data. You will hear the entire
stored signal spoken through the multimedia sound system.

2. During data playback, the active window status line is replaced with a Progress meter, a VU meter, a
Stop button, and a Pause button. The data cursor can move through the waveform during audio
output, and a Scope Window can be displayed beside the active window, depending on the audio
playback parameters and signal display options.
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Figure 17. Figure 4.1: Window A and the Scope Window during audio playback.

%] Note To toggle the Scope Window, select Window - Options > Waveform.

3. Next, select Speak, then Selected Data. This will speak the portion of data selected (and
highlighted) from the signal in the active window. Alternatively, you can use [F4] to speak only the
selected portion.

4-4-1 Saving a Signal

The CSL Main Program and Multi-Speech support several audio file formats. To save the recorded
waveform data:

1. Click on the title of Window A to activate it.

2. Click File then select Save or press the [Ctrl+S] keys.

3. A Save As box is displayed.

1 Save Data X

« A | « Public > Public Documents > Multi-Speech > data > v O Searchds »

demo 710:50 AM

testlnsp
testtone.nsp

. Local Disk (C)
2 DVD RW Drive (T
= DATA(F)

File name: ||

Saveas type: | CSLsignal files (*.nsp) v

A Hide Folders Cancel

Figure 18. Save As dialog box.

The default file format is a CSL signal file (*.NSP). Audio only can be saved to RAW and WAV
formats, but analysis, tags, and channels beyond two will not be captured. Use the NSP format for all
files you intend to use with CSL Main Program, Multi-Speech, or other PENTAX Medical Speech
Software.
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4-4-2 DataTypes

Three types of data appear or can bbe generated in the application, Waveform Data, Analysis Data, and
Transient Data.

Waveform Data

Waveform data is the basis from which analysis and transient data are drawn, a visual display of the
sound captured without modification.

Analysis Data

Analysis operations can be performed once waveform data have been displayed in the source window.
Analysis data resulting from the analysis operations can be one of the following types.

e | PC-based Frequency Response (LPC)
e |LPC Waterfall Array (LPCW)

e FFT-based Power Spectrum (FFT)

o FFT Waterfall Array (FFTW)

e Long-Term Average Power Spectrum (LTA)
e |nverse Spectrum (CEPSTRUM)

e Spectrogram (SPG)

e Formant History (FMT)

e Voiced Period Marks (IMPULSE)

e  Pitch Extraction (PITCH)

e Energy Calculation (ENERGY)

The type of analysis data will be reflected in the window title at the top left corner of the window. The
title of each analysis type is recorded in the bracketed information above. All analysis data can be saved
to a file for later processing or plotting, except for the spectrogram and for waterfall arrays.

Transient Data

The only types of transient data are the spectrogram, the FFT waterfall array, and the LPC waterfall array.
Transient data, which are the output of an analysis calculation, are not supported by numerical results or
statistics. Therefore, the data cannot be saved to a file.
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Audio File Formats

The following audio file formats are supported:

CSL Signal File format (.NSP)
Wave Audio File format ((WAV)

A number of Headerless Audio File formats (.RAW):

e i) 16-bit PCM

e i) 16-bit PCM (byte swap)

e i) 8-bit PCM

o iv) y-Law (MU-Law)

o v)Alaw

e vi) Dialogic ADPCM

vii) Intel ADPCM

CSL Signal File Format Features

e File Extension: NSP
Maximum Number of Channels: 8
Tags In Data: YES
Comment Field: YES

Wave Audio File Format Features

e File Extension: WAV
Maximum Number of Channels: 2
Tags in Data: NO
Comment Field: NO

Headerless Audio File Format Features

e File Extension: RAW
Maximum Number of Channels: 1
Tags In Data: NO
Comment Field: NO

PENTAX

MEDICAL

The data format and sampling rate must be specified before headerless audio files can be loaded or
saved. If the wrong format is specified when opening a raw data audio file, the results are garbage. If the
wrong sampling rate is specified, the data are spoken at the wrong speed (i.e., too fast or too slow).

It is recommended that headerless audio files be stored in separate folders that identify the file type and
subfolders that identify the sampling rate (for example, create a “MU-LAW" folder which contains
folders named “10000", “11025", etc.).
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4-4-3 Loading Saved Data from a File

Audio files in NSP format, WAV, and RAW can be opened and analyzed in the CSL Main Program and
Multi-Speech.

To load and review signal information for a saved file:

1. At the Window menu, select New to open a new, empty window.

Files can be loaded into any Window, though doing so in one containing data will prompt you to
confirm if you wish to purge the window and replace with the saved data.

2. Navigate to the desired file, or if familiarizing yourself with the application, the sample file
“joe_took.nsp” in the folder data and subfolder demo.

3. Confirm the name of the file you opened appears in the blue header bar of the active Window, and
that its waveform pattern appears inside the Window. In the image below, the file “joe_took.nsp” is
open and ready for use.

X
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Timelsec)

[l ! ! 1 1 | ! 1 1 ! 10 1 1 1 1 1 1 1 1
1]
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Figure 19. The demo file “joe_took.nsp,” loaded from disk.
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4-4-4  Signal Information

To view details about a file or recording including channel specifications, visibility of IPA Transcription and
Voiced Impulse Marks:

» Right click within the active window and select Information to view the file's Signal Information,
shown below for “joe_took.nsp”.

Signal Information ? X
Name Creation Date
C:\...\Public\Documents\Multi-Speech\data\demolj Jan 07 18:47:07 1999
Channel Channel Information

@1 Sampling Rate (Hz)| 12500

4 Length (pts)| 23375

B IPA Transcription

: Voiced Impulse Marks E

7 Tags

: Palatometer Data Cancel
Comment I

This file corresponds to the user file IMCRUMP

Figure 20. Signal Information window for “joe_took.nsp”

If you speak this file, you will hear a male voice saying, “Joe took father’s shoe bench out.”

4-4-5 One-Click Speak

The playback cursor lets you begin playing a recording by clicking the desired point within the waveform.
To Speak data using the playback cursor.
1. Do one of the following:

e At the Speak menu, select Hold Mouse Down to Speak.

e At the toolbar, click the Speak from Mouse Mode toolbar button (EE.

The data cursor changes to a “playback” cursor, which looks like a megaphone. The toolbar
button will appear pressed down while Speak from Mouse Mode is active.

2. Press and hold down the Left mouse button in the active window to speak the waveform data
associated with the window.

3. Audio output begins from the location of the mouse click
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4-4-6 Speak Ranges

You can Speak (play) recorded waveform data in whole or in specified ranges beginning from various
points within the active window.
To review Speak Options before playing:

1. At the Options menu, select Speak.

Speak Options ? X
Mode Repeat Delay
(® Mono (® No Repeat [] splice output intervals
(O stereo (O Continuous Report output location
. O 100 msec (O In active window
Muting O (® In source window
@ off s (O All linked windows
OlLeft (C) 500 msec
Output Device

v Setup
Cancel

Figure 21. Speak Options Menu
2. Select an output device and edit parameters as needed.
Setup provides additional playback options which vary based on the output device being used.
To speak all data in the active window:
» At the Speak Menu, click All Data. The whole of the data in the active window will play.
To speak only the selection between the blue segment markers:
» At the Speak Menu, click Displayed Data.
The section identified by blue segment mark plays.
To speak the waveform data currently displayed in the active window:
» At the Speak Menu, click All Data.
The whole of the data in the active window will play.
To speak the data from the start to the current data cursor location:

» At the Speak menu, click From Start to Cursor.
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4-4-7 Spliced and Gated Data

Data can be played with no pause between the segments (spliced), or played with a pause equal to the
length of the excluded data (unspliced or gated). This section covers ranges and the splicing and gating of
audio data.

To identify and speak two ranges of data:
1. Place the two blue segment markers around a range of data you wish to exclude.
The area not included in the selection makes up your two ranges.
2. Choose to Speak the data spliced (no pause) or gated (pause equal to omitted section)

e To speak the data without a pause, at the Speak menu, choose All But Selected (Spliced).
Both sections will play back-to-back.

e To speak the data with a pause (gated), at the Speak menu, choose All But Selected (Unspliced).
A blank section equal in length to the omitted data takes its place when you Speak the data.

3. To return the mouse to normal data cursor mode do one of the following:
e At the Speak menu, select Hold Mouse Down to Speak to clear the checkbox.
e At the toolbar, click the Speak from Mouse Mode button (ﬂ’: while it is in the pressed state.

The normal mouse cursor returns, and the ﬂ;fl': is no longer depressed.

@ Note Speak from Mouse Mode must be activated and deactivated for each window that
supports speech output.

4-4-8 Output Device Options

The output device can be a standard multimedia audio card, or it can be one of several audio devices
provided by PENTAX Medical. Output device options are set separately for each hardware type. Specify
the output device by selecting an available hardware device from the Output Device dropdown box in the
Signal D/A Options dialog box.

If you are using the PENTAX Medical CSL 4500b hardware device, you can set the output device options
by clicking the Setup box to the right of the Output Device dropdown box. If using a multimedia audio
card or any other PENTAX Medical hardware device, the Setup box to the right of the Output Device box
is disabled.

For data output using CSL 4500b hardware, you can set Digital Output, which allows selection of analog

output or digital output to a digital recording device with file transfer or S/P DIF interface capability when

using the CSL 4500b hardware. Note that if digital output is selected, the sampling rate of the signal data
must be compatible with the digital recording device. Typical rates are 32000, 44100 and 48000 samples
per second.
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4-5 Generating a Waveform

The CSL Main Program and Multi-Speech allow you to create a waveform signal, with a number of
parameters specified to control the waveform characteristics, and to display the waveform in the active
window.

To generate a waveform:
1. To create a waveform, choose Generate Waveform from the File menu.

2. If the active view is not empty, a warning is displayed that all data will be lost, and you are asked if
you wish to continue. Select Yes to delete the data displayed in the active window and begin signal
generation. If you do not want to lose the data in the active window, select No. You can now
activate a different window, or create a new window, then return to Step 1 to begin signal
generation in the new active window.

A dialog box is displayed in which you can select the signal characteristics.

Once you have selected the desired waveform characteristics, click the OK button. The generated
waveform will be displayed in the active window.

5. You can listen to the signal, and optionally save the signal data in an audio file.

4-5-1 Characteristics of Generated Signal
e Signal Type - Selects the kind of waveform to be generated, which can be a sine wave, square
wave, triangular wave, sawtooth wave, or White Noise.

e Start and End Amplitude - Selects the peak amplitude at the beginning and end of the waveform.
Peak amplitude values are then calculated linearly between the start and end values.

e Start and End Frequency - Sets the starting and fundamental frequency in Hertz of the periodic
waveform to be created. These values are ignored if the waveform type is White Noise. The
fundamental frequency is then calculated linearly between the selected start and end frequencies.

e Sampling Rate - Sets the sampling rate of the waveform, in number of samples per second.
o Phase Angle - Sets the starting phase angle of the waveform, in degrees between 0 and 359.

o Duration - Sets the length of the signal to be created, specified in seconds or in number of sampled
data points.
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4-6  Printout of the Application Window

You can send the current graphics information in the work area to a printer.
To generate a screenshot:
1. From the File menu, select Print/Save Graphic Images, then Print Full Screen Image.

2. A Screen Print dialog box is displayed on the screen. You can add a header to the printout by clicking
the Header checkbox, then entering the desired text in the Header box. Similarly, you can add a
footer to the printout by clicking the Footer checkbox and entering the desired text in the Footer box.

3. Click the Setup button to access a Print Setup dialog box, where you can specify the printer to use,
the page orientation, the paper size and the paper source. Click Font to specify the font to use for the
header and/or footer.

4. After entering any desired header or footer information, specifying the font and setting up the printer,
click Print to send the graphics to the printer. Click Cancel to abort the operation.

4-6-1 Print High-Resolution Image of Active Window

You can send a high-resolution graphic image of the active window to a printer.

To print the active window:

1. From the File menu, select Print/Save Graphic Images, then Print Active Window Image.
A Print Setup box is displayed.

2. Specify the printer, paper size, and page orientation, then click OK to dump a graphic image of the
contents of the active window to the printer, or click Cancel to abort the operation.

3. The high-resolution graphic image is centered on the printed page.

4-6-2 Save High-Resolution Image of Active Window

You can save a high-resolution graphic image of the active window to a file. The CSL Main Program and
Multi-Speech support a number of graphic file formats, including bitmap (.bmp), the Joint Photographic
Experts Group (JPEG) format (.jpg); graphics interchange format (.gif), and portable network graphics
(.png).

To save an image of the active window:

1. From the File menu, select Print/Save Graphic Images, then Save Active Window Image.

2. A Save Window Image dialog box is displayed on the screen.

3. Access the folder to save the image file in, using the Create New Folder feature if necessary.

4

You can save the graphic in BMP, JPG, GIF, or PNG file format. Select the type of file you wish to
save from the Save As Type box.

5. Enter a name in the File Name box.
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The size of the saved image is reported at the bottom of the dialog box, in pixels, inches, or
centimeters (cm). Optionally adjust the size of the graphic by modifying the Height and/or Width
values. Note that these values are constrained to stay in their original proportion to one another. If
you adjust the height of the image, the width changes in relation to the original aspect ratio, and vice
versa. Alternatively, when the image size is reported in inches or centimeters, adjust the size of the
saved file by increasing or decreasing the dots per inch (DPI) resolution. A smaller resolution
produces a smaller graphic image, and a larger resolution produces a larger graphic image.

Click the Save button to save the file or select Cancel to exit the file saving routine without saving
the file.

Configuration Files

Configuration files allow you to save and switch between commonly used arrangements of windows and
parameter settings. You can always revert CSL and Multi-Speech to their factory interface settings as
desired. All changes to the Ul are stored in a temporary location, which can be saved as a configuration
file at any time.

4-7-1 Save Configuration to User File

Configurations can be saved to the user files which opens on launch, or in a custom named file that can
be loaded as desired. To save a configuration to the user file:

1.

Ensure that “USER.XML" appears at the lower right of the application window, next to where the
source and active windows are listed.

o |f a different filename is displayed, exit the application and then restart. The “USER.XML"
configuration file is loaded at launch and will display after restarting the software.

At the File menu, select Configuration Files, and Save (Update) the User Configuration File.
The current configuration will be saved to the user file and will appear each time the application is
launched. Exit and restart the application to ensure your changes are saved.

Note You will receive an error message if the currently active configuration file is not
USER.XML. In this event, exit and restart the software, which will load the default user
file.
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4-7-2 Activating Configuration Files

Note: \When you reset the CSL Main Program or Multi-Speech, existing windows are deleted
and all data are lost. Before executing any of these commands, you should save any data that
you want available at a later time to disk storage.

At any time, you can reset the CSL Main Program or Multi-Speech to the default (factory delivered)
configuration:
» At the File menu, select Configuration Files, Reset User Configuration to Factory Settings.

This will delete both the permanent and temporary copies of the user configuration file, if it exists,
before redrawing the work area with the default layout. A new temporary file is created to store all
parameter changes made, which can be written to a permanent user configuration file.

You can reset the CSL Main Program or Multi-Speech to the work area layout and parameter settings
defined in the user configuration file, if it exists.

> Select Reset (to the User Configuration) from the File menu.

The temporary user file is deleted and the user configuration file becomes the active initialization file.
A new temporary user file is created to store all parameter changes made, which can be written to a
permanent user configuration file.

If you have created other configuration files, you can reset the CSL Main Program or Multi-Speech to any
saved configuration:

» Select Configuration Files, Reset to an Alternate Configuration from the File menu.

The named configuration file becomes the active file, and the configuration file box on the status line
is updated to display the name of this file. Any subsequent changes to the work area layout or
parameter settings are written to a temporary copy of this active file until specifically saved.

In each case, a warning message is displayed before the CSL Main Program and Multi-Speech
configuration is reset. Click Yes to continue with the operation; click No to cancel the request to
reset.

4-7-3 Saving Configuration Files

Note that all parameter setting changes you make are saved in a temporary initialization file until
specifically written to the active file, which is identified in a box on the status line. Thus, you can discard
the changes when the session ends, so that each session starts from the same configuration.

To save the settings in the temporary configuration file:

e When the CSL Main Program and Multi-Speech start, a temporary copy of the active configuration
file is created. The active file is usually the user configuration file. When the work area layout or
command parameter settings are changed, these changes are written to this temporary file.
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e You have the option of saving changes stored in the temporary user file to the permanent user
configuration file. Select Configuration Files, Save (Update) the User Configuration File from
the File menu. The current window layout and parameter settings are copied from the temporary file
into the user configuration file. Note that if the user configuration file is not active, an error message
is returned.

e You can create a number of configuration files, each designed to configure the CSL Main Program
and Multi-Speech for a specific task. These configuration files can be used, for example, to define
the work area layout and program variables for use in a macro.

3. Save the changes in the temporary file to a configuration file other than the active file by selecting
Configuration Files, Save a New Alternate Configuration File from File menu. Enter a
filename and click Save to store the current settings in that file.

4-7-4 Default Configuration

The default program configuration is written to the registry when the CSL Main Program and Multi-
Speech is installed. These factory settings are never altered by the CSL Main Program and Multi-Speech.
When you run the CSL Main Program and Multi-Speech, all parameter setting changes made in the
session are stored in temporary memory. You have the option of saving these changes to a permanent
user configuration in the registry.

If you do not save the new settings selected during a session, the changes are discarded when you exit
the CSL Main Program and Multi-Speech. This allows each session to start from the same configuration.

Each time a command is executed, the CSL Main Program and Multi-Speech first searches for any
required parameter settings in the temporary memory store. If the required settings are not found, the
CSL Main Program and Multi-Speech looks next in the user settings, if it exists, then finally in the factory
settings.

To save the current settings for use in the future:
» Select File from the Main Menu. Then select Save (Update) the User Configuration.

The current program settings are saved to a user configuration section. These settings are now
available for use in future sessions.

4-7-5  Restore the Factory Settings

To restore CSL Main Program or CSL to the default factory settings:
» At the File menu select Reset User Configuration to Factory Settings.

The user configuration settings and the session settings held in temporary memory are discarded.
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4-8  Adjust Signal Offset

You can remove any DC offset, or “float,” that can be generated by a multimedia audio card. The DC
offset value can be calculated automatically from the waveform data and subtracted from the amplitude
values in the data, or a manually specified offset value can be applied.

Automatically calculate and adjust the DC offset:
1. Capture waveform data into the active window.

2. Ensure that the offset adjustment parameters are set for automatic calculation of the DC offset
value. This can be done by selecting Editing, Signal Offset from the Options menu to display a
box in which you can view and change these parameters.

3. To compute and subtract the DC offset, select Adjust Signal Offset from the Edit menu, and then
select the range of waveform data to use for the calculation and adjust. This can be All Data, the
Selected Data or the Displayed Data in the active window.

4. The waveform in the specified range is examined to determine the offset in that range, and this
offset value is subtracted from the amplitude values in the waveform.

Manually adjust the DC offset:
1. Capture waveform data into the active window.

2. Ensure that the offset adjustment parameters are set to apply a manually specified DC offset value.
This can be done by selecting Editing, Signal Offset from the Options menu to display a box in
which you can view and change these parameters.

3. To adjust the DC offset, select Adjust Signal Offset from the Edit menu, and then select the range
of waveform data to use for the calculation and adjust. This can be All Data, the Selected Data or
the Displayed Data in the active window.

4. The manually set offset value is added to the amplitude values in the specified range of the
waveform. Note that amplitude values will
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5 Speech Pathology Data Analysis

This section discusses the many forms of data analysis you can conduct with CSL and Multi-Speech and
how to properly conduct them. The various options and configurations for each analysis are covered prior
to the analysis itself.

5-1 LPC Frequency Response

Before conducting an LPC Analysis, ensure the options are set to meet your needs:

1. At the Options menu, select Analysis, then LPC Frequency Response.

2. In the window which appears, the options below can be configured:

MUODO0000700

Frame Length - Specifies the length of the frame of data to be analysed when performing pitch-
asynchronous analysis. During pitch-synchronous analysis, this variable is used for data in
voiceless regions only, and the voiced regions are analysed using a frame length determined by
the voiced period marks.

Display Range (X-axis) - Specifies the frequency range (X-axis) over which the frequency
response will be displayed. You can choose to display the frequency range as a percentage of
the Nyquist Frequency or as specific upper and lower frequency values.

Filter Order - Selects the filter order, or the number of LPC coefficients to be applied to the
analysis.

Pre-Emphasis - Determines the application of pre-emphasis and the value of the pre-emphasis
factor. A value of 0 means no pre-emphasis.

Display Range (Y-axis) - Specifies the display range setting along the vertical axis in decibels of
sound pressure level (dB SPL).

Analysis Method - Selects the LPC analysis method. You have a choice of the autocorrelation or
covariance methods.

Window Weighting - Controls the application of window weighting to a frame of sampled data
that is to be processed during LPC analysis. Window weighting is applied to reduce the
amplitude of the signal as it approaches a frame boundary. If a rectangular window is selected,
its effect is to apply no window weighting. Window weighting is recommended when using the
autocorrelation method, and the rectangular window is recommended when the covariance
method is applied.

Pitch-Synchronous - Selects calculation of LPC framing from voiced period marks that are
present in the data or from a fixed frame length.

Frequency Report - specifies whether to report the x-axis value at the cursor location in Hz only,
Hz and Bark, or Hz and Mel.
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To conduct an LPC Frequency Analysis:

1.

Ensure that a waveform is displayed in the source window. The active window must either be empty
or contain frequency response (FFT or LPC) data:

If voiced period marks (impulse marks) are present in the data, you can perform pitch-synchronous
LPC analysis. In this case, the data between two voiced period marks are fed to the LPC processor
for analysis. Otherwise, frames of data of a fixed length are used.

Before generating the frequency response, set up the LPC analysis parameters. This can be done by
selecting Analysis, LPC Frequency Response from the Options menu to display a box in which you
can view and change these parameters.

Choose LPC Frequency Response, LPC Frequency Response at Cursor from the Analysis menu to
create a frequency response of the data at the cursor location.

The frequency response for the specified location is drawn in the active window, and the range of
data (frame) used to produce the LPC is highlighted in the source window. Numerical results and
result statistics can now be displayed, and optionally printed and saved, or copied to the clipboard
then pasted into a spreadsheet.

b-2 LPC Waterfall Analysis

Before conducting an LPC Waterfall Analysis, ensure the options are set to meet your needs:

1.
2.

At the Options menu, select Analysis, then LPC Waterfall Analysis.
In the window which appears, the options below can be configured:

e Analysis Method - Specifies the LPC analysis method. Choices are the Autocorrelation method
or the Covariance method.

o Filter Order - Specifies the filter order, or number of LPC coefficients to be applied to the
analysis.

¢ Pitch-Synchronous - Specifies calculation of LPC framing from voiced period marks (voiced
period marks) that are present in the data or from a fixed frame length. If pitch-synchronous
analysis is selected and voiced period marks are in the source signal data, pitch-synchronous LPC
values are computed; otherwise, fixed-frame LPC analysis is performed, with the size of the
analysis frame determined by the setting for Frame Length.

e Pre-Emphasis - Determines the application of pre-emphasis and the pre-emphasis factor. If a
value of O is entered, no pre-emphasis is applied.

¢ Window Weighting - Controls the application of window weighting to each frame of sampled
data that is processed during LPC analysis. Window weighting is applied to reduce the amplitude
of the signal as it approaches a frame boundary. If a rectangular window is selected, its effect is
to apply no window weighting. A Blackman or Hamming window is recommended for speech
processing.
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LPCW Options: Framing Tab
From the Framing Tab, set the following LPCW options:

e Frame Length - Specifies the length of each frame of data to be analyzed when performing fixed
frame (pitch-asynchronous) analysis. Frame length can be expressed in milliseconds or in number of
sampled data points. During pitch-synchronous analysis, this variable is used for data in the voiceless
regions only, and the voiced regions are analyzed using a frame length determined by the voiced
period marks in the data.

e Frame Advance - Specifies the frame advance for fixed-frame LPC calculation. The frame advance
can be expressed in milliseconds or in number of sampled data points. Frame advance is
independent of frame length, so the analysis results can be for contiguous or overlapping frames, or
can provide a small sample of LPC information for the data.

LPCW Options: Display Tab
From the Display Tab, set the following LPCW options:

o Display Range (X-Axis) - Specifies the frequency range (x-axis) over which the LPC frequency
responses are displayed. The frequency range can be displayed as a percentage of the Nyquist
Frequency or as specific upper and lower frequency values.

e Display Range (Y-Axis) - Controls the display range along the y-axis, in decibels of sound pressure
(dB SPL).

o Skew Angle - Specifies the angle of the waterfall display to skew to the left or to the right. The
window is divided into four quadrants of equal size. When set to skew right, the start frame is drawn
in the bottom left quadrant and subsequent frames are drawn behind it and angled up and to the
right. When set to skew left, the start frame is drawn in the bottom right quadrant and subsequent
frames are drawn behind it and angled up and to the left.

e Start Frame - Specifies whether the first or last frame of the analysis results is plotted at the front
of the waterfall array. Frames are plotted consecutively on the z-axis from first to last or from last to
first, with the start frame plotted in the lower left or right quadrant of the window, depending on the
setting for Skew Angle.

To create an LPC Waterfall Display:

1. Ensure that a waveform is displayed in the source window. The active window must be empty prior
to command execution.

2. If voiced period marks (impulse marks) are present in the waveform data, you can perform pitch-
synchronous analysis. In this case, the data between two voiced period marks is used for analysis.
Otherwise, frames of data of a fixed length are used.

3. Before generating the LPC waterfall display, set the LPCW analysis parameters. To do this, select
Analysis, LPC Waterfall from the Options menu to display a box in which you can view and change
these parameters.
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4. To generate the waterfall display, choose LPC Waterfall from the Analysis menu. A submenu
appears in the work area giving you the option to generate the LPC waterfall display from all the
source data (All Data), a selected region of the source data (Selected Data), or the displayed data
(Displayed Data). Select the range of data you want to analyze.

5. During the analysis, a dialog box appears in the work area, telling you which frame is being
processed and the total number of frames that will be processed, and giving you the option to Stop
Processing.

6. The LPC Waterfall display for the specified range is drawn in the active window, and the first frame
of the analysis results is highlighted. Depending on the setting for LPCW Start Frame, this first frame
can be plotted at the front or back of the array. The values in the x-axis, y-axis, and z-axis boxes on
the window status line report the frequency (Hz), energy (dB), and time (sec) values at the data
cursor in the highlighted frame. Use the [Up] arrow key to scroll forward in time on the z-axis,
highlighting each frequency response (from first to last) in turn, and use the [Down] arrow key to
scroll backward in time on the z-axis. Alternatively, click the mouse on the z-axis (time axis) to
highlight a specific frame.

7. The output of the LPC Waterfall analysis is not supported by numerical results or result statistics.

5-3 FFT Power Spectrum

From the Options menu, select Analysis, then FFT Power Spectrum. You can set the following FFT
Analysis options:

e Analysis Size - Specifies the number of coefficients in the FFT to be computed during analysis.

¢ Window Weighting - Controls the application of window weighting to a frame of sampled data that
is to be processed during FFT analysis. Window weighting is applied to reduce the amplitude of the
signal as it approaches a frame boundary. If a rectangular window is selected, its effect is to apply no
window weighting. A Blackman or Hamming window is recommended for speech processing.

¢ Smoothing - The power spectrum can be displayed in block mode or point mode, with a smoothing
factor optionally applied to the spectral coefficients in point mode. Smoothing the energy in the
frequency domain of the power spectrum is done in order to suppress any harmonic ripple present in
the signal. The degree of smoothing to be applied depends upon the harmonic separation in the
signal and upon the frequency resolution of the power spectrum.

e Pre-Emphasis - Determines the application of pre-emphasis and the value of the pre-emphasis
factor. If a value of O is entered, no pre-emphasis is applied.

o Frame Size - Specifies the length of the frame of data to be analyzed. This can be equal to the
number of FFT coefficients (analysis size), can be delineated by voiced period marks (pitch-
synchronous), or can be another value expressed in number of sampled data points or in
milliseconds. The frame size cannot be greater than the analysis size. If the selected frame size is
less than the FFT analysis size, the frame is padded with zeros.

¢ Display Range (X-Axis) - Specifies the frequency range (X-axis) over which the power spectrum
will be displayed. You can choose to display the frequency range as a percentage of the Nyquist
Freqguency or as specific upper and lower frequency values.

¢ Display Range (Y-Axis) - Controls the display range setting along the Y-axis, in decibels of sound
pressure (dB SPL). If normalization is on, this parameter is ignored.

e Frequency Report - specifies whether to report the x-axis value at the cursor location in Hz only, Hz
and Bark, or Hz and Mel.

To create a power spectrum:
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Ensure that a waveform is displayed in the source window.

The active window must be empty or contain frequency response (FFT or LPC) data prior to
command execution.

If voiced period marks (impulse marks) are present in the data, you can perform pitch-synchronous
analysis.

In this case, the data between two voiced period marks is used for analysis. Otherwise, frames of
data of a fixed length are used.

Before generating the power spectrum, set the FFT analysis parameters. To do this, select
Analysis, FFT Power Spectrum from the Options menu to display a box in which you can view
and change these parameters.

To generate the power spectrum, choose FFT Power Spectrum, FFT Power Spectrum at Cursor
from the Analysis menu to create a discrete power spectrum of the data at the cursor location.

The power spectrum for the specified location is drawn in the active window, and the range of data
(frame) used to produce the spectral slice is highlighted in the source window. Numerical results and
result statistics can now be displayed, and optionally printed and saved, or copied to the clipboard
then pasted into a spreadsheet.

FFT Waterfall Analysis

From the Options menu, select Analysis, then FFT Waterfall. There are a number of FFTW analysis and
display parameters that can be set by the user. Note that the FFT Waterfall Setup box contains three (3)
separate tabs. Click on the appropriate tab for the options you want to set, and then set the desired
parameters.

FFTW Options: Analysis Tab
From the Analysis Tab, set the following FFTW options:

FFT Analysis Size - Specifies the number of coefficients in the FFT to be computed during analysis.
The FFT Analysis Size must be greater than or equal to the Frame Length.

Pre-Emphasis - Determines the application of pre-emphasis and the pre-emphasis factor. If a value
of 0 is entered, no pre-emphasis is applied.

Smoothing Level - The power spectra in the waterfall array can be displayed in Block Mode or
Point Mode, with a smoothing factor optionally applied to the spectral coefficients in Point Mode.
Smoothing the energy in the frequency domain of a power spectrum is done in order to suppress
any harmonic ripple present in the signal. The degree of smoothing to be applied depends on the
harmonic separation in the signal and on the frequency resolution of the power spectrum.

Window Weighting - Controls the application of window weighting to each frame of sampled data
that is processed during FFT analysis. Window weighting is applied to reduce the amplitude of the
signal as it approaches a frame boundary. If a rectangular window is selected, its effect is to apply no
window weighting. A Blackman or Hamming window is recommended for speech processing.
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FFTW Options: Framing Tab
From the Framing Tab, set the following FFTW options:

e Frame Advance - Specifies the frame advance for fixed-frame FFT calculation. The frame advance
can be equal to the number of coefficients in the FFT, or can be specified as a value expressed in
number of sampled data points or in milliseconds. Frame advance is independent of frame length, so
the analysis results can be for contiguous or overlapping frames, or can provide a small sample of
FFT information for the data.

e Frame Length - Specifies the length of each frame of data to be analyzed. Frame length can be
equal to the number of FFT coefficients (FFT Analysis Size), can be delineated by voiced period
marks in the sampled data (Pitch-Synchronous), or can be another value expressed in number of
sampled data points or in milliseconds. The frame length cannot be greater than the FFT analysis
size. If the selected frame length is less than the FFT analysis size, the frame is padded with zeros.

FFTW Options: Display Tab
From the Display Tab, set the following FFTW options:

¢ Display Range (X-Axis) - Specifies the frequency range (x-axis) over which the power spectra are
displayed. The frequency range can be displayed as a percentage of the Nyquist Frequency or as
specific upper and lower frequency values.

e Display Range (Y-Axis) - Controls the display range along the y-axis, in decibels of sound pressure
(dB SPL).

o Skew Angle - Specifies the angle of the waterfall display to skew to the left or to the right. The
window is divided into four quadrants of equal size. When set to skew right, the start frame is drawn
in the bottom left quadrant and subsequent frames are drawn behind it and angled up and to the
right. When set to skew left, the start frame is drawn in the bottom right quadrant and subsequent
frames are drawn behind it and angled up and to the left.

e Start Frame - Specifies whether the first or last frame of the analysis results is plotted at the front
of the waterfall array. Frames are plotted consecutively on the z-axis from first to last or from last to
first, with the start frame plotted in the lower left or right quadrant of the window, depending on the
setting for Skew Angle.

The CSL Main Program and Multi-Speech allows you to generate a series of discrete power spectra
using the Fast Fourier Transform (FFT) algorithm, taking frames of waveform data in a specified range in
the source window, and displaying the resulting power spectra in a waterfall array in the active window.

To create an FFT Waterfall Display:

1. Ensure that a waveform is displayed in the source window. The active window must be empty prior
to command execution.

2. If voiced period marks (impulse marks) are present in the waveform data, you can perform pitch-
synchronous analysis. In this case, the data between two voiced period marks are used for analysis.
Otherwise, frames of data of a fixed length are used.
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Before generating the FFT waterfall display, set the FFTW analysis parameters. To do this, select
Analysis, FFT Waterfall from the Options menu to display a box in which you can view and
change these parameters.

To generate the waterfall display, choose FFT Waterfall from the Analysis menu. A submenu
appears in the work area giving you the option to generate the FFT waterfall display from all the
source data (All Data), a selected region of the source data (Selected Data), or the displayed data
(Displayed Data). Select the range of data you want to analyze.

During the analysis, a dialog box appears in the work area, telling you which frame is being
processed and the total number of frames that will be processed, and giving you the option to Stop
Processing.

The FFT Waterfall display for the specified range is drawn in the active window, and the first frame
of the analysis results is highlighted. Depending on the setting for FFTW Start Frame, this first frame
can be plotted at the front or back of the array. The values in the x-axis, y-axis, and z-axis boxes on
the window status line report the frequency (Hz), energy (dB), and time (sec) values at the data
cursor in the highlighted frame. Use the [Up] arrow key to scroll forward in time on the z-axis,
highlighting each power spectrum (from first to last) in turn, and use the [Down] arrow key to scroll
backward in time on the z-axis. Alternatively, click the mouse on the z-axis (time axis) to highlight a
specific frame.

The output of the FFT Waterfall analysis is not supported by numerical results or result statistics.

5-5 LTA Power Spectrum

From the Options menu, select Analysis, then LTA Power Spectrum. You can set the following LTA
Analysis options:

Analysis Size - Specifies the length of the frame of data to be analyzed, in number of sampled data
points.

Display Range (X-Axis) - Specifies the frequency range (X-Axis) over which the power spectrum
will be displayed. You can choose to display the frequency range as a percentage of the Nyquist
Frequency or as specific upper and lower frequency values.

Display Range (Y-Axis) - Controls the display range setting along the Y-axis, in decibels of sound
pressure (dB SPL). If normalization is on, this parameter is ignored.

Pre-Emphasis - Determines the application of pre-emphasis and the value of the pre-emphasis
factor. A value of 0 means no pre-emphasis is applied.

Smoothing - The power spectrum can be displayed in BLOCK mode or POINT mode, with a
smoothing factor optionally applied to the spectral coefficients in point mode. Smoothing the energy
in values in the frequency domain of the power spectrum is done in order to suppress the harmonic
ripple present in the signal. The degree of smoothing to be applied depends upon the harmonic
separation in the signal and upon the frequency resolution of the LTA power spectrum.

Window Weighting - Controls the application of window weighting to a frame of sampled data that
is to be processed. Window weighting is applied to reduce the amplitude of the signal as it
approaches a frame boundary. If a rectangular window is selected, its effect is to apply no window
weighting. A Blackman or Hamming window is recommended for speech processing.
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To create an LTA Power Spectrum:

1. Ensure that a waveform is displayed in the source window. The active window must either be empty
or contain frequency response (FFT or LPC) data.

2. Before generating the LTA power spectrum, set up the LTA analysis parameters. This can be done
by selecting Analysis, LTA Power Spectrum from the Options menu to display a box in which you
can view and change these parameters.

3. To generate the LTA power spectrum, choose LTA Power Spectrum from the Analysis menu. A
submenu appears in the work area giving you the option to generate the LTA power spectrum on all
the source data (All Data), a selected region of the source data (Selected Data), or the displayed
data (Displayed Data). Select the range of data you want to analyze.

4. During the analysis, a dialog box appears in the work area, telling you which frame is being
processed and the total number of frames that will be processed, and giving you the option to Stop
Processing.

5. The LTA power spectrum for the specified range is drawn in the active window, and the range of
data used to produce the LTA power spectrum is highlighted in the source window. Numerical
results and result statistics can now be displayed, and optionally printed and saved, or copied to the
clipboard then pasted into a spreadsheet.

Cepstrum Analysis

From the Options menu, select Analysis, then Cepstrum Analysis. You can set the following Cepstrum
options:

e Time sets the time domain of the quefrency axis (X-Axis) over which the cepstrum will be displayed.
The time display range is in milliseconds. Select the Display All Data checkbox to display all of the
data, or clear the checkbox and enter values in the Minimum and Maximum edit boxes to display a
smaller specified range. Recommended time values are 0.1 and 12.0. When normalization is applied
to this display, it is normalized to the maximum and minimum values found within this range.

o Level sets the amplitude display range (Y-Axis) for the cepstrum display. If normalization is turned
on, the parameter is ignored.

You can generate an inverse spectrum from a power spectrum that was previously generated with either
the FFT or LTA command, taking spectral data from a specified window and displaying the results on a
time (quefrency) axis in the active window.

The inverse spectrum is generated by taking an FFT of the log magnitude values of a power spectrum.
The purpose of the inverse spectrum is to isolate the harmonic energy that is present in a spectrum of
voiced speech, which can be used to determine the fundamental frequency of the voiced signal.

The fundamental frequency can be determined by taking the inverse of the time location associated with
the highest magnitude peak at a time location that is greater than about 4 msec (i.e., a fundamental
frequency that is less than 250 Hz). The magnitude of this fundamental peak is directly related to the
accumulation of harmonic energy in the power spectrum. Other peaks, referred to as “rahmonics”, often
appear at higher time locations and appear to be related to the strength of side lobes in the power
spectrum.
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The examination of the characteristics of the quefrency peaks is also useful to determine the degree of
periodicity of voiced speech. If the signal is predominantly periodic, the peak is dominant; if the signal is
aperiodic, then the peak is weak relative to the other energy in the spectrum.

To create an Inverse Spectrum

1. Ensure that a waveform is displayed in the source window. Window B must be the active window
and must be empty or contain frequency response (FFT or LPC) data. Window C must be open and
empty.

2. Generate a power spectrum using the FFT or LTA analysis routine, placing the data in Window B.

Before creating the power spectrum, ensure that you are performing an asynchronous (or fixed
frame) analysis and that the frame length is set to a length of at least two pitch periods, so that the
harmonic ripple is clearly displayed in the spectrum. In practice, a 1024 point FFT is used for data
sampled at rates between 20K to 25.6K per second, representing a frame duration of 40 to 50 msec.
A 512 point FFT can be applied to lower sampled data rates. You can find out the sampling rate of
the data by selecting Information on Active Window from the Window menu.

Before generating the inverse spectrum, set the Cepstral analysis parameters.
4. Activate Window C to display the inverse spectrum. This window must be empty.

To create an inverse spectrum of the power spectrum in Window B, choose Cepstrum Analysis,
Cepstrum of FFT in Window B from the Analysis menu. The inverse spectrum is displayed in
Window C.

6. Numerical results and result statistics can now be displayed, and optionally printed and saved, or
copied to the clipboard then pasted into a spreadsheet.

7. You can also create a smoothed spectrum from the first 3 msec. of the cepstrum in Window C from
the Analysis menu. by selecting Cepstrum Analysis, FFT of Cepstrum in Window C. The
results are drawn in Window B.

Spectrogram

From the Options menu, select Analysis, then Spectrogram. There are a number of Spectrogram analysis
and display parameters that can be set by the user. The Spectrogram Analysis Configuration box contains
three (3) separate tabs. Click on the appropriate tab for the options you want to set, and then set the
desired parameters.

SPG Options: Analysis Tab
From the Analysis tab, you can set the following Spectrogram Options:

e Analysis Size - Specifies the number of sampled data points per frame that are to be applied to the
spectrogram. The number of data points translates to a spectrogram “bandwidth,” which is
interpreted by the CSL Main Program and Multi-Speech from the frame length and the sampling rate
of the data in the source window.

e |f the source window contains signal data, a Hertz value is reported in the Analysis Size box beside
each points value, along with a message that the displayed bandwidths are for analysis of the current
default source.

e Pre-Emphasis - Determines the application of pre-emphasis and the value of the pre-emphasis
factor. A value of 0 means no pre-emphasis is applied.
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¢ Window Weighting - Controls the application of window weighting to a frame of sampled data that
is to be processed during SPG analysis. Window weighting is applied to reduce the amplitude of the
signal as it approaches a frame boundary. If a rectangular window is selected, its effect is to apply no
window weighting. A Blackman or Hamming window is recommended for speech processing.

SPG Options: Display Tab
From the Display tab, you can set the following Spectrogram Options:

o Display - Specifies the frequency range over which the spectrogram will be displayed. You can
choose to display the frequency range as a percentage of the Nyquist Frequency or as specific upper
and lower frequency values. The recommended maximum frequency is 40% of the sampling rate.

o Frequency Display - Specifies whether the display of the spectrogram will be shown in a
logarithmic scale, linear scale, Bark scale or Mel scale.

SPG Options: Palette Tab
From the Palette tab, you can set the following Spectrogram Options:
e Palette - Selects one of the preset color palettes to be used to display the spectrogram.

e Scale - Displays the decibel range assigned to evenly distributed gray shades or colors used to plot
the relative levels of energy in the spectrogram. You can change any of these values. Alternatively,
enter a minimum and maximum decibel level, and click the Smooth button (to the right) to create a
linear relationship to the values assigned to the interceding shades. Use the scrollbar to raise or
lower the overall color scale-to-gain assignment, to brighten or darken the display.

e Scale Adjustment - Specifies an adjustment in decibels of sound pressure (dB SPL) that is applied
to the color scale of the spectrogram, to lighten or darken the color scale.

In this section you will generate an FFT-based three-dimensional spectrogram.

A power spectrum is computed for a series of frames of sampled data in the specified range. Each
computed spectrum is displayed as a single vertical column, with frequency on the vertical axis and
energy expressed in darkness or color gradients. Time is represented on the horizontal axis, and is

represented by one spectrum of a frame of sample data for each pixel column in the window.

To create a Spectrogram:
1. Ensure that a waveform is displayed in the source window. The active window must be empty.

2. Before generating the spectrogram, configure the SPG analysis parameters. Select Analysis,
Spectrogram and All Data, Selected Data, or Displayed Data from the Options menu to display
a box to can view and change these settings.

3. During the analysis, a dialog box appears in the work area, displaying the number of the frame being
processed and the total number of frames. You can abort the analysis by clicking the Stop
Processing box, or pressing the Enter key before analysis is complete.

%] Note: The spectrogram for the specified range is drawn in the active window, and
the sampled data that contributes to the spectrogram frame at the cursor location is
highlighted in the source waveform. The output of the spectrographic analysis is not
supported by numerical results and result statistics. You can overlay any time domain
analysis data onto a spectrogram
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Formant History Analysis

From the Options menu, select Analysis, then Formant History. There are a number of FMT analysis
and display parameters that can be set by the user. Note that the Formant Analysis Configuration box
contains four (4) separate tabs. Click on the appropriate tab for the options you want to set, and then set
the desired parameters.

FMT Options: Analysis Tab
From the Analysis Tab, set the following FMT options:

Filter Order - Selects the filter order, or the number of LPC coefficients, to be applied to each LPC
analysis frame.

Pre-Emphasis - Determines the application of pre-emphasis and the value of the pre-emphasis
factor. A value of 0 means that no pre-emphasis is applied.

Analysis Method - Selects the LPC analysis method. You have a choice of the autocorrelation or
covariance methods.

Window Weighting - Controls the application of window weighting to a frame of sampled data that
is to be processed during FMT analysis. Window weighting is applied to reduce the amplitude of the
signal as it approaches a frame boundary. If a rectangular window is selected, its effect is to apply no
window weighting. Window weighting is recommended when using the autocorrelation method, and
the rectangular window is recommended when the covariance method is applied.

FMT Options: Framing Tab
From the Framing Tab, set the following FMT options:

Pitch-Synchronous (Use Voiced Period Marks) - Selects calculation of formant history framing
from voiced period marks that are present in the data or from a fixed frame length.

Unvoiced Frame Size - Specifies the length of the frame of data to be analyzed when performing
fixed frame analysis. During pitch-synchronous analysis, this variable is used for data in voiceless
regions only, and the voiced regions are analyzed using a frame length determined by the voiced
period marks.

Frame Advance - Selects the time, in milliseconds, by which the analysis frame is advanced during
fixed frame analysis. Frame advance is independent of the frame length, so the FMT analysis results
can be for contiguous or overlapping frames, or can provide a small sample of FMT information for
the data. This option is disabled during pitch-synchronous analysis (i.e., Use Voiced Period Marks is
selected).

FMT Options: Display Tab
From the Display Tab, set the following FMT options:

Display Range - Specifies the frequency range over which the formant history will be displayed.
You can choose to display the frequency range as a percentage of the Nyquist Frequency or as
specific upper and lower frequency values.

Bandwidth Limit - Specifies whether to display all formants, or whether to set a threshold value of
the bandwidth, so that formants above the threshold are not included in the graphic display, and are
optionally excluded from the reported numerical results.
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e Energy Limit - Specifies whether to display all formants, or whether to turn off LPC analysis in
frames whose signal energy is less than the set threshold value, so that formants in analysis frames
with energy below the set threshold are not included in the graphic display, and are optionally
excluded from the reported numerical results.

e Only Voiced - Specifies whether to display all formants, or whether to turn off LPC analysis in
frames that are voiceless.

e Show Bandwidth - Specifies whether to display the bandwidth with each reported formant
frequency so that the length of the vertical line represents the bandwidth of the formant, or whether
to display the formant contours as a series of dots.

o Frequency Display - Specifies whether the display of the formant history will be shown in a
logarithmic scale, linear scale, Bark scale, or Mel scale.

FMT Options: ColorTab
From the Color Tab, set the following FMT options:
e Use Large Dots - Specify whether to display the formant history plot using large dots or small dots.

e Contour Colors - Specify the colors to display the formant contours. For improved observation and
editing purposes, a different color can be assigned to each formant. Alternatively, all formants can be
displayed using the window pen color.

The CSL Main Program and Multi-Speech allow you to generate an LPC-based time history formant
display of a range of data in the source window, displaying the resulting formants over time in the active
window.

To create a Time History Formant display:

1. Ensure that a waveform is displayed in the source window. The active window must be empty or
contain a time series of analysis data.

2. Before generating the formant history, set the FMT analysis parameters. Do this at the Options
menu under Analysis, Formant History and All Data, Selected Data , or Displayed Data.

3. Choose Formant History from the Analysis menu. A submenu appears in the work area giving you
a list of analysis range options to create the formant history from. Select All Data to analyze all the
source data, Selected Data to produce a spectrogram of only the selected region of the source
data, Displayed Data for the displayed data, and 1st Sec. of Displayed or 1st 2 Secs. of
Displayed to use only the first one or two seconds of the displayed data.

4. The corresponding formant history for the specified range is drawn in the active window. Numerical
results and result statistics can now be displayed, and optionally printed and saved, or copied to the
clipboard then pasted into a spreadsheet.
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5-9  Voiced Period Marks (Impulse) Options

From the Options menu, select Analysis, then Voiced Period Marks. You can set the following
Impulse Analysis Options:

¢ Analysis Range - Specifies the analysis range setting in Hertz. A narrower range can be set to
selectively examine a particular region of the signal, while a wide analysis range (for example, 50 to
1000 Hz) can be used successfully for most speech. Reducing the range can help to avoid erroneous
selection of harmonic periods in low-frequency signals.

e Location - Governs the location where the voiced period marks are placed during analysis. If Peak is
selected, impulse marks are placed at the dominant amplitude peak at the start of each voiced
period. This could be a negative or a positive peak depending upon the polarity of the signal. If Zero
Crossing is selected, impulse marks are placed at the zero crossing immediately preceding the
dominant amplitude peak at the start of each voiced period.

e Zero Offset - Specifies the zero offset in amplitude to compensate for any DC float that can have
been produced by the hardware. If the signal offset has been previously computed, the resulting
value is automatically used.

You can compute the periodicity of voiced speech in the active window and mark the waveform data at
time locations to separate the voiced periods. These marks are referred to as voiced period marks, or
impulse marks. The process separates the voiced signal into its periodic components, the inverse of

each period being the fundamental frequency, or pitch separation, of the signal as it changes over time.

Note Voiced period marks must be inserted in the waveform data before pitch-synchronous
analysis can be performed on the sampled data.
To display and hide voiced period (impulse marks

Voiced period marks can be present in the waveform but hidden from view unless the settings are
configured to display them. To turn display of voiced period or impulse marks on and off:

1. To display the marks in the active window, select Waveform from the Options menu to display a
dialog box in which you can set the signal attributes to display. Enable the Impulse Marks
checkbox, causing a check mark to appear in the check box.

2. Remove the voiced period marks from the window without deleting them from the waveform data
by clearing the Impulse Marks checkbox in the Signal Display Options dialog box.
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Pitch Contour Analysis

From the Options menu, select Analysis, then Pitch Contour. There are a number of Pitch analysis
and display parameters that can be set by the user. The Pitch Analysis box contains three (3) separate
tabs. Click on the appropriate tab for the options you want to set, and then set the desired parameters.

Pitch Options: Analysis Tab

From the Analysis tab, you can set the following Pitch Options:

Pitch Synchronous Analysis - Specifies pitch synchronous (from impulse marks) or pitch
asynchronous (i.e., fixed frame) analysis. If this checkbox is selected and impulse marks are not in
the signal data, the pitch synchronous analysis process will compute impulse locations and store
them internally. If this checkbox is selected and impulse marks are in the signal, then the impulse
locations in the signal are used. If this checkbox is clear (unselected), fixed frame analysis is
performed using the frame length and frame advance settings specified on the Framing tab.
Interpolation is applied to the pitch analysis results (pitch synchronous or fixed frame) in order to
improve the resolution of the pitch analysis process.

Impulse Location — Specifies the location of the impulse marks computed during pitch synchronous
analysis. Options are at the dominant amplitude peak (which can be negative or positive, depending
on the polarity of the signal) at the start of each voiced period, or at the zero crossing immediately
preceding the dominant amplitude peak at the start of each voiced period. Note that this option is
disabled if the Pitch Synchronous Analysis checkbox is clear (unselected). If Pitch Synchronous
Analysis is selected and impulse marks are already in the signal, this setting is ignored.

Analysis Range - Specifies the analysis range setting in frequency (Hertz) for accepting
fundamental frequency (pitch) analysis results. To avoid possible error, the analysis range should be
close to the expected fundamental frequency range.

Process High Frequency Signal — Specifies analysis of a high-frequency signal. Use this setting to
obtain better results when analyzing some signals from a female or child’s voice. Note that this
option is disabled if the Pitch Synchronous Analysis checkbox is selected.

Pitch Sensitivity — Specifies the sensitivity of the pitch analysis routine. If the pitch analysis does
not produce pitch values in expected locations (giving drop-outs in the analysis), increase the pitch
sensitivity. If the pitch analysis is detecting more pitch values than expected (giving spurious values
in the analysis), decrease the pitch sensitivity. Note that this option is disabled if the Pitch
Synchronous Analysis checkbox is selected.

Smoothing Level - Optionally smooths the pitch contour by replacing the un-smoothed pitch results
with new values that are computed by applying median smoothing to the voiced frames that are
located within a specified time interval that is centered around the start of the current frame. The
duration of the time interval is 50 msec if a Low level of smoothing is selected, 100 msec for
Medium, and 200 msec for High. The number of adjacent frames that is used to smooth each
frame consists of all frames that lie completely within the time interval that corresponds to the
smoothing level selected. Select None to display the un-smoothed pitch results. Note that the Low
radio button is disabled if either the Frame Length or Frame Advance setting is greater than 25 msec.
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Pitch Options: Framing Tab
From the Framing tab, you can set the following Pitch Options:

e Frame Length - During fixed frame (or pitch-asynchronous) analysis, specifies the length of a frame
of waveform data used for computing the fundamental frequency (pitch). Note that this option is
disabled if the Pitch Synchronous Analysis checkbox is selected on the Analysis tab.

¢ Frame Advance - Selects the time, in milliseconds, by which the analysis frame is advanced during
fixed frame analysis. Frame advance is independent of frame length, so the pitch analysis results can
be for contiguous or overlapping frames, or can provide a small sample of pitch information for the
data. The smaller the frame advance is, the more detail about the pitch characteristics becomes
available. Note that this option is disabled if the Pitch Synchronous Analysis checkbox is selected
on the Analysis tab.

Pitch Options: Display Tab
From the Display tab, you can set the following Pitch Options:
o Display Range - Specifies the display range in frequency (Hertz) for the display of a pitch contour. Note

that the display range is set separately for pitch contours displayed on a logarithmic frequency scale or a
linear frequency scale. If normalization is on, this parameter is ignored.

e Draw Dot Contour - Selects display of the pitch plot as a series of dots or as a solid line.

e Use Large Dots - If a dot contour display is selected, specifies whether to display the pitch contour
using large dots or small dots.

e Frequency Scale - Selects display of the pitch contour on a logarithmic or linear frequency scale.

The CSL Main Program and Multi-Speech allows you to compute the fundamental frequency (pitch) of a
range of voiced data in the source window and display the resulting pitch contour in the active window.

To create a pitch contour:

1. Ensure that a waveform is displayed in the source window. The active window must be empty or
contain time domain analysis data prior to command execution.

2. Before generating the pitch contour, set up the pitch analysis parameters. This can be done by
selecting Analysis, Pitch Contour from the Options menu to display a box in which you can view
and change these parameters.

3. If pitch-synchronous analysis is performed, the fundamental frequency values are extracted by
computing the inverse of the time between each voiced period mark (impulse mark) in the data. If
impulse marks are not in the signal when pitch-synchronous analysis is performed, the pitch
synchronous analysis process will compute the impulse locations and store them internally. If
impulse marks are in the signal, then the impulse locations in the signal are used.

4. If pitch-asynchronous (fixed frame) analysis is performed, the fundamental frequency is extracted
directly from the waveform by determining the time intervals between dominant peaks in the
waveform. The waveform is first broken into regular intervals (frames), the duration of which is set
by the user. Note that frame length must be set to at least two pitch periods to achieve good results.

5. Interpolation is applied to the pitch analysis results (pitch synchronous or fixed frame) in order to
improve the resolution of the pitch analysis process.
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To generate a pitch contour, select Pitch Contour from the Analysis menu. A submenu appears in
the work area giving you the option to create a pitch contour on all the data (All Data), the selected
region of the data (Selected Data), or the currently displayed data (Displayed Data).

The resulting pitch contour is drawn in the active window. Numerical results and result statistics can
now be displayed, and optionally printed and saved, or copied to the clipboard then pasted into a
spreadsheet.

Energy Contour Analysis

From the Options menu, select Analysis, then Energy Contour. You can set the following Energy
Options:

Frame Length - Specifies the length of a frame of a data used for energy calculation. This parameter
specifies the frame length in voiceless regions only if pitch-synchronous analysis is used.

Frame Advance - Selects the time, in milliseconds, by which the analysis frame is advanced. Frame
advance is independent of the frame length, so the energy analysis results can be for contiguous or
overlapping frames, or can provide a small sample of energy information for the data. This parameter
is ignored during pitch-synchronous analysis.

Pitch-Synchronous - Selects calculation of energy frames from voiced period marks that are
present in the data (pitch-synchronous) or from a set frame length.

Draw Dot Contour - Selects display of the energy plot as a series of dots or as a solid line.

Use Large Dots - If a dot contour display is selected, specifies whether to display the energy
contour using large dots or small dots.

Smoothing Level - You can optionally apply smoothing to the computed energy values across
adjacent frames.

Display Range - Specifies the display range in decibels of sound pressure (dB SPL) for the display
of the energy contour. If normalization is on, this parameter is ignored. Note that the display range is
automatically adjusted by the energy shift value if the Energy Shift checkbox is selected.

Energy Shift - Specifies whether to shift the calculated energy values by a set shift value, to adjust
the dB values to approximate real-world dB SPL. If the Energy Shift checkbox is selected, the shift
value can be entered in the associated edit box.

You can compute the energy of a range of waveform data in the source window and display the resulting
energy contour in the active window.

The energy operation calculates the sum of the absolute amplitude values in a frame of data divided by
the number of points in the frame. The energy is first computed and then converted to decibels of sound
pressure (dB SPL).
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To create an energy contour:

1. Ensure that a waveform is displayed in the source window. The active window must be empty or
contain a time series of analysis data.

2. Before generating an energy contour, set the energy analysis parameters. This can be done by
selecting Analysis, Energy Contour from the Options menu to display a box in which you can
view and change these parameters.

3. To create an energy contour, select Energy Contour from the Analysis menu. A submenu appears
in the work area giving you the option to create an energy contour on all the data by selecting All
Data, on the selected region of data by selecting Selected Data, or on the currently displayed data
by selecting Displayed Data.

4. The resulting energy contour is drawn in the active window. Numerical results and result statistics
can now be displayed, and optionally printed and saved, or copied to the clipboard then pasted into a
spreadsheet.

Compute, Save, and Print Result Statistics

The CSL Main Program and Multi-Speech can display, save, and print, and save a series of statistical
analyses that are derived from the most recently computed analysis results in the active window.
Statistics and other text data can be copied and pasted to other applications.

To produce result statistics:

1. Ensure that the window contains analysis data. Note that result statistics are not available for
transient data.

2. Several windows containing analysis data can be displayed in the work area at once, and each of
these windows can contain the results of more than one analysis.

3. To display the result statistics for the topmost analysis data in the active window, select Compute
Result Statistics from the Analysis menu.

A dialog box appears in the work area displaying the result statistics.

4. At the Result Statistics dialog box, you can print the results and to save them in a file. You can also
click on the Info button to display a second box containing the summary information and any textual
information that has been entered into the comment field.

5. Remove the Result Statistics dialog box by clicking the Done button.
To save result statistics as a text file:

1. With the statistics displayed, click the Save As button in the Result Statistics box. A Save Results
box is displayed in the work area. The type of analysis is displayed at the top of the box (i.e., Pitch,
LPC, etc.).

2. Select the correct drive and directory location, and enter a file name in the File Name box. The fine
will save with the default *.txt extension.

3. Choose how the columns of information will be separated when the result file is saved to disk
storage. The field separator can be a space, a tab, or a comma. Choose the Tab or Comma option to
format the file for access by a spreadsheet program. Select the Space option to save the file so that
the display is easily read when you send it to the printer or if you intend to edit it at a later date using
any standard text editor.
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In the Contents section, select the information you wish to save in the file. This can include
parameter information, statistics, and numerical results. When saving LPC results, you can save the
frequency response and/or the formants information. When saving FMT results, you can save all
formant/bandwidth values, or can limit the file to formants above a specified bandwidth value.

Once you have selected the information you wish to save and the column separator, click the Save
button to save the data to a results file. Click the Cancel button to close the Save Results box
without saving the data.

To print result statistics

1.

With the result statistics displayed, click the Print button in the Result Statistics box. A Print Results
box is displayed in the work area. The type of analysis is displayed at the top of the box (i.e., Pitch,
LPC, etc.).

In the Margins section, you can enter header and/or footer information, including text, the current
time (%t), current date (%d), and page numbers (%p). The format is left;center;right.

In the Contents section, select the information you wish to print. This can include parameter
information, statistics, and numerical results. When printing LPC results, you can print the frequency
response and/or the formants information. When printing FMT results, you can print all
formant/bandwidth values, or can limit the printout to formants above a specified bandwidth value.

Click the Setup button to select the default printer and access other printing options for the selected
printer. Click the Fonts button to select the font to use, font size, etc.

Once you have selected the information you wish to print (including any header or footer), click the
Print button in the Print Results box. Click Done to close the Print Results box without printing any
information.

To copy result statistics to the clipboard

1.

Click the Copy to Clipboard button to copy all result statistics to the clipboard. The data can then
be pasted into a spreadsheet or other application from the clipboard.

Note that the Formant Result Statistics are displayed across several pages. In this case, only the
statistics on the displayed page are copied when Copy to Clipboard is selected.

5-13 Produce, Save, and Print Numerical Results

You can display, and optionally print and save, the numerical results associated with the topmost analysis
data in a specified window. You can also copy selected numerical results to the clipboard, then paste
from the clipboard to a spreadsheet or other application.

To display numerical results:

1.

Ensure that analysis results data are displayed in a window. Note that numerical results are not
available for transient data.

Several windows containing analysis data can be displayed in the work area at once, and each of
these windows can contain the results of more than one analysis.

To display numerical results for the topmost analysis data in the active window, select Produce
Numerical Results from the Analysis menu.
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A dialog box appears in the work area displaying the numerical results.

You have the option of saving the results in a file or sending the results to a printer. You can also
click on the Info button to display a second box containing the summary information and any textual
information entered into the comment field.

Remove the numerical results box by clicking the Done button.

To save numerical results

1.

With the numerical results displayed, click the Save As button in the Analysis Results box. A Save
Results box is displayed in the work area. The type of analysis is displayed at the top of the box (i.e.,
Pitch, LPC, etc.).

Select the correct drive and directory location, and enter a file name in the File Name box. Unless a
different file extension is specified as part of the file name, a .TXT file extension is appended to the
file name, to identify the type of file.

Choose how the columns of information will be separated when the result file is saved to disk
storage. The field separator can be a space, a tab, or a comma. Choose the Tab or Comma option to
format the file for access by a spreadsheet program. Select the Space option to save the file so that
the display is easily read when you send it to the printer, or if you intend to edit it at a later date using
any standard text editor.

In the Contents section, select the information you wish to save in the file. This can include
parameter information, statistics, and numerical results. When saving LPC results, you can save the
frequency response and/or the formants information. When saving FMT results, you can save all
formant/bandwidth values, or can limit the file to formants above a specified bandwidth value.

Once you have selected the information you wish to save and the column separator, click the OK
button to save the data to a results file. Click the Cancel button to close the Save Results box
without saving the data.

To print numerical results

1.

MUODO0000700

With the numerical results displayed, click the Print button in the Analysis Results box. A Print
Results box is displayed in the work area. The type of analysis is displayed at the top of the box (i.e.,
pitch, LPC, etc.).

In the Margins section, you can enter header and/or footer information, including text, the current
time (%t), current date (%d), and page numbers (%p). The format is left;center;right.

In the Contents section, select the information you wish to print. This can include parameter
information, statistics, and numerical results. When printing LPC results, you can print the frequency
response and/or the formants information. When printing FMT results, you can print all
formant/bandwidth values, or can limit the printout to formants above a specified bandwidth value.

Click the Setup button to select the default printer and access other printing options for the selected
printer. Click the Fonts button to select the font to use, font size, etc.

Once you have selected the information you wish to print (including any header or footer), click the
Print button in the Print Results box. Click Done to close the Print Results box without printing any
information.
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To copy numerical results to clipboard

1. Optionally click anywhere inside the numerical results list box and press the [Ctrl+A] keys to select
all data, then press [Ctrl+C] to copy the numerical results to the clipboard.

2. Alternatively, select one or more columns of results data, then press the [Ctrl+C] keys to copy the
selected columns of data.

3. You can also select individual cells of data by holding down the [Ctrl] key as you click on the data
items, or select a block of data by clicking in a cell (e.g., top left corner of the block to be selected),
then holding down the [Shift] key and clicking another cell (e.g., bottom right corner of block) in the
list box. Cells are highlighted when selected.

4. Atany time, press [Ctrl+U] to unselect all cells, and then optionally select a different range.

After selecting the desired data, press [Ctrl+C] to copy them to the clipboard. The copied data can
then be pasted into a spreadsheet or other application from the clipboard.

6. Note that column headings are not included with the data when they are copied and pasted.
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6 Data Operations

This section covers basic files operations including loading, saving, importing and exporting data, and
taking screenshots of your work.

6-1 Opening a Saved or Demo File

Click within the window you want to open the file in
1. At the File menu, select Open (Load) and navigate to the desire file.
e To open headerless files, type “*.*) in the search field to view files of all types.

2. Click OK to open the file. If the window contains previous data, you will be prompted to confirm you
wish to purge that data. Click Yes if you want to purge and replace or No if you do not.

e |fin step 3 you chose not to purge existing data, at the Window menu, select, Open New
Window and repeat from step 1.

6-2 Saving Waveform Data

To save your work to a file:
1. At the File menu, select Save.
e To open headerless files, type “*.*) in the search field to view files of all types.

2. Click OK to open the file. If the window contains previous data, you will be prompted to confirm you
wish to purge that data. Click Yes if you want to purge and replace or No if you do not.

e |fin step 3 you chose not to purge existing data, at the Window menu, select, Open New
Window and repeat from step 1.

3. In most cases, you will wish to save to the NSP file format. Select the desired folder, and press a
“MU-LAW" folder which contains folders named “10000", “11025", Save

A new file with the name and format specified will be stored to your computer.

@ Note: In the native NSP format, waveform data is stored along with features such as IPA
characters, impulse marks, palatogram information, text in comments will save if saved in
the file. RAW and WAV and headerless files contain only audio.
To save the waveform data in the active window:
1. From the File menu, choose Save.

2. A progress meter is then displayed, showing the progress of the file-saving operation.
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6-3 Using Configuration Files

A default program initialization file is included with the delivery. This factory default file is never altered by
the program. When you run the program, a temporary user file is created which stores all work area
layout and parameter setting changes made. You have the option of saving these changes to a
permanent user configuration file or to another configuration file.

You can also activate other configuration files. Note that all parameter setting changes you make are
saved in a temporary file until specifically written to the active initialization file, identified in a box on the
application status line. Thus, you can discard the changes when the session ends, so that each session
starts from the same configuration.

Each time a command is executed, the program searches for any required parameter settings first in the
temporary copy of the active configuration file, which is identified on the status line. This temporary file
contains any changes that have been made to the work area layout and parameter settings. If the
required settings are not found, the program next looks in the user configuration file, if it exists, then
finally in the factory-delivered default configuration file.

Activating Configuration Files

When you reset the program, existing windows are deleted and all data are lost. Before executing any of
these commands, you should save any data that you want available at a later time to disk storage.

1. Atany time, you can reset the program to the default (factory delivered) configuration by selecting
Configuration Files, Reset User Configuration to Factory Settings from the File menu. This
will delete both the permanent and temporary copies of the user configuration file, if it exists, before
redrawing the work area with the default layout. A new temporary file is created to store all
parameter changes made, which can be written to a permanent user configuration file.

2. You can reset the program to the work area layout and parameter settings defined in the user
configuration file, if it exists. Select Reset (to the User Configuration) from the File menu. The
temporary user file is deleted and the user configuration file becomes the active initialization file. A
new temporary user file is created to store all parameter changes made, which can be written to a
permanent user configuration file.

3. If you have created other configuration files, you can reset the program to any saved configuration by
selecting Configuration Files, Reset to an Alternate Configuration from the File menu. The
named configuration file becomes the active file, and the configuration file box on the status line is
updated to display the name of this file. Any subsequent changes to the work area layout or
parameter settings are written to a temporary copy of this active file until specifically saved.

4. Ineach case, a warning message is displayed before the program configuration is reset. Click Yes to
continue with the operation; click No to cancel the request to reset.
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Saving Configuration Files

Note that all parameter setting changes you make are saved in a temporary initialization file until
specifically written to the active file, which is identified in a box on the status line. Thus, you can discard
the changes when the session ends, so that each session starts from the same configuration.

To save the settings in the temporary configuration file:

1. When the program starts, a temporary copy of the active configuration file is created. The active file
is usually the user configuration file. When the work area layout or command parameter settings are
changed, these changes are written to this temporary file.

2. You have the option of saving changes stored in the temporary user file to the permanent user
configuration file. Select Configuration Files, Save (Update) the User Configuration File from
the File menu. The current window layout and parameter settings are copied from the temporary file
into the user configuration file. Note that if the user configuration file is not active, an error message
is returned.

3. You can create a number of configuration files, each designed to configure the program for a specific
task. These configuration files can be used, for example, to define the work area layout and program
variables for use in a macro.

4. Save the changes in the temporary file to a configuration file other than the active file by selecting
Configuration Files, Save a New Alternate Configuration File from File menu. A standard file
saving box is displayed, allowing entry of the drive, directory location and name for the configuration
file. An INI file extension is appended to the filename, to identify the file type. Click OK to complete
the file save operation. The current window layout and parameter settings are copied from the
temporary file into the named configuration file. Note that writing these settings to a different file
does not change the active configuration file.

Save the Current Settings

The default program configuration is written to the registry when the program is installed. These factory
settings are never altered by the program. When you run the program, all parameter setting changes
made in the session are stored in temporary memory. You have the option of saving these changes to a
permanent user configuration in the registry.

If you do not save the new settings selected during a session, the changes are discarded when you exit
the program. This allows each session to start from the same configuration.

Each time a command is executed, the program first searches for any required parameter settings in the
temporary memory store. If the required settings are not found, the program looks next in the user
settings, if it exists, then finally in the factory settings.

To save the current settings for use in the future:
1. Select File from the Main Menu. Then select Save (Update) the User Configuration.

2. The current program settings are saved to a user configuration section. These settings are now
available for use in future sessions.
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Restore the Factory Settings
At any time, you can reset the program to the default (factory delivered) configuration as follows:
3. Select File from the Main Menu. Then select Reset User Configuration to Factory Settings.

4. The user configuration settings and the session settings held in temporary memory are discarded.

6-3-1 Printout of the Application Window

You can send the current graphics information in the work area to a printer.
To generate a screen dump:
1. From the File menu, select Print/Save Graphic Images, then Print Full Screen Image.

2. A Screen Print dialog box is displayed on the screen. You can add a header to the printout by clicking
the Header checkbox, then entering the desired text in the Header box. Similarly, you can add a
footer to the printout by clicking the Footer checkbox and entering the desired text in the Footer box.

3. Click the Setup button to access a Print Setup dialog box, where you can specify the printer to use,
the page orientation, the paper size and the paper source. Click Font to specify the font to use for the
header and/or footer.

4. After entering any desired header or footer information, specifying the font and setting up the printer,
click Print to send the graphics to the printer. Click Cancel to abort the operation.

6-3-2 Print High-Resolution Image of Active Window

You can send a high-resolution graphic image of the active window to a printer.

To print the active window:

1. From the File menu, select Print/Save Graphic Images, then Print Active Window Image.
2. A Print Setup box is displayed.

3. Specify the printer, paper size, and page orientation, then click OK to dump a graphic image of the
contents of the active window to the printer, or click Cancel to abort the operation.

4. The high-resolution graphic image is centered on the printed page.

6-3-3 Save High-Resolution Image of Active Window

You can save a high-resolution graphic image of the active window to a file. The program supports a
number of graphic file formats, including bitmap (.bmp), the Joint Photographic Experts Group (JPEG)
format (.jpg); graphics interchange format (.gif), and portable network graphics (.png).

To save an image of the active window:

1. From the File menu, select Print/Save Graphic Images, then Save Active Window Image.

2. A Save Window Image dialog box is displayed on the screen.

3. Access the folder to save the image file in, using the Create New Folder feature if necessary.
4

You can save the graphic in BMP, JPG, GIF, or PNG file format. Select the type of file you wish to
save from the Save As Type box.
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Enter a name in the File Name box.

The size of the saved image is reported at the bottom of the dialog box, in pixels, inches, or
centimeters (cm). Optionally adjust the size of the graphic by modifying the Height and/or Width
values. Note that these values are constrained to stay in their original proportion to one another. If
you adjust the height of the image, the width changes in relation to the original aspect ratio, and vice
versa. Alternatively, when the image size is reported in inches or centimeters, adjust the size of the
saved file by increasing or decreasing the dots per inch (DPI) resolution. A smaller resolution
produces a smaller graphic image, and a larger resolution produces a larger graphic image.

Click the Save button to save the file. Select Cancel to exit the file saving routine without saving the
file.

A confirmation box is displayed, asking “Do you really want to exit?”

Select Yes to exit the program, or select No to return to normal program operations.

Source Data

6-4-1 Undo Last Edit in Active Window

To undo the last edit made:

1.
2.

At the Edit menu, choose Undo Last Edit in Active.

Repeat as necessary to reverse prior edits. The number of actions you can Undo is limited only by
the memory available to the application.

@ Note: If there is no waveform data or no edits have been performed within the active

window, the Undo function will have no effect

6-4-2 Copy Source to Active

You can copy waveform data from the source window to an empty active window.

To copy sampled data:

1.

Ensure that a waveform is displayed in the source window. The active window must be empty prior
to command execution.

At the Options menu, select Editing, Copy to display a box containing the current settings, and
adjust the settings as needed to copy what you want.

At the Edit menu, choose Copy Source to Active.
e To copy everything in the source window, select All Data.
e To copy only a selected region, choose Selected Data.

e To copy only the displayed (visible) data, choose Displayed Data.

The specified range of source data is then copied into the active window and displayed there.
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6-4-3 Append Source to Active

You can append a range of waveform data from the source window to the end of the waveform data in
the active window.

To append sampled data:

1. Ensure that a waveform is displayed in the source window. The active window must contain
waveform data with the same sampling rate as the source.

Before you begin, you can want to check the various setup parameters for this operation. From the
Options menu, select Editing, then select Append from the displayed submenu to display a box in
which you can select the data appending features.

2. From the Edit menu, choose Append Source to Active. You now have the option of appending All
Data in the source, or the Selected Data, or Displayed Data.

The specified range of source data is then copied into the active window and displayed there.

6-4-4 Multi-Channel Data

If the source waveform contains multi-channel data and the append options are set to include all
channels of data, each channel of the source signal is appended into the same channel in the active
window if that channel exists. What is copied varies based on the append options selected:

¢ With two channels of data in the source window, Ch. 1 and Ch. 2, then the Ch. 1 data from the
source window is appended to the Ch. 1 data in the active window if data currently exists in channel
1 in the active window, and the Ch. 2 data from the source window is appended to the Ch. 2 data in
the active window if data currently exists in channel 2.

e |f the source waveform contains multi-channel data and the append options are set to include only
the displayed channel (or the active channel, if all channels are displayed), the displayed (active)
channel in the source window is appended to the displayed (active) channel in the active window.

Note \When the range of data to be appended is All Data, the length of the data appended is
determined by the length of the data in the displayed (active) channel in the source window.
Data channels that are shorter than the displayed (active) channel are padded with zeros when
appended.

6-4-5 Insert Source into Active

You can insert a range of waveform data from the source window into the waveform data in the active
window.

To insert sampled data:

1. Ensure that a waveform is displayed in the source window. The active window must contain
waveform data with the same sampling rate as the source.

2. Before you begin, you can want to check the various setup parameters for this operation. From the
Options menu, select Editing, then select Insert from the displayed submenu to display a box in
which you can select the data insertion features.
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3. From the Edit menu, choose Insert Source to Active. You now have the option of inserting All
Source Data to Start of Active, Selected Source Data to Start of Active, All Source Data to
Cursor in Active, or the Selected Source Data to Cursor in Active.

The active window is redrawn with the specified range of source data inserted at the specified location.
If a scrollbar is displayed in the window, the time scale is also updated to reflect the increased duration
of data. Because of the method used to avoid clicks when joining signal endpoints, the resulting file can
be slightly shorter than the sum of the lengths of the two components.

6-4-6 Mix Source Data

The program allows you to mix a range of waveform data in the source window with the waveform data
in the active window. This is done by either adding the amplitude values together or by calculating the
average amplitude values. The resulting waveform is displayed in the active window.

To mix sampled data:

1. Ensure that a waveform is displayed in both the source and active windows. If the source and active
windows are the same, the range that is specified is mixed with the data starting at the beginning. If
the source and active windows are not the same, the windows must contain waveform data of the
same sampling rate.

2. The data in the active window will be replaced with the mixed data. If you do not want to lose the
active window data, you can activate a different window or create a new window, then copy the data
to the new active window.

3. From the Options menu, select Editing, Mix to display a dialog box which allows you to select the
waveform mixing options.

4. To mix the two waveforms together, choose Mix Source Data from the Edit menu. Then select the
region of data you wish to mix.

The source and active window data are mixed together and the resulting waveform is displayed in the
active window.

6-4-7 Source Signal Duration

You can change the duration of the signal data in the source window without changing the pitch
characteristics of the data.

To modify the duration of the data in the source window:

1. The default source window must contain waveform data. If the Signal Duration Options are set so
that a new signal is generated, the active window must be empty.

2. Before changing the duration of the data, set the signal duration options. This can be done by
selecting Editing, Source Signal Duration from the Options menu to display a box in which you
can view and change the current settings.

3. To change the duration of the data in the source window, select Modify Source Signal Duration
from the Edit menu. A submenu appears giving you the option to modify the duration of all the data
(All Data), the selected region of the data (Selected Data), or the currently displayed data
(Displayed Data).

The modified data is either spoken or displayed in the active window, depending on the setting of the
rate modification output option. If the data is to be displayed, the active window must be empty. If the
data is spoken, a playback toolbar is displayed during audio output of the modified data.
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To halt audio output before the end of the data is reached:
» Click the Stop button or press the Enter key or Esc key.
To pause audio output temporarily:

» Click the Pause button or press the spacebar. \When audio output is paused, the Pause button
becomes a Resume button. Click the Resume button or press the spacebar to continue audio
output at the point where it was halted.

%] Note: source window contains multi-channel data, only the data in the currently displayed
channel are modified.

6-4-8 Filter Source Data

You can apply a finite impulse response (FIR) digital filter to a specified range of waveform data in the
source window and copy the resulting filtered waveform to the active window. You must first build and
save a filter file, or load an existing digital filter from disk. The most recently saved or loaded filter will be
applied to the waveform data.

Build an FIR digital filter

Creates a finite impulse response (FIR) digital filter file using the parameters selected. The frequency
response will be displayed in the RESPONSE window. Before the digital filter can be applied to sampled
data, it must be saved as a filter file.

1. To begin, select Editing, Filter from the Options menu. A dialog box appears on the screen in
which you can set the filter options.

2. Once you have set the filter parameters, click on the Build button to display the frequency response
in the RESPONSE window within the FIR Filter Options dialog box. You can change any of the filter
parameters and click on the Build button again to display the new filter profile.

3. Note that building a filter profile will only cause the program to display the frequency response. The
filter is not available for use by the program until it has been saved to disk.

4. Click the OK button to close the FIR Filter Options box and install the most recently saved or loaded
digital filter for use by the program. Click the Cancel button to close the FIR Filter Options box
without installing a digital filter.

Save an FIR digital filter
Saves the filter coefficients of a recently built filter to disk.

1. Select Editing, Filter from the Options menu to display the FIR Filter Options dialog box, then build
an FIR digital filter.

2. When you are satisfied with the filter that you have built, click on the Save As button. This will save
the filter file to disk.

3. Click the OK button to automatically install the most recently saved filter file into the system, ready
for use. This installed filter is used when a digital filter is applied to waveform data. Click Cancel to
close the Filter Options box without installing the saved filter.
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Load an Existing FIR digital filter

Displays a Load FIR Filter Description box in which you can select an existing filter to install. The filter is
loaded into memory and the corresponding frequency response is displayed in the RESPONSE window
of the dialog box. The Window, Type, Cutoff and Filter Order boxes will display the settings used when
the filter was created.

1. Select Editing, Filter from the Options menu to access the FIR Filter Options box. Now click on the
Load button. Scroll to the location of your filter files, then select the file you wish to load from the
list of available filter files. Click the OK button or press the Enter key to complete the file loading
routine.

2. The filter is loaded into memory and the corresponding frequency response is displayed in the
RESPONSE window of the Filter Options dialog box. The Window, Type, Cutoff and Filter Order
boxes will display the settings used when the filter was created.

3. Click OK to install the loaded filter for use by the program. Click Cancel to close the FIR Filter
Options box without installing the most recently loaded filter.

Apply an FIR Digital Filter
Applies the installed FIR digital filter to the waveform data in the default source window.

1. Ensure that a waveform is displayed in the source window. If the source and active windows are the
same, the range that is specified in the source window is replaced by the filtered data. If the source
and active windows are not the same, then the active window must be empty.

2. To filter the waveform data, select Filter Source Data from the Edit menu. Then select All Data to
apply the filter to all the waveform data, Selected Data to filter the data in the selection area, or
select Displayed Data to filter the data currently displayed in the default source window.

3. If no finite impulse response (FIR) filter is installed, the Filter Options box is displayed, allowing you
to build and save a new filter, or load an existing digital filter.

4. The data are filtered using the installed digital filter, and the resulting waveform is drawn in the active
window. Compare the original and filtered waveforms visually by generating power spectra at similar
locations in each. You can also listen to the differences by speaking each in turn. If desired, you can
Downsample Displayed Source

The program provides the facility for downsampling a range of sampled data in the source window. The
resulting waveform data is displayed in the active window.

Downsampling is typically used to reduce the sampling rate of a waveform after it has been filtered. The
combination of downsampling and filtering can be used to remove possible aliasing effects from digitally
encoded waveform data.

Note Anti-aliasing is carried out automatically during data capture. However, you can wish to
filter, then downsample the data to change the bandwidth of sampled data without recapturing
the data.
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To downsample sampled data:

1. Ensure that a waveform is displayed in the source window. Unless all the data in the source window
are to be downsampled, the source and active windows must be different, and the active window
must be empty.

2. To downsample the waveform data displayed in the source window, choose Downsample
Displayed Source from the Edit menu. A dialog box appears on the screen, displaying the present
sampling rate and a list of allowed rates that the data can be downsampled to. Select a new
downsampling rate from the list.

3. The sampling rate of the data is changed to the selected rate and the resulting waveform is displayed
in the active window. You can verify the new sampling rate by selecting Information on Active
Window from the Window menu.

6-4-9 Scale Displayed Source

The program includes a scaling operation which multiplies the amplitude values in a range of sampled
data in the source window by a specified scaling factor, and then displays the resulting scaled waveform
in the active window.

To scale sampled data:

1. Ensure that a waveform is displayed in the source window. If the source and active windows are the
same, the range that is specified in the source window is replaced by the scaled data. If the source
and active windows are not the same, then the active window must be empty.

2. To scale the displayed waveform data, choose Scale Displayed Source from the Edit menu. A
dialog box appears on the screen, allowing entry of the scaling factor.

3. The amplitude values of the source waveform data are multiplied by the scaling factor and the
resulting waveform is displayed in the active window. If scaling produces amplitude values that are
greater than the maximum allowed dynamic range (amplitude values ranging from +32,767 to -
32,768), the values are scaled to the maximum.

6-4-10 Pre-Emphasis Displayed Source

You can apply a pre-emphasis factor to a range of sampled data in the source window and display the
results in the active window.

To apply pre-emphasis factor to sampled data:

1. Ensure that a waveform is displayed in the source window. If the source and active windows are the
same, the range that is specified in the source window is replaced by the pre-emphasized data. If the
source and active windows are not the same, then the active window must be empty.

2. To apply pre-emphasis to the displayed waveform data, choose Pre-emph Displayed Source from
the Edit menu. A box will appear, asking for entry of the pre-emphasis factor.

3. Pre-emphasis operates on the waveform by multiplying the amplitude of the current sampled data
point by a factor ranging from 0.0 to 2.0, then subtracting it from the amplitude of the next sampled
data point, repeating this process for all data specified in the range. The pre-emphasized waveform is
displayed in the active window.
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6-4-11 Subtract Displayed Source

You can compute the differences between waveform data in a specified range in the source window and
waveform data of the same sampling rate in the active window. The resulting differenced waveform will
be displayed in the active window.

To difference sampled data:

1. Ensure that a waveform is displayed in both the source and active windows. Remember that the
source window data are subtracted from the active window data. If the durations of the data in the
two windows are not the same, the remaining undifferenced data are appended to the end of the
differenced waveform. If the source and active windows are the same, the range that is specified is
replaced by the differenced data. This has the effect of converting the data in the specified range to
Zeros.

2. The data in the active window will be replaced with the differenced data. If you do not want to lose
the active window data, you can create a new window, and then copy the data to the new window.

3. From the Edit menu, choose Subtract Displayed Source to subtract the displayed source data
from the active window data.

4. The amplitude values of the specified range of source data are subtracted from the amplitude values
of the data in the active window. The resulting differenced waveform is displayed in the active
window.

6-4-12 Flip Displayed Source

You can reverse the polarity of a range of sampled data in the source window and display the resulting
waveform in the active window.

To flip a waveform signal:

1. Ensure that a waveform is displayed in the source window. If the source and active windows are the
same, the range that is specified in the source window is replaced by the inverted data. If the source
and active windows are not the same, then the active window must be empty.

2. To flip the waveform signal, choose Flip Displayed Source from the Edit menu. This will cause all
of the displayed data in the source window to be flipped.

3. The polarity of the source waveform data is reversed and the resulting waveform is displayed in the
active window.

4. You can want to zoom in on a region of the waveform to have a closer look at the signal polarity.
Select a voiced section of data, and then choose Selected Data from the View menu to display the
selected section of data.
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6-4-13 Reverse Displayed Source

You can reverse the time domain of a range of sampled data in the source window and display the
resulting waveform in the active window.

To reverse sampled data:

1. Ensure that a waveform is displayed in the source window. If the source and active windows are the
same, the range that is specified in the source window is replaced by the reversed data. If the
source and active windows are not the same, then the active window must be empty.

To reverse the displayed waveform data, choose Reverse Displayed Source from the Edit menu.

3. The time domain of the source waveform data is reversed and the resulting waveform is displayed in
the active window. You can listen to the reversed data.

6-4-14 Multi-Channel Functions

%] Note The program now supports the display of more than one channel of data in the window.

Split from Next Channel in Source

If the waveform signal in the source window is a multi-channel signal, you can split a single channel from
it and place that channel of data in an empty active window.

To split a channel of data from a multi-channel signal:

1. Ensure that a multi-channel signal is displayed in the source window. If you do not have a multi-
channel signal, you can create one by joining signals. Note that the source window cannot be the
active window.

The active window must be empty prior to command execution.

3. From the Edit menu, choose Multi-Channel Functions, Split from Next Ch. in Source to split
the next-to-displayed channel of the source data into the active window. If all channels of data are
displayed, the next-to-active channel is split from the source data.

4. For example, if the source window contains a signal with 4 channels of data (Ch. 1 through Ch. 4)
and only Ch. 3 is displayed, then the Ch. 4 data will be split from the source signal into the empty
active window. Alternatively, if all 4 channels are displayed in the source window and Ch. 3 is active
channel (i.e., the Ch. 3 pane is active in the source window), again, the Ch. 4 data is split.

5. The channel of data that was split from the multi-channel signal is now displayed in the active
window. You can listen to the new data, and optionally save the data in the active window as a new
signal data file.
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Join as Next Channel in Source

You can merge single-channel waveform data in the active window with the waveform data in the source
window, removing the data in the active window and creating a multi-channel signal of up to eight (8)
channels in the source window. Note that when you save the waveform data, not all audio file formats
support multi-channel signals.

To create multi-channel data:

1. Ensure that a waveform is displayed in the source window, and that the active window contains
single-channel data having the same sampling rate as the source data. If the data in the active
window is multi-channel, you will have to split the signal to create single-channel data.

2. To join the data from the active window to next available channel after the displayed channel in the
source window, choose Multi-Channel Functions, Join as Next Ch. in Source from the Edit
menu. If all channels of data are displayed in the source window, the signal in the active window is
joined as the next-to-active channel in the source window.

3. For example, if the source window contains a signal with 3 channels of data (Ch. 1 through Ch. 3)
and only Ch. 3 is displayed, then the data in the active window will be joined to the source data as
Ch. 4. Alternatively, if all 3 channels are displayed in the source window and Ch. 3 is active channel
(i.e., the Ch. 3 pane is active in the source window), again, the data are joined as Ch. 4.

4. The data in the active window are removed and joined to the source data. The joined data are time
aligned so that they have the same duration as the source. If the duration of the data in the active
window is greater than the data in the source window, the active window data are truncated to the
duration of the source. If the duration of the active window data is less than the duration of the data
in the source, zeros are added to the end of the active window data to make its duration equal to the
source.

5. You can optionally save the newly created multi-channel data. Note that up to eight (8) channels can
be saved in CSL signal file format. Wave audio file format supports a maximum of two (2) channels
of data, and the supported headerless audio file formats allow storage of single-channel data only.

6-4-15 Edit Voiced Period Marks

Due to the varying nature of sampled data, errors in the placement of voiced period marks, or impulse
marks, can result. Such errors affect any pitch-synchronous analyses that are subsequently performed.
You can manually add voiced period marks to the data, creating frame boundaries that are independent of
the pitch. You can also edit the placement of voiced period marks that already exist in the waveform data
and are displayed in the active window along with their associated waveform data.

Note that voiced period marks will not be displayed unless the signal display options are set to show
them with the waveform.
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Move impulse marks

1. Ensure that a waveform is displayed in the active window, and that voiced period marks are
displayed in the waveform data.

2. This command is used to change the location of voiced period marks, either to correct for processing

errors or to move them to a new location relative to the voiced period. Use the following commands
to make these changes:

e To move the voiced period mark to the left of the cursor to the cursor location, choose Voiced
Period Marks, Move Previous Impulse to Cursor from the Edit menu.

e To move the voiced period mark to the right of the cursor to the cursor location, choose Voiced
Period Marks, Move Next Impulse to Cursor from the Edit menu.

3. After editing the voiced period marks, you can want to save the changes. To do this, choose Save
from the File menu.

Manually add an impulse mark

1. Ensure that a waveform is displayed in the active window, and that the window is set to display
voiced period marks.

2. Toinsert a voiced period mark at the current cursor location in the waveform data, choose Voiced
Period Marks, Add Impulse at Cursor from the Edit menu.

Delete impulse marks

1. Ensure that a waveform is displayed in the active window, and that voiced period marks are
displayed in the waveform data.

2. To delete a voiced period mark at the current cursor location in the waveform data, choose Voiced
Period Marks, Delete Impulse at Cursor from the Edit menu.

3. You can also delete voiced period marks in a specific range of data. To delete voiced period marks
within the selected region of the data, choose Voiced Period Marks, Delete Impulses in
Selected Data from the Edit menu.

Impulse Marks

You can compute the periodicity of voiced speech in the active window and place marks in the waveform
data at time locations that separate the voiced periods. These marks are referred to as voiced period
marks, or impulse marks. The process separates the voiced signal into its periodic components, the
inverse of each period being the fundamental frequency, or pitch separation, of the signal as it changes
over time.

6-5-1 Impulse Analysis

Note that voiced period marks must be inserted in the waveform data before pitch-synchronous analysis
can be performed on the sampled data.

Placement of the voiced period marks can be edited.
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6-5-2 Display impulse marks

Voiced period marks can be present in the waveform but hidden from view.

1. To display the marks in the active window, select Waveform from the Options menu to display a
dialog box in which you can set the signal attributes to display. Enable the Impulse Marks
checkbox, causing a check mark to appear in the check box.

2. Remove the voiced period marks from the window without deleting them from the waveform data
by clearing the Impulse Marks checkbox in the Signal Display Options dialog box.

6-5-3 Manually add an impulse mark

You can manually add impulse marks at locations along a waveform as desired. To insert impulse marks
to a waveform:

1. At the Options menu, select Waveform.

Under Display options, ensure the box next to Impulse Marks is checked.

Click Apply after selection if necessary, then OK to close the window.

Left-click the desired location in the waveform. The red data cursor will move to that location.

o M D

At the Edit menu, go to the submenu Voiced Period Marks, and select Add Impulse at Cursor.\

6-5-4 Compute and insert impulse marks

To compute and insert impulse marks:
1. Ensure that a waveform is displayed in the active window.

2. Before generating the voiced period marks, set the impulse analysis parameters. This can be done by
selecting Analysis, Voiced Period Marks from the Options menu to display a box in which you
can view and change these parameters.

3. To compute and insert voiced period marks into the data, choose Voiced Period Marks from the
Analysis menu. A dialog box appears in the work area giving you the option to compute the voiced
period marks on all the data by selecting All Data, the selected region of the data by choosing
Selected Data, or the currently displayed data by selecting Displayed Data.

4. The waveform is redrawn with the voiced period marks inserted. If the voiced period marks are not
displayed in the waveform, you must change the signal display options so that these marks will
be displayed.

5. You can optionally save the sampled data with the voiced period marks.
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6-5-5 Delete impulse marks

1. Ensure that a waveform is displayed in the active window, and that voiced period marks are
displayed in the waveform data.

2. To delete a voiced period mark at the current cursor location in the waveform data, choose Voiced
Period Marks, Delete Impulse at Cursor from the Edit menu.

3. You can also delete voiced period marks in a specific range of data. To delete voiced period marks
within the selected region of the data, choose Voiced Period Marks, Delete Impulses in
Selected Data from the Edit menu.

6-5-6 Move impulse marks

To change the position of voiced period marks, either to correct for errors or relative to voiced period:

1. Ensure that a waveform is displayed in the active window, and that voiced period marks are
displayed in the waveform data. Do ONE of the following:

e To move the voiced period mark to the left of the cursor to the cursor location, choose Voiced
Period Marks, Move Previous Impulse to Cursor from the Edit menu.

e To move the voiced period mark to the right of the cursor to the cursor location, choose Voiced
Period Marks, Move Next Impulse to Cursor from the Edit menu.

6-5-7 Pitch Analysis

The program allows you to compute the fundamental frequency (pitch) of a range of voiced data in the
source window and display the resulting pitch contour in the active window.

To create a pitch contour:

1. Ensure that a waveform is displayed in the source window. The active window must be empty or
contain time domain analysis data prior to command execution.

2. Before generating the pitch contour, set up the pitch analysis parameters. This can be done by
selecting Analysis, Pitch Contour from the Options menu to display a box in which you can view
and change these parameters.

3. If pitch-synchronous analysis is performed, the fundamental frequency values are extracted by
computing the inverse of the time between each voiced period mark (impulse mark) in the data. If
impulse marks are not in the signal when pitch-synchronous analysis is performed, the pitch
synchronous analysis process will compute the impulse locations and store them internally. If
impulse marks are in the signal, then the impulse locations in the signal are used.

4. If pitch-asynchronous (fixed frame) analysis is performed, the fundamental frequency is extracted
directly from the waveform by determining the time intervals between dominant peaks in the
waveform. The waveform is first broken into regular intervals (frames), the duration of which is set
by the user. Note that frame length must be set to at least two pitch periods to achieve good results.

5. Interpolation is applied to the pitch analysis results (pitch synchronous or fixed frame) in order to
improve the resolution of the pitch analysis process.
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6. To generate a pitch contour, select Pitch Contour from the Analysis menu. A submenu appears in
the work area giving you the option to create a pitch contour on all the data (All Data), the selected
region of the data (Selected Data), or the currently displayed data (Displayed Data).

7. The resulting pitch contour is drawn in the active window. Numerical results and result statistics can
now be displayed, and optionally printed and saved, or copied to the clipboard then pasted into a
spreadsheet.

6-5-8 Energy Analysis

You can compute the energy of a range of waveform data in the source window and display the resulting
energy contour in the active window.

The energy operation calculates the sum of the absolute amplitude values in a frame of data divided by
the number of points in the frame. The energy is first computed and then converted to decibels of sound
pressure (dB SPL).

To create an energy contour:

1. Ensure that a waveform is displayed in the source window. The active window must be empty or
contain a time series of analysis data.

2. Before generating an energy contour, set the energy analysis parameters. This can be done by
selecting Analysis, Energy Contour from the Options menu to display a box in which you can
view and change these parameters.

3. To create an energy contour, select Energy Contour from the Analysis menu. A submenu appears
in the work area giving you the option to create an energy contour on all the data by selecting All
Data, on the selected region of data by selecting Selected Data, or on the currently displayed data
by selecting Displayed Data.

4. The resulting energy contour is drawn in the active window. Numerical results and result statistics
can now be displayed, and optionally printed and saved, or copied to the clipboard then pasted into a
spreadsheet.

6-5-9 Impulse-Driven Data Cursor Movement

If the active window contains waveform data and voiced period marks (impulse marks) have been placed
in the data, you can move the data cursor from its current location to the location of the next or previous
voiced period mark:

1. From the Edit menu, select Voiced Period Marks. To move the data cursor to the location of the
voiced period mark that precedes the current cursor location, select Go to Previous Impulse. To
move to the voiced period mark that follows the current cursor location, select Go to Next Impulse.

2. If the active window contains waveform data and tags are in the data, you can move the data cursor
from its current location to the location of the tag immediately to the left or right of the current cursor
location. To move the data cursor to the location of the tag that precedes the current cursor location,
select Go to Previous Tag from the Tags menu. To move the data cursor to the location of the tag
that follows the current cursor location, select Go to Next Tag from the Tags menu.
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3. Acquire or load data into an empty window (e.g., Window A) and select a window for plotting
analytical results (e.g., Window B).

If the waveform source window (e.g., Window A) is still active when an analysis operation is called,
The CSL Main Program and Multi-Speech will automatically activate the next empty window in the
work area before performing the requested operation.

4. Select an analysis technique by clicking Analysis on the Main Menu and then select the desired
analysis mode (e.g., Spectrogram).

Select which portion of the signal you would like to analyse (e.g., All Data, Selected Data, etc.).

If you wish to adjust some of the analysis set parameters (e.g., spectrogram bandwidth), you can
alter all of these set parameters from the menu by selecting Analysis on the Main Menu, then
Spectrogram, and then Adjust Spectrogram Analysis.

Alternatively, right-click in the window containing the spectrogram, then select SPG Setup from the
displayed pop-up menu. From the dialogue box displayed in Figure 22 below, you can now alter the
setup parameters to suit your analysis requirements, and then apply desired settings to the existing
analysis.

7. Click on the new selection, and then click OK to accept these changes for the next analysis or click
Apply to apply the changes to the current SPG analysis results in the active window
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Note that any number of compatible analysis results can be overlaid in a window. For example,
Spectrogram, Formant History, Pitch Contour and Energy Contour results are all displayed over a
time domain.

8. To overlay an LPC-based time history formant display over the spectrogram in Window B, click
Analysis on the Main Menu and then select Formant History.

9. From the Formant History submenu, select which portion of the signal you would like to analyze
(e.g., All Data, Selected Data, etc.).

10. The title of the window changes from SPG to FMT, and the formant history is drawn on top of the
spectrogram.
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The formant history shown below is laid over the spectrogram using large dots, and with a different pen
color assigned to each formant.

You can display numerical results for the formant analysis on the screen:

1. Click on the Analysis menu, and then select Produce Numerical Results. Alternatively, press the
[Alt+R] keys to display the numerical results for the active window.

A Formant Analysis Results box is displayed in the work area, giving the option to save the
data to a file, print the data, or display information about the analysis option settings and the
source data used for the analysis.

2. After reviewing the data, click the Done button to close the Formant Analysis Results box.

3. To avoid cluttering the window, remove the formant history before plotting the pitch and energy of
the signal. Click on the View menu, and then select Remove Current (Top) Plot. Note that instead
of using the menu, you can press the [Ctrl+End] keys on the keyboard to remove the top plot in the
window.

The formant history is removed from the window and the spectrogram is again displayed. The
title of the window changes back from FMT to SPG.

In preparation for pitch-synchronous analysis of the sampled data, you can compute the locations of the
voice period separations in the speech waveform data and place marks in the waveform data at these
time locations. These marks are called voiced period marks, or impulse marks.

To compute impulse mark locations:
1. To begin, click on the title of Window A to activate it.
Click on Analysis on the Main Menu, and then select Voiced Period Marks.

3. From the Voiced Period Marks submenu, select which portion of the signal you would like to
analyze (e.g., All Data, Selected Data, etc.).

The impulse marks are inserted along the bottom of the waveform data.
4. Click Window B to reactivate it.

Analysis parameters can be set before the analysis is performed. Prior to plotting a pitch contour in
the active window (i.e., Window B); select Analysis on the Main Menu, then Pitch Contour, and
then Adjust Pitch Contour. In the displayed Pitch Analysis Options dialog box, click the Display tab
to access the display settings, and then clear the Draw Dot Contour checkbox to display the pitch
contour as a solid line.

Now to perform the pitch analysis, select Analysis on the Main Menu, then select Pitch Contour.

From the Pitch Contour submenu, select which portion of the signal you would like to analyze (e.g.,
All Data, Selected Data, etc.).

The title of the active window changes from SPG to PITCH, and a pitch contour is overlaid on
the spectrogram using the active pen color, which is reported by the leftmost color swatch on
the window status line.

Initially, both the current (active) plot pen color and the next plot pen color are both set to
black. However, either of these color values can be changed by double-clicking on the color
swatch at the bottom of the window, the leftmost of the two small lines to the left of “x".

8. To change the color of the next plot in Window B, double-click on the rightmost color swatch and
then click on the Forest Green swatch in the displayed color panel. The color swatches on the status
line should now be red (left) for the current plot and green (right) for the next plot.
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9. Finally, we will overlay an energy contour for a portion of the waveform data on top of the
spectrogram and pitch contour in Window B. Select Analysis on the Main Menu, then select
Energy Contour.

10. From the Energy Contour submenu, select which portion of the signal you would like to analyze
(e.g., All Data, Selected Data, etc.).

The title of the active window changes from PITCH to ENERGY, and a green colored energy contour
is overlaid on the spectrogram and the pitch contour, as shown below.

Both color swatches on the window status line are now green, as the active (i.e., energy) plot was
drawn using this pen color. The green energy contour is the current (top) plot, as indicated by
ENERGY in the Window B title bar and by the leftmost color swatch on the Window B status line.
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Figure 23. Pitch and energy contours overlaid on spectrogram.
To move the data cursor through the analysis data:

Press the [Right arrow] key or the [Ctrl+Right arrow] key combination to move at a faster rate.
Alternatively, click the mouse on the red data cursor and, holding the mouse button down, drag it to
a new location in the data. The x-axis and y-axis values on the window status line are updated to
reflect the time and energy (dB) values of the data at the cursor location.

With multiple analysis plots in a window, you can scroll through the analysis data, causing the current
data to move to the end of the analysis results list and the previous data to become current (i.e., topmost
in the list):

1. Select View on the Main Menu, and then select Put Previous Plot on Top.

2. The energy contour is “hidden” behind the spectrogram and the pitch contour is now active. The title
of Window B changes from ENERGY to PITCH, and the leftmost color swatch on the window status
line changes to red, indicating the pen color of the pitch contour display. The y-axis box now reports
the fundamental frequency (Hz) value of the data at the current cursor location.

Both the analysis results in Window B and the source waveform in Window A are displayed over a
Time (sec) dimension. Therefore, cursor movement, data mark movement, selection area definition,
and data display operations in the two windows can be linked.
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3. To link these operations in the two windows, click Window on the Main Menu, then select Link
Windows. Finally, select Link to Source Window from the displayed submenu.

Now as you move the data cursor through the analysis results in Window B, the cursor movement is
replicated in Window A. Again, move the data cursor in Window B using the keyboard or mouse, and
notice that cursor movement in Window A is time-aligned with the cursor movement in Window B.

Notice that the values in the x-axis boxes on both window status lines are the same. From the y-axis
box in Window A, we can read the amplitude of the waveform at a point in time, and from the y-axis
box in Window B, we can read the pitch analysis value produced from the waveform data.

When windows are linked, data display operations are also duplicated in the linked windows. To
illustrate, we will display only the data from the start to the current cursor location:

1. Select View from the Main Menu, and then select Start to Cursor. Alternatively, press the [Alt+C]
keys.

Both Window A and Window B are redrawn, showing only the first portion of the data in each.

2. Toredisplay all data in the windows, click View on the Main Menu, then select All Data.
Alternatively, press the [Alt+A] keys.

Again, both linked windows are redrawn to display all data.

3. To calculate Result Statistics for the pitch analysis data, click Analysis on the Main Menu, then
select Compute Result Statistics, or press [Alt+S].

A Pitch Result Statistics box is displayed. You have the option to save the data to a file, print the
data, or display information about the analysis option settings and source data used for the analysis.

4. After reviewing the data, click the Done button to close the Pitch Result Statistics box.

Frequency Axis Results

The prior steps have shown the results of analyses that are displayed over a time axis. Power spectra
and frequency response data, however, are displayed on a frequency axis as follows:

1. Clear any data from Window B by clicking Window on the Main Menu, then selecting Purge Active
Window. Alternatively, you can press the [F2] function key.

2. The contents of Window B are erased, and the link between Window A and Window B is
automatically removed.

Click the Minimize button in Window B.

4. To open a new window to display the frequency response data. click Window on the Main Menu,
and then select Open Preset Window. Finally, select For Frequency Response etc. from the
displayed submenu.

A new active window is displayed in the work area with the label “C Empty.”
Click on the title of Window A to activate it.
Move the data cursor to the location of a vowel sound in the source waveform.

7. Reactivate Window C by pressing either the [Page Up] or the [Page Down] key on the keyboard.

MUODO0000700 88 Revision B



6-6

PENTAX

MEDICAL

Click Analysis on the Main Menu, and then select LPC Frequency Response. Finally, select LPC

Frequency Response at Cursor from the displayed submenu.

The frequency response data are displayed in the active window and the window title reads LPC.
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Figure 24. LPC Frequency Response.

9. Note that LPC Frequency Response and FFT Power Spectrum analysis results are displayed over a

This concludes our overview of many of the analysis functions that are available.

frequency axis; therefore, these data can optionally be plotted in the same window.

Tagging Data

The program allows you insert tags at specified locations in the waveform display, and to manipulate a

tag at a location or all tags in a range of waveform data in the active window.

6-6-1 ViewTags in Waveform Data

Tags are arranged in consecutive numerical order starting with T1, and are location dependent. If a tag is
placed at a location before an existing tag, the tag numbers are reordered so that the first tag in the
waveform is always T1.

To enable display of tags:

1.

Ensure that a waveform is displayed in the active window. Tags must already exist in the waveform
data for all tag operations except inserting new tags. To determine if tags are present, select
Information on Active Window from the Window menu. If tags are present, a check mark will
appear in the box beside the tag description.

Tag marks can be present in the waveform but hidden from view. To display the tags, select
Waveform from the Options menu to display a dialog box in which you can set the signal attributes
to display. Select Tags, causing a check mark to appear in the box beside the Tags description.
Remove the tags from the window without deleting them from the waveform data by clearing the
Tags box in the Signal Display Options dialog box.
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3. You can insert tags in a waveform, delete existing tags, move tags to a new location, display the tag
comment information, and edit the comment information for a tag.

4. You can save any changes that you make to the tags in the waveform. Note that you must save the
data in CSL signal file format to store the tag information with the waveform, as wave audio file
format does not support this type of information.

6-6-2 InsertTag

To insert a tag with an optional comment field at the current cursor location in the waveform data:
1. At the Tags menu. choose Insert Tag at Cursor.

2. Enter text to identify tag to be saved along with its location in the file.

3. Click OK to insert the tag.

6-6-3 DeleteTag

To delete the tag at the current cursor location:
» At the Tags menu. select Delete Tag at Cursor.
To delete all tags within the selection area:

» Select Delete Tags in Selected Data from the Tags menu.

6-6-4 EditTag

To edit the comment information for the tag at the current cursor location:
1. Choose EditTag at Cursor from the Tags menu.

An Edit Tag Text dialog box is displayed, showing the time location of the tag and the textual
information in the comment field.

2. Edit the comment field.

3. Click OK to save the change, or click Cancel to close the Edit Tag Text box without saving changes
made to the comment field.
6-6-5 Display Tag Comment Field

To display the comment information for a tag at the current cursor location, choose Query Tag at
Cursor from the Tags menu. A box displays the time location of the tag and the text in the tag comment
field.

6-6-6 MoveTag

To move the tag to the left of the data cursor to the current cursor location, select Move Previous Tag
to Cursor from the Tags menu. To move the tag to the right of the data cursor to the current cursor
location, select Move NextTag to Cursor from the Tags menu.
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6-7 IPA Characters and Transcription

You can add, delete, copy, or move International Phonetic Alphabet (IPA) symbols at a specified location
in the waveform in the active window. You can then save the transcribed waveform data to a file using
CSL signal file format. (Note that wave audio file format does not support storage of IPA characters with
the waveform data. If you save the signal data as a WAV file, the IPA transcripts will be lost.)

6-7-1 Prepare for IPATranscription

Before you begin, ensure that one or both of the IPA transcription lines are displayed in the window. If
both lines are displayed, you must specify which one is the active line for IPA operations.

1.

IPA characters can be stored with waveform data in a sampled data file. However, |PA transcripts
will not be displayed in the window with the waveform data unless the program has been set to
display the IPA transcription lines. To display one or both IPA lines, select Waveform from the
Options menu to display a dialog box in which you can set the signal attributes to display. Then
select one or both of the transcription line boxes, Upper or Lower.

If both are transcription lines are displayed, radio buttons are activated allowing you to select which
transcription line is active (editable). Symbols in the active line will be drawn in black, while symbols
in the inactive line will be in gray. Alternatively you can select the active transcription line by selecting
IPA Transcription from the Options menu to display a dialog box in which you can select the Active
Transcription Line, either Line 1 (Upper) or Line 2 (Lower).

You can also specify the size of the font used when displaying IPA symbols in the window. Select
Waveform from the Options menu to display a dialog box for selecting signal display options. In the
Transcription Font area of this dialog box, click on the Down Arrow to display a drop box of valid font
sizes. Scroll through the list of available font sizes and select the size you wish to use to display the
IPA symbols.

When entering IPA characters using the transcription box, you can set the font size for the display of
the characters in the box. From the Options menu, select IPATranscription to display the IPA
Transcription Options dialog box. In the Editor Font section of the dialog box, select the desired font
size from the dropdown box.

Finally, when using the transcription box, you have the option of inserting the IPA characters into the
active window, if it contains signal data, or into the window containing the source signal for the time
domain analysis data in the active window. From the Options menu, select IPATranscription to
display the IPA Transcription Options dialog box, then select Active or Source in the Insert Into
section of the dialog box.

Whenever you make changes to the settings in an Options dialog box, click Apply to apply the

changes to the active window containing waveform data. Click the OK button to save the changes
and close the box. Click Cancel to clear the dialog box without saving the changes.
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6-7-2 Insert IPA Characters Using the Transcription Box
An IPA Characters transcription box has been developed as an alternative method of inserting IPA
symbols into waveform data.

1. Ensure that a waveform is displayed in the active window and that at least one transcription line is
displayed in the window. There can or cannot be IPA symbols already present in the waveform data.

2. To display the IPA Characters transcription box, select Display IPA Symbol Table from the IPA
menu.

Click on any of the IPA Characters in the displayed symbol table.

As an aid to transcription, you can click the Description button to display information about the
selected symbol.

5. Toinsert the selected IPA Character at the current cursor location, click the Insert button.
Remember that IPA Characters are inserted in the waveform in either the active window or the
window containing the source signal for the time domain analysis data in the active window,
depending on the settings for the IPA Options.

6. When you have finished transcribing the waveform, remove the IPA Characters transcription box
from the screen by selecting Remove IPA Symbol Table from the IPA menu.

6-7-3 Insert IPA Characters Using the Keyboard

Using the keyboard, you can insert IPA characters into the waveform data in active window.

1. Ensure that a waveform is displayed in the active window and that at least one transcription line is
displayed in the window. There can or cannot be IPA symbols already present in the waveform data.

2. Configure the keyboard for the purpose of entering IPA symbols. Select Load IPA Symbols to
Keyboard from the IPA menu to load the IPA characters to the keyboard.

3. Press the appropriate key or key combination for the IPA symbol you wish to insert at the current
cursor location. Refer to Appendix F IPA Characters for detailed information on entering IPA
symbols in this manner.

4. When you are finished transcribing the speech data, reload the keyboard definitions for normal
program operation. Select Restore Keyboard to Normal from the IPA menu.

5. The Information dialog box for the waveform signal will show that IPA Transcriptions have been
added to the waveform. You can save any changes that you have made to the sampled data file. To
save the sampled data with the added IPA symbols, choose Save from the File menu.

6-7-4 Delete IPA Characters
1. Ensure that a waveform is displayed in the active window. IPA characters must already be present in
the waveform data.

2. To delete an IPA character and associated comment information at the current cursor location, select
Delete IPA Symbol at Cursor from the IPA menu. To delete IPA characters in the selected region
of the waveform, select Delete IPA Symbol in Selected Data from the IPA menu.
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6-7-5 Move IPA Characters

1. Ensure that a waveform is displayed in the active window command. IPA characters must be present
in the waveform data.

2. You can move the IPA symbol preceding the data cursor to the cursor location by selecting Move
Previous IPA Symbol to Cursor from the IPA menu. Move the IPA symbol following the data
cursor to the cursor location by selecting Move Next IPA Symbol to Cursor from the IPA menu.
An IPA character must exist at the first location and not exist at the second location. Use this
command to fine tune character placement.

6-7-6 IPATranscription Options

From the Options menu, select IPATranscription. You can set the following IPA Transcription Options:

o ActiveTranscription Line - One or two data fields can be optionally displayed for entry of IPA
characters. If both of the available IPA transcription lines are displayed, specifies which line is active.
Note that if only one transcription line is displayed, it is automatically set as the active line.

¢ Insert Into - When using the transcription box, you have the option of inserting the IPA characters
into the active window, if it contains signal data, or into the window containing the source signal for
the time domain analysis data in the active window.

e Editor Font Size - When entering IPA characters using the transcription box, specifies the font size
to display the characters in the box.

6-7-7 Load IPA Keyboard Definitions from a File

1. You can assign keyboard definitions from a specified file. For example, the file IPA.KEY contains
keyboard definitions for IPA characters. Refer to the IPA Character Charts and Tables in Appendix F
IPA Characters of this instruction manual for more information.

2. To load these IPA keyboard definitions to the keyboard, select Load IPA Symbols to Keyboard
from the IPA menu.

3. Note that you must press the spacebar to access the command line when the IPA keyboard
definitions are loaded.

4. To reload the keyboard definitions for normal program operation, select Restore Keyboard to
Normal from the IPA menu.
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Logging

The program offers the ability to record information taken from the current cursor location and save it in
an ASCII text file, called a log book. Note that only one log file can be opened at a time.

6-8-1 Open an Existing Log File

You can open a previously created log file to review the existing records and to add new data. To reopen

an existing log file:

» Select Open from the Log menu. An Open Log Book dialog box is displayed, allowing you to select
the log file you wish to reopen from the list of existing log files.

A message is displayed in the work area, confirming that the log book has been opened. Each time a
log book is opened, a special Time Stamp comment containing both the time and date at which the
log was opened is entered into the log file.

6-8-2 Create a New Log File

To open a log file for the first time:
1. Select Open from the Log menu.

An Open dialog box is displayed, requesting entry of a name for the log file. Type a name for the log
book in the File Name box. A .LOG extension is automatically added to the file name.

Once you have named the new log file, a Create Results Log information box appears in the work
area. You can have up to eight fields in each log record. For each field, select the type of information
that the field is to contain, and optionally assign a label to the field. You must also select a field
separator. The different fields appear as columns of information in the log file.

2. Click the OK button after defining the fields for your log book.

Once a log book has been initialized, its fields and field labels cannot be changed. Click the Cancel
button to clear the Create Results Log box from the work area without initializing a new log file.

Entries to the log book are recorded as rows of information taken from the current cursor location for
both vertical and horizontal cursors. When windows are linked, data are recorded first from the active
window and then from the linked windows.

Setting Up a New Results Log

You can have up to eight fields in each log record. For each field, select the type of information that the
field is to contain, and optionally assign a label to the field. You must also select a field separator.

When you first open the log book, all eight fields are blank. You can leave a field blank (field type
NOTHING), or you can define it as one of the seven field types allowed, repeating a given field type as
many times as you wish, and defining up to the limit of eight fields.

e Available field types are Time, D.Time, Amplitude, Energy, Frequency, D.Freq, and Pitch, as
described below:

e Time - Time value taken from the cursor location of a waveform, pitch, energy, spectrogram or
formant history window.

¢ D.Time - Time value describing the difference between the current data cursor location and the
location of the data mark. Valid for waveform, pitch, energy, spectrogram or formant history
windows.
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e Amplitude - Vertical reading taken from a waveform window.

o Energy - Vertical reading taken from an energy, FFT power spectrum or LPC frequency response
window.

e Frequency - Vertical reading taken from a spectrogram or formant history result window or the
horizontal reading taken from an FFT power spectrum or LPC frequency response result window.

e D.Freq - Frequency value describing the difference between the current data cursor location and
the location of the data mark (|). This value is a vertical reading when taken from a spectrogram
or formant history results window or a horizontal reading when taken from an FFT power
spectrum or LPC frequency response results window.

e Pitch - Vertical reading taken from a pitch result window.
1. To define a field type, do one of the following:

e Click the Down Arrow box to display a drop box listing the available field types. Then select the
desired field type from the displayed list.

e Type the name of the field type in the box. When a field type is entered in this manner, you can
use abbreviations to identify the field type, but sufficient information must be provided in the
field name to distinguish field types from one another (i.e., D.T and D.F).

e Using the keyboard, press the [Down Arrow] key to progress from one field type to the next.
2. Repeat Step 2 for each field that you wish to define, up to a maximum of eight (8) fields.

After the log fields have been assigned, you can enter a title for any or each of the log fields. Any text
can be entered as a field label.

Choose how the log fields will be separated when the log file is saved to disk storage. The field separator
can be a space, a tab, or a comma. Choose the Tab or Comma option to format the log book for access
by a spreadsheet program. Select the Space option to save the log file so that the display is easily read
when you send it to the printer or if you intend to edit it at a later date using any standard text editor.

6-8-3 Display the Current Entry

The current entry is the log record currently being built. The data it contains have not yet been saved to
the log file.

At any time, you can verify the assigned log fields and view the current entry.

» Select Display Current Entry from the Log menu.

An information box is displayed showing the field labels, the field types, and any values stored in the
fields of the current entry. Check marks in the New boxes to the right of the values indicates that
these values are the most recent added to the record. There is a comment field in which you can
enter textual information to be stored with the log record.

You can delete the new values in the current log entry:

1. Delete all values from all the fields in the current record, or write the current entry to the log book
along with any textual information entered in the comment field.

2. If you add to or edit the information in the comment field, click OK to close the Building Log Entry
box from the work area after first saving any changes made to the comment field. Click Cancel to
clear the Building Log Entry box from the work area without saving any changes made to the
comment field.
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6-8-4 Display the Complete Contents of the Log File

To view all of the entries in the log book (not just the current entry):
» Select Display All Entries from the Log menu.

Log entries are numbered on the immediate left of the log file. Line numbers are listed sequentially
in the order that they are entered to the log, and the log entries are displayed in a scrollable dialog
box.

6-8-5 Add Values to the Current Entry

1. Select Enter Current Values from the Log menu to record the information at the current cursor
location to the appropriate log field(s). After adding, an information box displays the values stored in
the current entry. This is the same information that is provided when you display the current entry.
The most recent values added to the current entry are indicated by a check mark in the New box to
the right of the log values.

2. From within the information box, you can click the Save Now button to write the current entry to
the log book, even if all of the fields in the log entry are not full. Click the Undo New button to
remove the values just recorded, or click the Undo All button to delete the values in all of the fields
of the current log entry.

Each time the current log entry is displayed, you are given the option to enter a comment which will
be saved with the record. You can enter any textual information to identify the entry.

3. Click the OK button to accept the new or edited comment information and close the box. Click
Cancel to close the information box without saving the revised comment information.

Once all of the fields in the current record are filled, you must write the current entry to the log file or
you must delete some or all of the values from the current record.

4. If you try to add values to the current log record and all of the log fields are full, an information box
displays an error message. Click the Save button to write the current entry to the log file along with
any textual information entered in the comment field. The new values are then recorded in the fields
of the current entry and displayed in the usual manner. Click the Clear button to clear the values in
all fields of the current entry before adding the new values. Click the Cancel button to cancel the
operation.

6-8-6 Delete Values from the Current Entry

1. To clear the last added values from the fields for the current entry:
2. Select Clear Last Values from the Log menu.

Only the fields filled by the last log add operation are removed from the log. These fields are
identified by a check mark in the New box beside the values when viewed through the Build Log
Entry dialog box. If the current log entry is displayed, you can click the Undo New button to perform
this operation.

3. If the current log entry is displayed, you can click the Undo All button to clear all values from the
current log entry.
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6-8-7 Write the Current Entry to the Log Book

At any time, you can save the values in the fields of the current entry as a record in the log file. Note that
you do not have to fill all the fields before saving the record. To write the current entry to the log book:

» Select Save Current Entry from the Log menu. If the current entry information box is displayed,
you can optionally click the Save Now button.

All values in the current entry are written to the log file, along with any information that has been
entered into the comment field of the current entry. Each entry to the log book is recorded as a row
of information, with the fields defining the columns in the log book.

6-8-8 Close the Current Log Book

1. Select Close from the Log menu to close the current log book.

If current values have not been saved to the log book, a warning message is displayed and you are
given the option to save them now.

2. Click Yes to save the current values and close the log. Click No to close the log without saving the
values. Click Cancel to abort the request to close the log book.

A message is displayed informing the user that the log book has been closed.

Options Menu

6-9-1 Analysis Options

Note that if the topmost analysis in the active window is the same type as the analysis options being
modified (for example, if changing the pitch options when a pitch contour is the top plot in the active
window), you can click the Apply button after changing the settings to apply the new settings to the
active window. Click OK to close the dialog box and save the modified parameters in the current
initialization file without applying the new settings to the active window. Click Cancel to close the dialog
box and discard any changes that were made and not yet applied.

LPC Frequency Response Options

From the Options menu, select Analysis, then LPC Frequency Response. You can set the following
LPC Analysis Options:

e Frame Length - Specifies the length of the frame of data to be analyzed when performing pitch-
asynchronous analysis. During pitch-synchronous analysis, this variable is used for data in voiceless
regions only, and the voiced regions are analyzed using a frame length determined by the voiced
period marks.

¢ Display Range (X-axis) - Specifies the frequency range (X-axis) over which the frequency response
will be displayed. You can choose to display the frequency range as a percentage of the Nyquist
Freqguency or as specific upper and lower frequency values.

o Filter Order - Selects the filter order, or the number of LPC coefficients to be applied to the
analysis.

e Pre-Emphasis - Determines the application of pre-emphasis and the value of the pre-emphasis
factor. A value of 0 means no pre-emphasis.

MUODO0000700 97 Revision B



PENTAX

MEDICAL

Display Range (Y-axis) - Specifies the display range setting along the vertical axis in decibels of
sound pressure level (dB SPL).

Analysis Method - Selects the LPC analysis method. You have a choice of the autocorrelation or
covariance methods.

Window Weighting - Controls the application of window weighting to a frame of sampled data that
is to be processed during LPC analysis. Window weighting is applied to reduce the amplitude of the
signal as it approaches a frame boundary. If a rectangular window is selected, its effect is to apply no
window weighting. Window weighting is recommended when using the autocorrelation method, and
the rectangular window is recommended when the covariance method is applied.

Pitch-Synchronous - Selects calculation of LPC framing from voiced period marks that are present
in the data or from a fixed frame length.

Frequency Report - specifies whether to report the x-axis value at the cursor location in Hz only, Hz
and Bark, or Hz and Mel.

LPC Waterfall Options

From the Options menu, select Analysis, then LPC Waterfall. There are a number of LPCW analysis
and display parameters that can be set by the user. The LPC Waterfall Setup box contains three (3)
separate tabs. Click on the appropriate tab for the options you want to set, and then set the desired
parameters.

LPCW Options: Analysis Tab
From the Analysis Tab, set the following LPCW options:

Analysis Method - Specifies the LPC analysis method. Choices are the Autocorrelation method or
the Covariance method.

Filter Order - Specifies the filter order, or number of LPC coefficients to be applied to the analysis.

Pitch-Synchronous - Specifies calculation of LPC framing from voiced period marks (voiced period
marks) that are present in the data or from a fixed frame length. If pitch-synchronous analysis is
selected and voiced period marks are in the source signal data, pitch-synchronous LPC values are
computed; otherwise, fixed-frame LPC analysis is performed, with the size of the analysis frame
determined by the setting for Frame Length.

Pre-Emphasis - Determines the application of pre-emphasis and the pre-emphasis factor. If a value
of O is entered, no pre-emphasis is applied.

Window Weighting - Controls the application of window weighting to each frame of sampled data
that is processed during LPC analysis. Window weighting is applied to reduce the amplitude of the
signal as it approaches a frame boundary. If a rectangular window is selected, its effect is to apply no
window weighting. A Blackman or Hamming window is recommended for speech processing.

LPCW Options: Framing Tab
From the Framing Tab, set the following LPCW options:

Frame Length - Specifies the length of each frame of data to be analyzed when performing fixed
frame (pitch-asynchronous) analysis. Frame length can be expressed in milliseconds or in number of
sampled data points. During pitch-synchronous analysis, this variable is used for data in the voiceless
regions only, and the voiced regions are analyzed using a frame length determined by the voiced
period marks in the data.
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Frame Advance - Specifies the frame advance for fixed-frame LPC calculation. The frame advance
can be expressed in milliseconds or in number of sampled data points. Frame advance is
independent of frame length, so the analysis results can be for contiguous or overlapping frames, or
can provide a small sample of LPC information for the data.

LPCW Options: Display Tab
From the Display Tab, set the following LPCW options:

Display Range (X-Axis) - Specifies the frequency range (x-axis) over which the LPC frequency
responses are displayed. The frequency range can be displayed as a percentage of the Nyquist
Frequency or as specific upper and lower frequency values.

Display Range (Y-Axis) - Controls the display range along the y-axis, in decibels of sound pressure
(dB SPL).

Skew Angle - Specifies the angle of the waterfall display to skew to the left or to the right. The
window is divided into four quadrants of equal size. When set to skew right, the start frame is drawn
in the bottom left quadrant and subsequent frames are drawn behind it and angled up and to the
right. When set to skew left, the start frame is drawn in the bottom right quadrant and subsequent
frames are drawn behind it and angled up and to the left.

Start Frame - Specifies whether the first or last frame of the analysis results is plotted at the front
of the waterfall array. Frames are plotted consecutively on the z-axis from first to last or from last to
first, with the start frame plotted in the lower left or right quadrant of the window, depending on the
setting for Skew Angle.

FFT Power Spectrum Options

From the Options menu, select Analysis, then FFT Power Spectrum. You can set the following FFT
Analysis Options:

Analysis Size - Specifies the number of coefficients in the FFT to be computed during analysis

Window Weighting - Controls the application of window weighting to a frame of sampled data that
is to be processed during FFT analysis. Window weighting is applied to reduce the amplitude of the
signal as it approaches a frame boundary. If a rectangular window is selected, its effect is to apply no
window weighting. A Blackman or Hamming window is recommended for speech processing.

Smoothing - The power spectrum can be displayed in block mode or point mode, with a smoothing
factor optionally applied to the spectral coefficients in point mode. Smoothing the energy in the
frequency domain of the power spectrum is done in order to suppress any harmonic ripple present in
the signal. The degree of smoothing to be applied depends upon the harmonic separation in the
signal and upon the frequency resolution of the power spectrum.

Pre-Emphasis - Determines the application of pre-emphasis and the value of the pre-emphasis
factor. If a value of O is entered, no pre-emphasis is applied.

Frame Size - Specifies the length of the frame of data to be analyzed. This can be equal to the
number of FFT coefficients (analysis size), can be delineated by voiced period marks (pitch-
synchronous), or can be another value expressed in number of sampled data points or in
milliseconds. The frame size cannot be greater than the analysis size. If the selected frame size is
less than the FFT analysis size, the frame is padded with zeros.

Display Range (X-Axis) - Specifies the frequency range (X-axis) over which the power spectrum
will be displayed. You can choose to display the frequency range as a percentage of the Nyquist
Frequency or as specific upper and lower frequency values.
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¢ Display Range (Y-Axis) - Controls the display range setting along the Y-axis, in decibels of sound
pressure (dB SPL). If normalization is on, this parameter is ignored.

e Frequency Report - specifies whether to report the x-axis value at the cursor location in Hz only, Hz
and Bark, or Hz and Mel.

FFT Waterfall Options

From the Options menu, select Analysis, then FFT Waterfall. There are a number of FFTW analysis
and display parameters that can be set by the user. Note that the FFT Waterfall Setup box contains three
(3) separate tabs. Click on the appropriate tab for the options you want to set, and then set the desired
parameters.

FFTW Options: Analysis Tab
From the Analysis Tab, set the following FFTW options:

e FFT Analysis Size - Specifies the number of coefficients in the FFT to be computed during analysis.
The FFT Analysis Size must be greater than or equal to the Frame Length.

e Pre-Emphasis - Determines the application of pre-emphasis and the pre-emphasis factor. If a value
of O is entered, no pre-emphasis is applied.

¢ Smoothing Level - The power spectra in the waterfall array can be displayed in Block Mode or
Point Mode, with a smoothing factor optionally applied to the spectral coefficients in Point Mode.
Smoothing the energy in the frequency domain of a power spectrum is done in order to suppress
any harmonic ripple present in the signal. The degree of smoothing to be applied depends on the
harmonic separation in the signal and on the frequency resolution of the power spectrum.

¢ Window Weighting - Controls the application of window weighting to each frame of sampled data
that is processed during FFT analysis. Window weighting is applied to reduce the amplitude of the
signal as it approaches a frame boundary. If a rectangular window is selected, its effect is to apply no
window weighting. A Blackman or Hamming window is recommended for speech processing.

FFTW Options: Framing Tab
From the Framing Tab, set the following FFTW options:

e Frame Advance - Specifies the frame advance for fixed-frame FFT calculation. The frame advance
can be equal to the number of coefficients in the FFT, or can be specified as a value expressed in
number of sampled data points or in milliseconds. Frame advance is independent of frame length, so
the analysis results can be for contiguous or overlapping frames, or can provide a small sample of
FFT information for the data.

e Frame Length - Specifies the length of each frame of data to be analyzed. Frame length can be
equal to the number of FFT coefficients (FFT Analysis Size), can be delineated by voiced period
marks in the sampled data (Pitch-Synchronous), or can be another value expressed in number of
sampled data points or in milliseconds. The frame length cannot be greater than the FFT analysis
size. If the selected frame length is less than the FFT analysis size, the frame is padded with zeros.

FFTW Options: Display Tab

From the Display Tab, set the following FFTW options:

e Display Range (X-Axis) - Specifies the frequency range (x-axis) over which the power spectra are
displayed. The frequency range can be displayed as a percentage of the Nyquist Frequency or as
specific upper and lower frequency values.

¢ Display Range (Y-Axis) - Controls the display range along the y-axis, in decibels of sound pressure
(dB SPL).
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e Skew Angle - Specifies the angle of the waterfall display to skew to the left or to the right. The
window is divided into four quadrants of equal size. When set to skew right, the start frame is drawn
in the bottom left quadrant and subsequent frames are drawn behind it and angled up and to the
right. When set to skew left, the start frame is drawn in the bottom right quadrant and subsequent
frames are drawn behind it and angled up and to the left.

e Start Frame - Specifies whether the first or last frame of the analysis results is plotted at the front
of the waterfall array. Frames are plotted consecutively on the z-axis from first to last or from last to
first, with the start frame plotted in the lower left or right quadrant of the window, depending on the
setting for Skew Angle.

LTA Power Spectrum Options

From the Options menu, select Analysis, then LTA Power Spectrum. You can set the following LTA
Analysis Options:

o Analysis Size - Specifies the length of the frame of data to be analyzed, in number of sampled data
points.

e Display Range (X-Axis) - Specifies the frequency range (X-Axis) over which the power spectrum
will be displayed. You can choose to display the frequency range as a percentage of the Nyquist
Frequency or as specific upper and lower frequency values.

e Display Range (Y-Axis) - Controls the display range setting along the Y-axis, in decibels of sound
pressure (dB SPL). If normalization is on, this parameter is ignored.

e Pre-Emphasis - Determines the application of pre-emphasis and the value of the pre-emphasis
factor. A value of 0 means no pre-emphasis is applied.

¢ Smoothing - The power spectrum can be displayed in BLOCK mode or POINT mode, with a
smoothing factor optionally applied to the spectral coefficients in point mode. Smoothing the energy
in values in the frequency domain of the power spectrum is done in order to suppress the harmonic
ripple present in the signal. The degree of smoothing to be applied depends upon the harmonic
separation in the signal and upon the frequency resolution of the LTA power spectrum.

o Window Weighting - Controls the application of window weighting to a frame of sampled data that
is to be processed. Window weighting is applied to reduce the amplitude of the signal as it
approaches a frame boundary. If a rectangular window is selected, its effect is to apply no window
weighting. A Blackman or Hamming window is recommended for speech processing.

Cepstrum Analysis Options

From the Options menu, select Analysis, then Cepstrum Analysis. You can set the following
Cepstrum Options:

e Time - Sets the time domain of the quefrency axis (X-Axis) over which the cepstrum will be
displayed. The time display range is in milliseconds. Select the Display All Data checkbox to display
all of the data, or clear the checkbox and enter values in the Minimum and Maximum edit boxes to
display a smaller specified range. Recommended time values are 0.1 and 12.0. When normalization
is applied to this display, it is normalized to the maximum and minimum values found within this
range.

o Level - Sets the amplitude display range (Y-Axis) for the cepstrum display. If normalization is turned
on, the parameter is ignored.
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Spectrogram Options

From the Options menu, select Analysis, then Spectrogram. There are a number of Spectrogram
analysis and display parameters that can be set by the user. The Spectrogram Analysis Configuration box
contains three (3) separate tabs. Click on the appropriate tab for the options you want to set, and then
set the desired parameters.

SPG Options: Analysis Tab
From the Analysis tab, you can set the following Spectrogram Options:

e Analysis Size - Specifies the number of sampled data points per frame that are to be applied to the
spectrogram. The number of data points translates to a spectrogram “bandwidth”, which is
interpreted by the program from the frame length and the sampling rate of the data in the source
window.

e |f the source window contains signal data, a Hertz value is reported in the Analysis Size box beside
each points value, along with a message that the displayed bandwidths are for analysis of the current
default source.

e Pre-Emphasis - Determines the application of pre-emphasis and the value of the pre-emphasis
factor. A value of 0 means no pre-emphasis is applied.

o Window Weighting - Controls the application of window weighting to a frame of sampled data that
is to be processed during SPG analysis. Window weighting is applied to reduce the amplitude of the
signal as it approaches a frame boundary. If a rectangular window is selected, its effect is to apply no
window weighting. A Blackman or Hamming window is recommended for speech processing.

SPG Options: Display Tab

From the Display tab, you can set the following Spectrogram Options:

e Display - Specifies the frequency range over which the spectrogram will be displayed. You can
choose to display the frequency range as a percentage of the Nyquist Frequency or as specific upper
and lower frequency values. The recommended maximum frequency is 40% of the sampling rate.

o Frequency Display - Specifies whether the display of the spectrogram will be shown in a
logarithmic scale, linear scale, Bark scale or Mel scale.

SPG Options: Palette Tab

From the Palette tab, you can set the following Spectrogram Options:

o Palette - Selects one of the preset color palettes to be used to display the spectrogram.

e Scale - Displays the decibel range assigned to evenly distributed gray shades or colors used to plot
the relative levels of energy in the spectrogram. You can change any of these values. Alternatively,
enter a minimum and maximum decibel level, and click the Smooth button (to the right) to create a
linear relationship to the values assigned to the interceding shades. Use the scrollbar to raise or
lower the overall color scale-to-gain assignment, to brighten or darken the display.

e Scale Adjustment - Specifies an adjustment in decibels of sound pressure (dB SPL) that is applied
to the color scale of the spectrogram, to lighten or darken the color scale.
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Formant History Options

From the Options menu, select Analysis, then Formant History. There are a number of FMT analysis
and display parameters that can be set by the user. Note that the Formant Analysis Configuration box
contains four (4) separate tabs. Click on the appropriate tab for the options you want to set, and then set
the desired parameters.

FMT Options: Analysis Tab
From the Analysis Tab, set the following FMT options:

e Filter Order - Selects the filter order, or the number of LPC coefficients, to be applied to each LPC
analysis frame.

e Pre-Emphasis - Determines the application of pre-emphasis and the value of the pre-emphasis
factor. A value of 0 means that no pre-emphasis is applied.

o Analysis Method - Selects the LPC analysis method. You have a choice of the autocorrelation or
covariance methods.

o Window Weighting - Controls the application of window weighting to a frame of sampled data that
is to be processed during FMT analysis. Window weighting is applied to reduce the amplitude of the
signal as it approaches a frame boundary. If a rectangular window is selected, its effect is to apply no
window weighting. Window weighting is recommended when using the autocorrelation method, and
the rectangular window is recommended when the covariance method is applied.

FMT Options: Framing Tab
From the Framing Tab, set the following FMT options:

e Pitch-Synchronous (Use Voiced Period Marks) - Selects calculation of formant history framing
from voiced period marks that are present in the data or from a fixed frame length.

e Unvoiced Frame Size - Specifies the length of the frame of data to be analyzed when performing
fixed frame analysis. During pitch-synchronous analysis, this variable is used for data in voiceless
regions only, and the voiced regions are analyzed using a frame length determined by the voiced
period marks.

e Frame Advance - Selects the time, in milliseconds, by which the analysis frame is advanced during
fixed frame analysis. Frame advance is independent of the frame length, so the FMT analysis results
can be for contiguous or overlapping frames, or can provide a small sample of FMT information for
the data. This option is disabled during pitch-synchronous analysis (i.e., Use Voiced Period Marks is
selected).

FMT Options: Display Tab
From the Display Tab, set the following FMT options:

o Display Range - Specifies the frequency range over which the formant history will be displayed.
You can choose to display the frequency range as a percentage of the Nyquist Frequency or as
specific upper and lower frequency values.

e Bandwidth Limit - Specifies whether to display all formants, or whether to set a threshold value of
the bandwidth, so that formants above the threshold are not included in the graphic display, and are
optionally excluded from the reported numerical results.

¢ Energy Limit - Specifies whether to display all formants, or whether to turn off LPC analysis in
frames whose signal energy is less than the set threshold value, so that formants in analysis frames
with energy below the set threshold are not included in the graphic display, and are optionally
excluded from the reported numerical results.
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e Only Voiced - Specifies whether to display all formants, or whether to turn off LPC analysis in
frames that are voiceless.

¢ Show Bandwidth - Specifies whether to display the bandwidth with each reported formant
frequency so that the length of the vertical line represents the bandwidth of the formant, or whether
to display the formant contours as a series of dots.

o Frequency Display - Specifies whether the display of the formant history will be shown in a
logarithmic scale, linear scale, Bark scale, or Mel scale.

FMT Options: Color Tab
From the Color Tab, set the following FMT options:
e Use Large Dots - Specify whether to display the formant history plot using large dots or small dots.

e Contour Colors - Specify the colors to display the formant contours. For improved observation and
editing purposes, a different color can be assigned to each formant. Alternatively, all formants can be
displayed using the window pen color.

Voiced Period Marks (Impulse) Options

From the Options menu, select Analysis, then Voiced Period Marks. You can set the following
Impulse Analysis Options:

e Analysis Range - Specifies the analysis range setting in Hertz. A narrower range can be set to
selectively examine a particular region of the signal, while a wide analysis range (for example, 50 to
1000 Hz) can be used successfully for most speech. Reducing the range can help to avoid erroneous
selection of harmonic periods in low-frequency signals.

e Location - Governs the location where the voiced period marks are placed during analysis. If Peak is
selected, impulse marks are placed at the dominant amplitude peak at the start of each voiced
period. This could be a negative or a positive peak depending upon the polarity of the signal. If Zero
Crossing is selected, impulse marks are placed at the zero crossing immediately preceding the
dominant amplitude peak at the start of each voiced period.

e Zero Offset - Specifies the zero offset in amplitude to compensate for any DC float that can have
been produced by the hardware. If the signal offset has been previously computed, the resulting
value is automatically used.

Pitch Contour Options

From the Options menu, select Analysis, then Pitch Contour. There are a number of Pitch analysis
and display parameters that can be set by the user. The Pitch Analysis box contains three (3) separate
tabs. Click on the appropriate tab for the options you want to set, and then set the desired parameters.

Pitch Options: Analysis Tab
From the Analysis tab, you can set the following Pitch Options:

¢ Pitch Synchronous Analysis - Specifies pitch synchronous (from impulse marks) or pitch
asynchronous (i.e., fixed frame) analysis. If this checkbox is selected and impulse marks are not in
the signal data, the pitch synchronous analysis process will compute impulse locations and store
them internally. If this checkbox is selected and impulse marks are in the signal, then the impulse
locations in the signal are used. If this checkbox is clear (unselected), fixed frame analysis is
performed using the frame length and frame advance settings specified on the Framing tab.
Interpolation is applied to the pitch analysis results (pitch synchronous or fixed frame) in order to
improve the resolution of the pitch analysis process.
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¢ Impulse Location - Specifies the location of the impulse marks computed during pitch synchronous
analysis. Options are at the dominant amplitude peak (which can be negative or positive, depending
on the polarity of the signal) at the start of each voiced period, or at the zero crossing immediately
preceding the dominant amplitude peak at the start of each voiced period. Note that this option is
disabled if the Pitch Synchronous Analysis checkbox is clear (unselected). If Pitch Synchronous
Analysis is selected and impulse marks are already in the signal, this setting is ignored.

e Analysis Range - Specifies the analysis range setting in frequency (Hertz) for accepting
fundamental frequency (pitch) analysis results. To avoid possible error, the analysis range should be
close to the expected fundamental frequency range.

o Process High Frequency Signal — Specifies analysis of a high-frequency signal. Use this setting to
obtain better results when analyzing some signals from a female or child’s voice. Note that this
option is disabled if the Pitch Synchronous Analysis checkbox is selected.

¢ Pitch Sensitivity — Specifies the sensitivity of the pitch analysis routine. If the pitch analysis does
not produce pitch values in expected locations (giving drop-outs in the analysis), increase the pitch
sensitivity. If the pitch analysis is detecting more pitch values than expected (giving spurious values
in the analysis), decrease the pitch sensitivity. Note that this option is disabled if the Pitch
Synchronous Analysis checkbox is selected.

¢ Smoothing Level - Optionally smooths the pitch contour by replacing the un-smoothed pitch results
with new values that are computed by applying median smoothing to the voiced frames that are
located within a specified time interval that is centered around the start of the current frame. The
duration of the time interval is 50 msec if a Low level of smoothing is selected, 100 msec for
Medium, and 200 msec for High. The number of adjacent frames that is used to smooth each
frame consists of all frames that lie completely within the time interval that corresponds to the
smoothing level selected. Select None to display the un-smoothed pitch results. Note that the Low
radio button is disabled if either the Frame Length or Frame Advance setting is greater than 25 msec.

Pitch Options: Framing Tab
From the Framing tab, you can set the following Pitch Options:

e Frame Length - During fixed frame (or pitch-asynchronous) analysis, specifies the length of a frame
of waveform data used for computing the fundamental frequency (pitch). Note that this option is
disabled if the Pitch Synchronous Analysis checkbox is selected on the Analysis tab.

e Frame Advance - Selects the time, in milliseconds, by which the analysis frame is advanced during
fixed frame analysis. Frame advance is independent of frame length, so the pitch analysis results can
be for contiguous or overlapping frames, or can provide a small sample of pitch information for the
data. The smaller the frame advance is, the more detail about the pitch characteristics becomes
available. Note that this option is disabled if the Pitch Synchronous Analysis checkbox is selected
on the Analysis tab.
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Pitch Options: Display Tab

From the Display tab, you can set the following Pitch Options:

o Display Range - Specifies the display range in frequency (Hertz) for the display of a pitch
contour. Note that the display range is set separately for pitch contours displayed on a
logarithmic frequency scale or a linear frequency scale. If normalization is on, this parameter is
ignored.

e Draw Dot Contour - Selects display of the pitch plot as a series of dots or as a solid line.

e Use Large Dots - If a dot contour display is selected, specifies whether to display the pitch
contour using large dots or small dots.

e Frequency Scale - Selects display of the pitch contour on a logarithmic or linear frequency
scale.

Energy Contour Options

From the Options menu, select Analysis, then Energy Contour. You can set the following Energy
Options:

Frame Length - Specifies the length of a frame of a data used for energy calculation. This parameter
specifies the frame length in voiceless regions only if pitch-synchronous analysis is used.

Frame Advance - Selects the time, in milliseconds, by which the analysis frame is advanced. Frame
advance is independent of the frame length, so the energy analysis results can be for contiguous or
overlapping frames, or can provide a small sample of energy information for the data. This parameter
is ignored during pitch-synchronous analysis.

Pitch-Synchronous - Selects calculation of energy frames from voiced period marks that are
present in the data (pitch-synchronous) or from a set frame length.

Draw Dot Contour - Selects display of the energy plot as a series of dots or as a solid line.

Use Large Dots — If a dot contour display is selected, specifies whether to display the energy
contour using large dots or small dots.

Smoothing Level - You can optionally apply smoothing to the computed energy values across
adjacent frames.

Display Range - Specifies the display range in decibels of sound pressure (dB SPL) for the display
of the energy contour. If normalization is on, this parameter is ignored. Note that the display range is
automatically adjusted by the energy shift value if the Energy Shift checkbox is selected.

Energy Shift - Specifies whether to shift the calculated energy values by a set shift value, to adjust
the dB values to approximate real-world dB SPL. If the Energy Shift checkbox is selected, the shift
value can be entered in the associated edit box.
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6-9-2 Edit Options

Signal Offset Options

From the Options menu, select Editing, then Signal Offset. You can set the following offset
parameters:

e Automatic vs. Manual - Specifies whether the offset value be computed automatically and applied
to the signal data, or whether a manually set offset value be applied to the signal data.

e DC Offset Value - Specifies the DC offset if a manually set offset value is to be applied to the signal
data.

Copy Options
From the Options menu, select Editing, then Copy. You can set the following Copy Options:

o Channels - If the signal is multi-channel, you can select which channel(s) of the data to copy.
Options are to copy only the displayed channel, to copy all channels, or to copy selected channels
from the source waveform to the active window.

e Copy As - If copying only the displayed channel, you can select which channel in the active window
to copy the data to.

e Signal Attributes - You can select which attributes of the signal you would like to include with the
copied data. If the following attributes are present in the source data, they can be copied along with
the waveform signal: Impulse marks (voiced period marks), IPA transcription, Tags, or Palatometer
Images. A check mark appears in the box beside the attribute description if that signal information
will be copied along with the waveform data.

Append Options
From the Options menu, select Editing, then Append. You can set the following Append Options:

¢ Signal Attributes - You can select which attributes of the data you would like to include with the
appended data. If the following attributes are present in the data, they can be appended with the
data: Impulse marks (voiced period marks), IPA transcription, Tags or Palatometer Images. A check
mark appears in the box beside the attribute description if that signal information will be appended
with the waveform data.

e Channels - If the signal is multi-channel, you can append all channels of data or just the displayed
channel.

Insert Options
From the Options menu, select Editing, then Insert. You can set the following Insert Options:

e Signal Attributes - You can select which attributes of the data you would like to include with the
inserted data. If the following attributes are present in the data, they can be inserted with the data:
Impulse marks (voiced period marks), IPA transcription, Tags or Palatometer Images. A check mark
appears in the box beside the attribute description if that signal information will be inserted with the
waveform data.

e Channels - If the signal is multi-channel, you can insert all channels of data or just the displayed
channel.
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Mix Options
From the Options menu, select Editing, then Mix. You can set the following Mix Options:

o Perform Signal Averaging - A check mark in the Perform Signal Averaging box indicates that
waveforms will be mixed by averaging the waveform amplitude values. Clear this box to mix the
waveforms by adding the waveform amplitude values. Values that cause overflow are clipped to the
maximum amplitude value of 32767, and are displayed in red.

Filter Options
From the Options menu, select Editing, and then Filter. You can set the following Filter Options:

e Filter Order - Sets the filter order, or number of poles that are applied to the filter, between a
minimum of 4 and a maximum of 250. The higher the order, the steeper the cutoff of the filter. For a
band-pass or band-reject filter, the number of poles selected is divided evenly between the low and
high cutoffs.

o FilterType - Can be Low Pass, High Pass, Band Pass or Band Reject.
e Alow-pass filter attenuates any energy in the signal that is above a set frequency.
e A high-pass filter attenuates any energy in the signal that is below a set frequency.

e A band-pass filter attenuates any energy in the signal that is outside the set lower and upper
frequency cutoffs.

e A band-reject filter attenuates any energy in the signal that is inside the set lower and upper
frequency cutoffs.

o WindowType - Can be Rectangular, Triangular, Hamming, Blackman, or Hanning. For speech
signals, it is advised that a Blackman or a Hamming window be used.

e Cutoffs - Cutoffs are relative to the Nyquist frequency, which is half the sampling rate. To determine
a cutoff percentage, use the formula:
cutoff %= (Shoulder Frequency / Nyquist Frequency) * 100%

For example, to set a low-pass filter at 2000 Hertz in a signal sampled at 10000 samples per second,
the cutoff would be 40%.

Source Signal Duration Options

From the Options menu, select Editing, then Source Signal Duration. You can set the following Rate
Synthesis Options:

¢ Rate Modification - Specifies the percentage change in the duration from the original. The duration
can be decreased to a minimum of 30% of the original data duration, or increased to 300% or 3
times the original duration. A setting of 100% has the effect of making no change to the duration of
the data.

¢ Processing Options - Specifies whether to generate audio output of the time-modified signal data,
or whether to generate a new signal from the modified data, displaying the waveform in the empty
active window.
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o Horizontal Axis Divisions per Interval: Specifies the number of divisions within each major grid
interval on the horizontal axis. If Grid Layout by Data Type is not selected, this setting is ignored.
Note that horizontal grid lines are not displayed unless the Grid on Horizontal Axis checkbox is
selected.

o Horizontal Axis Show Grid Labels: Specifies display of grid labels at each major grid interval on
the vertical axis. If not selected, labels are displayed only at the extreme edges of the display area. If
Grid Layout by DataType is not selected, this setting is ignored. Note that horizontal grid lines are
not displayed unless the Grid on Horizontal Axis checkbox is selected.

¢ Horizontal Axis Mark Intervals with Lines: Specifies whether major grid intervals on the
horizontal axis are displayed as lines across the window or as tick marks. If Grid Layout by Data
Type is not selected, this setting is ignored. Note that horizontal grid lines are not displayed unless
the Grid on Horizontal Axis checkbox is selected.

e Vertical Axis Grid Interval: Specifies placement of major grid lines on the vertical axis (i.e.,
horizontal lines). If Grid Layout by Data Type is not selected, this setting is ignored. Note that
vertical grid lines are not displayed unless the Grid on Vertical Axis checkbox is selected. If the set
grid interval will cause the labels to overlap, fewer labels are used.

e Vertical Axis Divisions per Interval: Specifies the number of divisions within each major grid
interval on the vertical axis. If Grid Layout by Data Type is not selected, this setting is ignored.
Note that vertical grid lines are not displayed unless the Grid on Vertical Axis checkbox is selected.

e Vertical Axis Show Grid Labels: Specifies display of grid labels at each major grid interval on the
vertical axis. If not selected, labels are displayed only at the extreme edges of the display area. If
Grid Layout by DataType is not selected, this setting is ignored. Note that vertical grid lines are
not displayed unless the Grid on Vertical Axis checkbox is selected.

e Vertical Axis Mark Intervals with Lines: Specifies whether major grid intervals on the vertical axis
are displayed as lines across the window or as tick marks. If Grid Layout by DataType is not
selected, this setting is ignored. Note that vertical grid lines are not displayed unless the Grid on
Vertical Axis checkbox is selected.
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7 Windows and Work Area

CSL and Multi-Speech can have up to 26 windows open at once, titled in alphabetical order from A to Z.
This section details source and active windows, linking and unlinking windows, and options
customizations.

7-1-1 Open New Window

You can create and display up to 26 windows at a time in the work area. The window labels are in
alphabetical order, from A to Z.

Open a new window:

1. To open a new window based on the active window, choose Open New Window from the
Window menu.

A new window is created and activated over the previously active window. The size of the new
window is the same as the previously active window. The new window will also have the same
display settings. If no windows were displayed in the work area prior to executing this command, the
settings for window size, position and attributes are taken from an initialization file.

A scrollbar can optionally be displayed in the window. This scrollbar represents the full range of data
in the window. A red indicator above the scrollbar shows the location of the data cursor in the
window, a green indicator shows the location of the data mark, and two blue indicators show the
locations of the selection marks in the data.

2. Position the mouse arrow over the window title bar and, holding the Left mouse button down, drag
the window to the desired location in the work area. Use the mouse arrow and Left mouse button to
change the size of the window.

7-1-2 Open Preset Window

1. From the Window menu, choose Open Preset Windows.

2. Select one of the following options to create and activate a new window which is the appropriate
size for the selected type of data:

For Waveforms etc.

For Spectrograms etc.

For Analysis Contours etc.
For Frequency Response etc.

3. You can resize the window if desired, and drag it to a convenient location within the work area. To
move the window, position the mouse arrow over the window title bar, then hold the Left mouse
button down while dragging the window to the desired location in the work area.

4. You can also change the window attributes, such as the color to display graphics within the window
and the placement of grid lines in the window.
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7-1-3 Closing Windows

If you find that your work area is becoming cluttered, you can want to close one or more of the windows
that are currently displayed. Note that when you close a window, any data associated with the window is
lost.

1. To close the active window, choose Close Active Window from the Window menu.
The active window is removed and the next window in the list becomes the active window.

2. To close all of the open windows, select Close All Windows from the Window menu.

7-1-4 Clear (Purge) Window Contents

You can clear the contents of a window, creating an empty window, ready to display new waveform or
analysis data.

To clear the active window:

» From the Window menu, choose Purge Active Window.

The data in the active window is deleted. Note that if the data in a linked window are purged, that
window is automatically removed from the link list.

7-1-5 Make a Window Active

Many program operations use the currently active window. For example, when loading a sampled data
file, the program loads the signal to the active window. Up to 26 windows, labeled A through Z, can be
open at one time. You can select which window is active in a number of ways, as described below. Note
that when you create (open) a new window, it automatically becomes the active window. A window
must already exist in the work area before it can be activated.

To activate the next or previous window in alphabetical order

» Choose Activate Next Window or Activate Previous Window from the Window menu.
Windows that are minimized cannot be accessed using this method.

To activate any existing window (not necessarily the next or previous window in alphabetical order),

» Click the Left mouse button on the title bar of any window displayed in the work area to activate it.
To activate a minimized window, simply restore it.

7-1-6 Link and Unlink Windows

You can link cursor movement, data mark movement, selection area definition, and data display
operations in the active window with another window containing compatible data. Note that if the data in
a linked window are purged, that window is automatically removed from the link list.

To link windows:

1. Ensure that the data in the windows you wish to link have the same horizontal dimension. The
windows need not be the same duration, however. (If the durations are different and the windows
are linked, you can use the show operation to align the linked waveforms.)

2. To link the active window to the default source window, choose Link Windows, Link to Source
Window from the Window menu.

3. You can activate a different window, and then repeat Step 2 to link operations in more than two
windows.
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4. Move the cursor around in one of the linked windows and note how cursor movement is duplicated
in the other linked windows. Select a region of data in a linked window and display the selected data.
The selection area is redisplayed in all linked windows.

To unlink the active window in the link list:
> Select Link Windows, Unlink Active Window from the Window menu.
To display a list of linked windows:

» Select Link Windows, Show Current Links from the Window menu. A list of the windows that
are currently linked to the active window is displayed.

7-1-7 Multi-Channel Windows

Note that the program supports the display of more than one channel of data in the window. Optionally, a
single channel of the signal can be displayed in the window at any given time, or all channels can be
displayed.

Here is a display of a window containing multi-channel signal data with all channels displayed.

@ Note It is rare in clinical applications to use more than two channels, but CSL and Multi-
Speech support up to eight.
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Figure 25. Active window with multi-channel signal data.

The loaded signal file contains five channels of data and is divided into a pane for each channel. The title
bar for the Channel 1 pane is highlighted, indicating that Channel 1 is the currently active channel. Click
on the title of a different pane to activate a different channel
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7-1-8 Select Source Window

When waveform data are loaded, generated, or captured to a window, that window automatically
becomes the default source window. The current default source window is reported in a box in the lower
right-hand corner of the work area. Many of the data analysis and data editing commands are performed
on the waveform in this default source window.

If more than one window containing waveform data is displayed, you can want to analyze a signal that
was obtained earlier than the current default source signal. You must change the default source before
the operation takes place.

To select the Active window as the default Source:

» Activate the window containing the waveform data you wish to use as the source data for analysis,
and then choose Select Active Window as Source from the Window menu.

7-1-9 Display Information about Window Contents

You can display an information box containing the summary information for the waveform data or results
data in the specified window.

Note that if the active window contains waveform data, the information box will inform you if IPA
Transcripts, Voiced Impulse Marks (voiced period marks); Tags, and/or Palatogram information have been
added to the displayed channel of the signal. These types of information, though stored with the
waveform, are not always displayed in the window. Select Waveform from the Options menu to
display a dialog box in which you can select the signal attributes to display or hide.

To display information on the active window:

1. Activate the window that you want information on, and then choose Information on Active
Window from the Window menu.

If the active window contains waveform data, summary information is displayed for the current
channel of data in the window. If the data is multi-channel, you can click the radio button for a
different channel of data to display summary information for that signal data. If you wish, you can add
to or change the comment in the Comment Field of the Information box. This textual information is
stored with the waveform data when the file is saved in CSL signal file format (NSP), but will be lost
if the data are saved in any other audio file format.

If the active window contains analysis results data, the information box will display the type of
analysis, information identifying the source window for the analysis data, and the analysis parameter
settings. For all analysis data except transient data, the box contains a Comment Field for entry of
textual information.

2. An Apply button is present in the Spectrogram Analysis Information box. You can change the display
settings from the Palette tab of the summary information box, and then apply the change to the
spectrogram display in the active window. For example, you can change the color palette or change
the decibel values assigned to the gray shades or colors used to plot the relative levels of energy in
the spectrogram.

3. Choose the OK button, remove the information box from the work area, and save any changes
made. Choose Cancel to close the information box without saving any changes.
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7-1-10 Window Features

CSL and Multi-Speech are extremely versatile programs, and you can customize much about what and
how each window is displayed.

To change window options:

1. Click inside the window you want to change options in, making sure it is listed as the Active Window
in the bottom right of the application.

2. At the Options menu, select Window Attributes. You can set the following Window Display
Options:

e Normalize - Governs application of normalization to non-transient data. If normalization is
applied, graphics are drawn with the maximum and minimum y-axis values defining the display
range.

e Show Grid - Overlays horizontal and/or vertical grid lines across the window. Click the Grid
Options button to display a Grid Layout box in which you can fine-tune the display of the grid.

o Display Scrollbar - Displays a scrollbar under the horizontal axis of the active window. If a
scrollbar is displayed in the window, the window can be set to update the graphic display during
scrolling or after scrolling.

o Pen Color - Selects the color to draw graphics. Also provides the ability to optionally define a
new pen color, and add it to the list of available pen colors.

Double-clicking on the Active (leftmost) or Next (rightmost) pen color indicator in the window status
line to display a box of color swatches, and then selecting a new color from the displayed box.

Grid Layout Options

If the Show Grid checkbox is selected in the Windows Options box, grid lines are overlaid on top of the
graphics display in the window. From the Window Options box, click the Grid Options button to display
a Grid Layout box, in which you can fine-tune the grid overlay.

e @Grid on Horizontal Axis: Overlays grid lines across the window on the horizontal axis (vertical
lines). Grid lines can be placed automatically by the program, or placed manually at specified intervals
if the Grid Layout by Data Type checkbox is selected.

e Grid on Vertical Axis: Overlays grid lines across the window on the vertical axis (horizontal lines).
Grid lines can be placed automatically by the program, or placed manually at specified intervals if the
Grid Layout by Data Type checkbox is selected.

e Grid Color: Selects the color of the grid lines.

e Grid Layout by Data Type: Specifies whether grid lines are placed automatically by the program
(i.e., the checkbox is clear) or placed manually at user-specified intervals based on the type of data in
the window (i.e., the checkbox is selected). If manual placement is selected, optionally define major
grid intervals, number of divisions within each grid interval, display of grid labels, and display of the
major grid as lines across the window or as tick marks. Note that grid lines are only displayed if the
Grid on Horizontal Axis and/or Grid on Vertical Axis checkbox is selected, regardless of whether
they are placed manually or automatically.
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o DataType: Lists the types of data that can exist in a window, e.g., signal data or analysis results
data. Grid placement for each data type can be defined separately if the Grid Layout by Data Type
checkbox is selected.

¢ Horizontal Axis Grid Interval: Specifies placement of major grid lines on the horizontal axis (i.e.,
vertical lines). If Grid Layout by Data Type is not selected, this setting is ignored. Note that
horizontal grid lines are not displayed unless the Grid on Horizontal Axis checkbox is selected. If
the set grid interval will cause the labels to overlap, fewer labels are automatically used.

7-1-11 Work Area Layout
Routines are provided which allow you to open and close windows in the work area. Commands also
exist for cascading and tiling the existing windows in the work area.

You can rearrange the windows in the work area so that they are cascaded or tiled. This does not affect
any data in the windows. Minimized windows remain minimized.

To rearrange the windows in the work area:

e To overlap (cascade) the windows with the active window in front and the title bar for each window
is visible, select Cascade from the Window menu.

e To redraw the windows with similar sizes so they all are fully displayed in the work area, do one of
the following:

o To rearrange the windows into horizontal tiles, select Tile Horizontally from the Window menu.

e To arrange the windows into vertical tiles, select Tile Vertically from the Window menu.
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7-1-12 Minimize, Maximize and Restore Windows

Windows can be minimized, maximized and restored in the work area in the same manner that
application windows can be minimized, maximized, and restored within Windows. Maximize a window to
better display the data. Shrink a window to an icon when you finish working with the data in it, but want
it available for later use. The data are still held in memory, but the window is not taking up space in the
work area.

To maximize a window:

» Click the Maximize button in the upper right-hand corner of a window to fill the work area with the
contents of the window.

To minimize a window:

» Click the Minimize button in the upper right-hand corner of a window to shrink the window to an
icon. Each icon includes a title which identifies both the window label and contents. If the icon
represents a window containing multiple analysis plots, the topmost plot is identified.

To restore a window:

> To restore the window, access the Window menu, and then click on the window title at the bottom
of the menu. This will both restore a minimized window and activate it. The window is restored in
the work area to its original size and placement.

7-1-13 Window Display Settings

You can change the window display settings for the active window, such as the pen color and the
placement of grid lines in the window. Changing the pen color is a particularly useful feature if, for
example, the results of more than one analysis are to be overlaid in a window.

To set the window options:

1. To set the display options for the active window, choose Window Attributes from the Options
menu. A box appears in which you can change the window options.

Window Options @

Display Options Pen Colar
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Global and Window "A"

[ OK ] | Cancel |

Figure 26. Window Options dialog box.

Alternatively, click the Right mouse button inside any open window to activate the window and
display a pop-up menu. Select Window Options from the pop-up menu to display the Window
Options box.
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2. Once you change a window display setting, you can redisplay the existing data with the new window
settings if you wish to change the display properties of the existing data. This can be done from
within the Window Options dialog box by clicking the Apply button. Note that if the window
contains multiple analysis data, only the topmost data will be redisplayed using the new settings. The
display of earlier analysis results is not affected.

3. To close the dialog box and save the changes to the parameter settings in the initialization file, click
OK. To close the dialog box without saving the changes, click Cancel.

4. If you did not apply the changes to the existing data from within the Window Options dialog box, you
can redisplay the topmost data with the new window settings by selecting a display range (e.g., All
Data) from the View menu.

Two color swatches appear on the left side of the status line of each window. The leftmost swatch
reports the color of the current (active) plot in the window, and the rightmost swatch reports the color
that will be used to draw the next plot in the window.

To quickly change the pen color:

1. To change the color of the current (active) plot, double-click on the leftmost color swatch, then select
a new color from the displayed box of color swatches. The topmost graphic in the window is
redrawn with the newly selected “Active” pen color.

2. To set the color for the next plot, double-click on the rightmost color swatch, then select a new color
from the displayed box of color swatches. The next graphic drawn in the window will be plotted
using the selected “Next"” pen color.

To change the grid layout:

1. If the Show Grid checkbox is selected in the Windows Options dialog box, grid lines are overlaid on
top of the graphics plot in the window. The placement of these grid lines can be fine-tuned.

2. In the Windows Options box, click the Grid Options button to display a Grid Layout box in which
you can set the grid layout. Options include laying a grid on the horizontal axis and/or vertical axis,
and setting the grid color. Fine-tune the grid by specifying the grid interval and the number of
divisions (which are separated by ticks) per major interval, and optionally display grid labels and draw
lines for the interval divisions.

Grid Layout @@
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Divisions per Interval 747 B ‘ Divisions per Interval 1 2|
Show Grid Labels Show Grid Labels
[VIMark Intervals with Lines [[IMark Intervals with Lines

Figure 27. Grid Layout options for signal data.

3. Once changes are made to the grid layout, click OK to return to the Windows Options box, where
you can optionally click the Apply button to apply the changes to the active window.
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7-1-14 Palatogram Plot

A palatogram plot displays points of contact between the tongue and the palate as a means of showing
how speech sounds are produced. Waveform and palatogram information can be stored in a single
sampled data file. (This must be done externally to the program). This data file can then be loaded into
the active window in the work area in order to study the palatogram results.

To display the palatogram information:

1. Ensure that palatogram information is stored with the waveform data in the active window. Select
Information on Active Window from the Window menu to display a dialog box containing
information about the signal. The small box beside the Palatogram description will contain a check
mark if Palatometer Data are present.

2. To display the palatogram plot, select Waveform from the Options menu to display a dialog box for
setting signal display options. Select the Palate attribute checkbox. A check mark will appear in the
small box beside the Palate description.

A separate palatogram window will be opened in order to display the palatogram information at the
current cursor location. Drag this window to any desired location in the work area.

The points of contact are shown as colored squares as opposed to the neutral background squares
indicating no contact. (These colors are determined by your Windows setup when you first start the
program: the contact color is the same as the Active Title Bar color setting, and the neutral color is
the same as the Inactive Title Bar color setting.) Move the data cursor through the waveform data
and observe the corresponding activity in the palatogram window.

To remove the palatogram display:

1. To hide the palatogram display box, select Waveform from the Options menu to display a dialog
box for setting signal display options. Then clear the Palate attribute checkbox. The check mark will
disappear from the small box beside the Palate description.

2. The palatogram plot will be hidden from view, but the information is still stored with the waveform
data and can be redisplayed later.

7-1-15 Waveform Data Display Options

Waveform data can have IPA Transcriptions, Impulse Marks (voiced period marks), Tags, and/or
Palatogram information stored with it. These signal attributes can be displayed in the window with the
waveform or they can be hidden from view. In addition, waveform data that are saved in CSL signal file
format can contain up to eight (8) channels of data, and waveform data in WAV format can contain up to
two (2) channels of data.

To determine which signal attributes are present and the number of data channels in the waveform data
in the active window:

1. Select Information on Active Window from the Window menu.
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2. From the Options menu, select Waveform. You can set the following Waveform Data Display
Options:

e Impulse Marks - If the waveform data contains impulse marks (voiced period marks), specifies
whether to display these impulse marks in the waveform data. Note that removing impulse
marks from the window does not remove them from the waveform, but simply hides them.

o Tags - If the waveform data contains tags, specifies whether to display these tags with the
waveform data. Note that removing tags from the window does not remove them from the
waveform, but simply hides them.

e Display Palate Window - If the waveform data contains palatogram information, specifies
whether to display a palatogram plot to accompany the waveform data. Note that removing the
palatogram plot from the window does not remove the palatogram information from the
waveform, but simply hides it.

e UpperTranscription Line - One or two data fields can be optionally displayed for entry of IPA
characters. Specifies whether to display IPA Line 1. If both transcription lines are displayed, radio
buttons are activated allowing you to select which line is active (editable). Symbols in the active
line will be drawn in black, while symbols in the inactive line will be in gray. Note that removing
the upper transcription line from the window does not remove the IPA transcripts from the
waveform, but simply hides them.

e LowerTranscription Line - One or two data fields can be optionally displayed for entry of IPA
characters. Specifies whether to display IPA Line 2. If both transcription lines are displayed, radio
buttons are activated allowing you to select which line is active (editable). Symbols in the active
line will be drawn in black, while symbols in the inactive line will be in gray. Note that removing
the lower transcription line from the window does not remove the IPA transcripts from the
waveform, but simply hides them.

e Display All Channels - For multi-channel signal data, specifies whether to display a single
channel of data or all channels of data.

7-1-16 Put Previous Plot onTop

A window can contain any number of compatible analysis results. If multiple analysis results are present
in a window, you can scroll through the analysis data, causing the current data to move to the end of the
analysis results list and the previous data to become current (topmost in the list).

Note that when you overlay multiple analysis results in a window, it can be helpful to display each
calculation in a different color. For example, after generating a gray-scale spectrogram, you can overlay
the formant history in red, the pitch contour in blue, and the energy contour in green.

To recall the previous analysis results in the active window:

1. Ensure that the results from more than one analysis are overlaid in the active window. The window
title identifies the current (topmost) analysis data.

To scroll through the analysis results, choose Put Previous Plot on Top from the View menu.

3. The current analysis results are moved to the end of the results list and the previous data are brought
to the top of the list. The window title changes to reflect the current analysis data.

4. You can display information about the current analysis. You can also display numerical results and
result statistics for the current analysis data. Note that, because spectrogram data are transient,
statistics and numerical results are not available.
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7-1-17 Help Menu

Open Help

This manual is available in both printed form and as a .pdf file.

7-1-18 Display Information about the Program

You can display a box containing information about the program.
» Todisplay this information box, select About from the Help menu.

A box displays the version of the program along with information about the creators of the program.
After reviewing the displayed information, click OK to remove the box from the work area.
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Writing and Running Macros

Introduction

A macro (or command file) is a text file that contains a list of commands that are sequentially executed
when the selected macro is run. Macros provide an easy way to repeat a series of commands that would
otherwise have to be implemented one at a time. If any process you are performing requires repetitive
steps, consider using a macro to speed up the process. Also, macros ensure that the exact same
sequence of commands is used each time and are; therefore, useful for research protocols, teaching
exercises for students, and clinical protocols.

You can create a command file while executing commands by setting the program to “learn” mode. All
subsequent commands and command parameters that are executed (with the exception of macro
commands) will be recorded to a macro file.

This application is delivered with many demonstration macros, which can have utility as written. More
importantly, the demonstration macros not only illustrate the features of the program, but the usefulness
of macros as well. Experiment with these macros to learn more about the program and how macros can
be used.

List of Delivered Macros with Description

Macro Directory and Name Description

..\macros\clinical\

als.mac SPG with FMT of model versus subject target word (e.g.,
hail, sew, sigh, wax).

breathy.mac LTA of model versus subject sustained “ah.” Shows energy
above 6 kHz in “breathy” voicing.

cepstrum.mac Cepstral analysis of model versus subject sustained “ah.”

pitch.mac Pitch and energy analysis of stimulus file versus subject
attempt.

spgnarrow.mac Narrow-band SPG analysis of model versus subject
utterance.

spgwidw.mac Wideband SPG analysis of model versus subject utterance.

.\macros\demo\

demo.mac Demonstration of multiple analyses in single window, and
the RECALL and REMOVE features, SPG, Pitch, Energy,
FFT, and LPC.

dipth1.mac Demonstration of pitch-synchronous LPC analysis at

multiple locations in captured data, placing all plots in a
single window and providing instructions for using the
RECALL and RESULTS functions for recalling earlier plots
and examining results.
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Macro Directory and Name

Description

dipth2.mac

Demonstration of pitch-synchronous FFT analysis at
multiple locations in captured data, placing all plots in a
single window and providing instructions for using the
RECALL and RESULTS functions for recalling earlier plots
and examining results.

fmt.mac

formant1.mac

formant2.mac

Ipc.mac
mark.mac

multi.mac

overlay.mac

paljoe.mac

pch_eng.mac
phone.mac

pitchtst.mac

rainbow1.mac

Demonstration of typical speech analysis (pitch energy,
SPG [wide and narrowband], formant, FFT, and LPC
analyses).

Comparative analysis of vowel using Cepstrum, pitch-
synchronous LPC and pitch-synchronous FFT.

Analysis of sustained vowels using Cepstrum and long-term
LPC.

LPC of subject vowel.
Demonstration of selecting and marking features.

Demonstration of multi-pane display capability and analysis
of multiple channel signals (e.g., Lx ).

Macro to demonstrate overlaying and recalling analysis
results in a single window.

Demonstration of palate window, IPA transcription, tagged
signals, and linked windows.

Overlaid pitch and energy analysis of subject utterance.
Demonstration of filtering using simulated phone line filter.

400 Hz sine wave sampled at various rates for purpose of
audio card testing.

Sequential LPC analysis of a diphthong, to illustrate placing
large numbers of analysis results in a single window.

rainbow?2.mac

ratex.mac

sampling.mac

Sequential pitch-synchronous FFT analysis of a diphthong,
to illustrate placing large numbers of analysis results in a
single window.

Demonstration of Ratesyn function.

Vocal utterance sampled at various rates to illustrate audio
card capabilities and advantages of higher sampling rates.
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Creating a Macro Flowchart

Creating a macro is generally a four-step operation:

1.
2.

Determine the commands necessary to implement what you want to do.

Create files containing the text of any messages to be displayed to the user during macro execution.
It is recommended that these files be saved in HTML format, for best display results; however, text
files can also be called, although the display is less attractive.

Configure the workspace, adjust the desired settings, and save these settings to a configuration file
(i.e., an INI file).

Author a macro by first calling the desired INI file and then execute the desired commands. Save this
macro to a file for later recall.

There are a number of detailed operations within these four general steps. These operations are
described in the following flowchart:

Outline what you want the macro to do.

v

Set the workspace (e.g., windows) and set all parameters (e.g., spectrogram bandwidth).
You can wish to use a previously defined configuration file and then modify it.

N

Use an HTML editor or text editor to create separate message files containing the text of
each message to be displayed to the user during macro execution. These message files
must be stored in the same folder as the macro file.

v
Store workspace and set parameters to a configuration file: an .INI file (e.g., TEST.INI).
Save this configuration by selecting Macros, Configuration, Save Current Configuration for
Macro.

v

Start recording the macro. Click Macros on the Main Menu and then Record, or use a text editor
(e.g., Notepad.exe) to store a set of commands.

N

First commands to store are commands to recall desired INI while specifying that you do
not wish to save these changes by adding SET FROM before the INI file (e.g., SET FROM
filename .INI) and set window work area by using the commands WINDOW RESET
WORKAREA. To accomplish above, select Macros, Configuration, Reset To Saved Macro
Configuration.

\Z

Add operational commands to acquire, load, analyze, and speak signals. These can be recorded in
Macros on the Main Menu and then Record or use a text editor.
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N

If you wish to change a set parameter from the setting in the INI during a macro, remember to reset to
prior condition after using new set parameter.

\Z

End macro by adding line to set to previous working environment before macro was
evoked by typing two lines at end of macro SET FROM.NOSAVE INI or select Macros,
Configuration, Return To User Settings at End of Macro.

v

Use text editor (e.g., Notepad) to alter and enhance macro and INI. Save without exiting and rerun
macro while editor is resident. [Alt-tab] back and forth between macro, .INI, and Multi-Speech until
macro performs as desired. Always save from editor before running macro.

8-4 Creating a Macro

Creating a macro is straightforward. First, set up the settings and save the configuration. Then proceed
to create your macro as follows:

1. Evoke the learn function by selecting Macros from the Main Menu, then Record. A dialog box
appears.

Macro - [<untitled>] @@

Macro Commands

SET FROM

WINDOW RESET WORKAREA
USE A

PURGE =

CAPTURE

SOURCE =

USEB

SPG! 0=

SET FROM.NOSAVE INI

Figure 28. Macro Commands

When you create a macro, include a command at the beginning to set the parameters appropriately
for the task by activating a saved configuration file (i.e., SET FROM NAME.INI). You can select this
INI from the command line or from the dialog box from Macros on the Main Menu, Configuration,
and then Reset to Saved Macro Configuration....

2. Reconfigure the work area by using the command line (i.e., WINDOW RESET WORKAREA). This will
be done automatically for you if you selected Reset to Saved Macro Configuration... from the
menu.
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3. Add the commands you want to implement. Include a command at the end of the macro to restore
the settings that existed before macro execution began by activating the previous configuration file
(i.e., SET FROM.NOSAVE INI). Select Macros on the Main Menu, Configuration, and then Return
to User Settings at End of Macro.

Therefore, all macros will share a structure as follows with filename .INI representing the name of
the INI file called for in the macro and “Insert command 1-3 here” representing the list of commands
included in the macro:

SET FROM filename.INI
WINDOW RESET WORKAREA
Insert command 1 here

Insert command 2 here

Insert command 3 here

Etc.

SET FROM.NOSAVE INI

4. Macro files can also be created externally to the program. Use any standard text editor to create or
edit a macro file containing a series of commands, which the program will recognize and perform. If
you use a word processor to write or edit a macro, remember to store it as a .TXT file (e.g., not a
.doc). This file of commands is then named and saved.

8-4-1 Displaying or Hiding the Macro Dialog Box

If you entered macro “learn” mode by selecting Macros on the Main Menu, then Record, the macro
dialog box is automatically displayed. If you entered macro mode from the command line, or if you
have hidden the macro dialog box, you can view a macro dialog box by typing MACRO DISPLAY on
the command line or by selecting Macros from the Main Menu, then Display Commands. This box
displays the macro commands as they appear in the command file. Also, several buttons, which
execute certain macro commands, appear inside the box. If the macro has been named, the filename
appears at the top of the dialog box.

» To remove the box from the work area, click on Hide inside the macro dialog box, or type MACRO
HIDE on the command line.

8-4-2 Removing a Command from the Macro

Commands can be entered by using the command line, the menu line, the toolbar, or predefined keys.
Commands executed using a window dialog box are recorded, but the selection made within the dialog
box is not recorded. Therefore, if you use a dialog box to make selections, you will need to text edit the
macro later to add specific information.

1. If the last command was incorrectly specified, you can delete it from the command file by typing
MACRO UNDO on the command line or by selecting Macros from the Main Menu, then Delete
Last Command.

Alternatively, if the macro dialog box is displayed in the work area, you can select any line in the
Macro Commands box that you want to delete and click Undo. Then, click within the application
work area and continue recording your macro.
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8-4-3 Saving the Macro Without Exiting Macro Learn Mode

1. In order to save a macro without exiting learn mode, do one of the following:
o Type MACRO SAVE on the command line.
e From the Macros menu, select Save.
e |f the macro dialog box is displayed, click Save.

2. The program will display a Save Macro File dialog box. Select the directory location for the macro file
and enter a filename. Then click Save or press Enter to save the macro.

3. The program will automatically add a .MAC extension to the file when it is saved.

Running a Macro

Once you have created and saved a command file, you can run it from within the program. Note that, as
a rule, the first command in a macro is to reconfigure the work area so that windows are displayed and
program parameters are set appropriately. Existing windows, and all data in them, are deleted before the
new windows are displayed. Before you run a macro, you must save to a file any existing data
that you want to retrieve at a later time.

1. To run your macro, do one of the following:
e From the Macros Main Menu, select Run.
o Type MACRO RUN on the command line.

A Load Macro File dialog box appears in which you can select the macro file you wish to run. If the
desired macro file is not listed, scroll through the directories until you find the file. If the file
extension is not .MAC, change the extension in the Files of Type box.

2. Click Open to run the selected file, or Cancel to cancel the operation.

Optionally, to run a macro you can enter MACRO RUN filename on the command line, where
filename is the name of the macro file. Filename must include the file extension and can include the
full directory path. This causes the named macro to be run automatically, without scrolling though
the Load Macro File dialog box.

Program Configuration Files for Macros

To ensure smooth running of a macro file, it is desirable to define the work area layout and set the
program parameters in a specific manner. When macro execution is completed, you want to restore the
previous settings for normal program operation. You can create program configuration files, and select
which configuration file to use.

1. Open and arrange windows in the work area in the layout you desire, and set the program
parameters. \When the program is configured to your liking, save the window layout and parameter
settings to a file. Access the Macros menu and select Configuration, then select Save Current
Configuration for Macro from the displayed submenu.

2. A standard File Saving dialog box is displayed in which you can enter a name (and optionally the drive
and directory location) for the file. An INI file extension is automatically appended to the filename to
identify it as a configuration file. Click the OK button to complete the file save operation.
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When you create a macro, include a command at the beginning to reconfigure the work area and set
the parameters appropriately for the task by activating a saved configuration file. Include a command
at the end of the macro to restore the settings that existed before macro execution began by
activating the previous configuration file.

Work Area Layout

You can save the template of a window in the active initialization file. Subsequently, you can create a
new window based on the defined window template. Similarly, you can save a grouping of windows, so
that you can redraw the work area to contain a defined group of windows. Commands also exist for
cascading and tiling the existing windows in the work area.

8-6-1 Saving a Group of Windows

You can create a number of windows in the work area. The attributes for this group of windows can be
saved to a unique group name. Later, you can reset the work area to display this defined group of
windows.

1. Onthe command line, type WINDOW SAVEALL group_name, where group_name is a text string
that will uniquely identify the group of windows. This group name will be stored in a
GROUP.group_name section of the session file, along with information providing the size, position
within the work area, and window settings for every window currently existing in the work area.

This defined group will only be accessible while the current session file is valid. To save the window
grouping for later sessions, the configuration must be saved to either the User Configuration or
preferably another named file (e.g., SET TO NAME.INI).

2. When you save program parameters to a configuration file using the menu commands, the current
work area layout is automatically saved to a group hamed GROUP.WORKAREA.

8-6-2 Restoring a Group of Windows

After the settings for all windows in the work area are saved to a unigque group name, you can
restore the work area to redisplay the saved window setup. Note that when you reset the work area
with a saved group of windows, the existing windows are deleted and all existing data are lost
before the new windows are opened.

To restore the work area to any previously saved setup defined in the current configuration file:

»  Type WINDOW RESET group_name on the command line, where group_name is a unique name for
a group of windows you have defined previously using the WINDOW SAVEALL command. If
group_name is not entered, the work area is redrawn with the window setup that existed at program
startup.

When you set the program parameters from a configuration file using the menu commands, the
work area is redrawn from the window group [GROUP.WORKAREA] defined in that file.
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8-6-3 Rearranging the Windows in the Work Area
You can rearrange the windows in the work area so that they are cascaded or tiled. This does not affect
any data in the windows. Minimized windows remain minimized.

1. To overlap (cascade) the windows with the active window in front and the title bar for each window
visible, do one of the following:

¢ From the Window Main Menu, select Cascade.
e Type WINDOW CASCADE on the command line.

2. To redraw the windows with similar sizes so they are all fully displayed in the work area, do one of
the following:

e To rearrange the windows into horizontal tiles, select Window on the Main Menu, then Tile
Horizontally, or type WINDOW TILE HORIZONTAL on the command line.

e To arrange the windows into vertical tiles, select Window on the Main Menu, then Tile
Vertically, or type WINDOW TILE VERTICAL on the command line.

At any time, you can reset the work area to the window layout at program startup by typing
WINDOW RESET AT START on the command line. Note that when you use this command, all data in
the windows are deleted before the windows are redrawn.

8-7 Macro Example

Below is a sample print of a macro delivered with the program. Note that any line beginning with an
asterisk (i.e., *), blank lines, or characters before commands are ignored by the program during
execution. They are added to a macro so that the macro can be more easily understood when
subsequently reviewed.

* FMT.MAC - Pitch, energy and SPG w/ FMT of sample file.

* Updated 24 March 2005

SET FROM.NOSAVE c\KAYLAB\Ini\demo\FMT.INI

* This set command loads the selected .INI file which stores all

* of the setup information for the commands used in this *macro.
* |f user configuration changes have been made but not saved,

* the changes are automatically discarded when the new INI

* file is activated.

CLOSE ALL
* This command closes all of the opened windows so that new Windows can

* be created.

WINDOW RESET WORKAREA
* Creates the Windows, sets the source window and assigns the window to display the

* waveform data.

MUODO0000700 128 Revision B



PENTAX

MEDICAL

USE A
* This command makes Window A the active window and ready to receive graphic

* displays.

LOAD SPEECH.NSP
* Load the sampled data file.

SPEAKAOQ*
SPEAKAQ *
SELECT 0.7 1.6

* Speak the file twice, then select the region from 0.7 to 1.6 seconds.

SPEAK A SS SE

SPEAK A SS SE

MOVE .95

* Speak the selected region twice, zoom in on the selected region,

* then move the cursor to a location for future analysis.

USE B

* Activate window B

PITCHAOQ *

* Do a pitch analysis of all the data.

USE C
* Activate window C

ENERGY A <>
* Do an ENERGY analysis of all the data.

USE D
* Activate window D

SPG A SS SE
* Perform a wide band spectral analysis of the selected region.

USE E

* Activate window E
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SET SPG.LENGTH 512

*Adjust the spectrogram bandwidth to narrowband analysis

SPG ASS SE

* Perform a narrow band spectral analysis of the selected region.

SET SPG.LENGTH 75

*Adjust the spectrogram bandwidth to wideband analysis

USE F

* Activate window F

FFTA =

* Do an FFT analysis of the source signal at the cursor location

SET WINDOW.PEN BRICK

* Change the pen color

LPCA =

* Do an LPC analysis at the same location

SET WINDOW.PEN GREEN

* Change the pen color again

USED

* Activate window D

FMT A SS SE

* Perform formant history calculation of selected region.

SPEAK A SS SE
SPEAK A SS SE
* Speak the selected source twice.
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USE A

LINK B

LINK C

LINKD

LINK E

SHOW 0 *

SELECT O *

SPEAKAOQ *

SPEAKAOQ *

* Link all time-domain windows and show all data in A,

* select all the data, then speak all the data twice.

MESSAGE FROM FMT1.HTM
* Display a message to the user. The text of the message is stored in the file FMT1.HTM.

SET FROM.NOSAVE.INI

* This command restores the INI setting to the settings before the macro was run.
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Appendix A. Installation of CSL Main Program and Multi-Speech

Note Specific hardware is required only with CSL. Multi-Speech is designed to work with your
computer’s internal graphics and a user-provided microphone. Installation of the CSL hardware is
described in the Computerized Speech Lab (CSL™) Hardware and Installation Manual.

A-1  CSL Components

See Section 2-1, System Components and the Computerized Speech Lab (CSL™) Hardware and
Installation Manual for details.

A-2 Multi-Speech Components

Unpack and inspect Multi-Speech. The following parts should be included:

e |nstruction manual.

e Software (Multi-Speech application CD. If you purchased options, they appear on separate CDs.
o Software security key.

Note If for any reason parts are damaged or missing, immediately contact the factory or
PENTAX Medical representative

A-3 Major Steps for Installation of CSL and Multi-Speech

There are two major operational steps for CSL; if you are installing Multi-Speech, skip to step 2.
1. Install CSL 4500b hardware:

See the Computerized Speech Lab (CSL™) Hardware and Installation Manual for details.

a. Install the PCle sound card into the computer.

b. Connect the CSL to AC power source, microphone, speaker, and computer (using cable).

2. Install application software, device driver (CSL 4500b only), and security key driver for the CSL 4500b
or Multi-Speech.
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A-3-1 Installing CSL Hardware

-

CSL

PC

PCle sound card

Figure 29. CSL Hardware Schematic
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Appendix B. Software Installation

Before you install CSL software, make sure that you install all hardware components. Refer to Appendix
A, Installation of CSL Main Program and Multi-Speech, and to the Computerized Speech Lab (CSL™)
Hardware and Installation Manual for details.

B-1 Installing CSL Main Program and Multi-Speech

Note These instructions use CSL windows to illustrate the installation process. Multi-Speech
windows follow the same sequence.

B-1-1 Installing Application Software

To install the CSL 4500b or Multi-Speech software:

1. Insert the Software Installation Disc and Software Instruction Manual CD.

PENTAX PENTAX

MEDICAL MEDICAL
Computerized Speech Lab Multi-Speech
Model 4500 Model 3700

f View/Print Software Manual ﬁ
( View?Print Soﬁware Manua ,
t Insfa CSﬁSOO ’

_ N S LT
Install Security Key Driver
?Insta Audio Device Driver ( Trstall Security Key briver ,

) € B )

Version 4.0.0 Version 4.0.0

Figure 30. CSL 4500b and ms installation menu

2. At the installation menu, click Install CSL4500 or Install Multi-Speech.
If this menu appears, skip to step 3; if it does not appear, go to step 3.

3. If the installation menu does not appear, launch the application manually:
a. Open File Explorer and navigate to your CD drive.

b. Double-click autorun.exe.
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4. Use the Setup Wizard to install the application.

a. Atthe Setup Wizard
window, select Next.

b. Atthe End-User License
Agreement, click the button
to accept terms and then
click Next.

c. At the Customer Information
window, enter your user
name, organization, CD
Serial Number, and click
Next.

The serial number appears
on the CD packaging

MUODO0000700

ﬁ Computerized Speech Lab Model 4500 Setup X

Welcome to the Computerized
Speech Lab Model 4500 Setup
Wizard

The Setup Wizard will install Computerized Speech Lab Model
4500 on your computer. Click "Next" to continue or "Cancel”
to exit the Setup Wizard.

ﬁ Computerized Speech Lab Model 4500 Setup

End-User License Agreement

Please read the following license agreement carefully

PENTAX MEDICAL PROGRAM LICENSE AGREEMENT AND LIMITED ~
PRODUCT WARRANTY
Computerized Speech Laboratory Model 4500 (Version 4.0.0)

CAREFULLY READ THE FOLLOWING TERMS AND CONDITIONS. YOUR
USE OF THE PROGRAM WILL INDICATE YOUR ACCEPTANCE. IF YOU DO
NOT AGREE WITH THESE TERMS AND CONDITIONS, DO NOT INSTALL
THE PROGRAM.

PENTAX Medical provides this Program and licenses its use to you. v
(@1 accept the terms in the License Agreement
(01 do not accept the terms in the License Agreement

Advanced Installer

< Back Cancel

ﬁ Computerized Speech Lab Model 4500 Setup X

Customer Information

Please entzr your customer information

User Name:
Organization:

Serid Number:

o JLH ]

Advanced Instaler

< Back Cancel
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At the Select Installation
Folder window, click Next to
install software at the default
location.

You can also navigate to
another folder.

At the Ready to Install
window, click Install.

A status bar tracks the
installation process.

PENTAX

MEDICAL

ﬁ Computerized Speech Lab Model 4500 Setup -

Select Installation Folder
This is the folder where Computerized Speech Lab Model 4500 will be install...

To install in this folder, dick Next", To install to a different folder, enter it below or dick
"Browse",

Folder:
C:\Program Files (x86) \PENTAX Medical\Computerized Speech Lab M Browse...

Advanced Installer

==

ﬂ Computerized Speech Lab Model 4500 Setup

Ready to Install

The Setup Wizard is ready to begin the Computerized Speech Lab Model 4500
installation

Click “Install” to begin the installation. If you want to review or change any of your
installation settings, dick "Back”. Click "Cancel” to exit the wizard.

Advanced Installer —

<o =

ﬁ Comptterized Speech Lab Model 4500 Setup X

Installing Computerized Speech Lab Model 4500

Please wait while the Setup Wizard installs Computerized Speech Lab Model 4500.
This may take several minutes.

Status: Preparing files for removal
|

Advanced Installer

< Back Next >
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f.  When the process is
complete, click Finish.

The Installation menu
appears again. For CSL, can
now install the audio device
driver.

For Multi-Speech, skip to
Section B-1-3, Installing the
Security Key Driver.

-2 Installing the Audio Device Driver

PENTAX

MEDICAL

ﬁ Computerized Speech Lab Model 4500 Setup X

Completing the Computerized
Speech Lab Model 4500 Setup
Wizard

Click the "Finish™ button to exit the Setup Wizard.

< Back Cancel

After you install the application software, you can install the audio device driver for CSL:

1.

MUODO0000700

At the Installation menu, click Install Audio Device Driver.

Note Do not plug the security key into the computer’'s USB slot until you install the

driver.

PENTAX

MEDICAL

Computerized Speech Lab

Model 4500

( View/Print Software Manual

)

( Insfa” CSLESOO ,

 __ Install Security Key Driver

5

( Install Audio Device Driver ’

( EXi

J

Version 4.0.0

Figure 31. CSL 4500b installation menu
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2. At the End User License Ag reement #8, Lynx Studio Technology, Inc. End User License Agreement (EULA) - X
window, click Accept.

CLICKING THE "ACCEPT" BUTTON, OR OTHERWISE ATTEMPTING TO
COPY, INSTALL, OR USE ANY PART OF THE SOFTWARE, WILL INDICATE
THAT YOU HAVE READ, UNDERSTOOD, AND ACCEPT THE APPLICABELE
TERMS AND CONDITIONS. DO NOT PROCEED IN ANY SUCH MANNER
UNLESS YOU ARE ABLE AND WILLING TO ENTER INTO AND COMPLY
WITH THE APPLICABLE END USER LICENSE AGREEMENT. IF YOU HAVE
ANY QUESTIONS CONTACT LYNX STUDIO TECHNOLOGY, INC. EEFORE
YOU ATTEMPT TO COPY, INSTALL OR USE ANY PART OF THE SOFTWARE.

BY INSTALLING THIS SOFTWARE YOU AGREE TO INDEMNIFY AND
HOLD HARMLESS LYNX STUDIO TECHNOLOGY, INC. FROM ALL
CLAIMS, COSTS AND EXPENSES (INCLUDING LEGAL EXPENSES)
ARISING OUT OF ANY USE OF OR INABILITY TO USE THIS
SOFTWARE.

IN NO EVENT WILL LYNX BE LIABLE FOR INCIDENTAL, CONSEQUENTIAL
OR OTHER DAMAGES RESULTING FROM THE USE OF THIS SOFTWARE,
INCLUDING, AMONG OTHER THINGS, DAMAGE TO PROPERTY, DAMAGE
BASED ON INCONVENIENCE OR ON LOSS OF USE OF THE PRODUCT,
AND, TO THE EXTENT PERMITTED BY LAW, DAMAGES FOR PERSONAL
INJURY,

Accept | Dedine

3. At the next WindOW, the default 7 LynxTWO/L22/AES16/AES16e Version 2/WDM Driver - X
destination folder appears:

To install the LynXTWO/L22/AES16/AES16e Version 2/WDM

¢ Click Install to accept the driver, first press the "Install" button below. Once the files
folder have been extracted from this archive, further instructions
' will be provided.
® Click Browse to select another If the destination folder does not exist, it will be created
destination. automatically.
Destination folder
C:\Lynx] M Browse...
Installation progress
coc
A status bar tracks the installation 7 LynxTWO/L22/AES16/AES16e Version 2/WDM Driver - X
process.

Extracting files to C:\Lynx folder
Extracting from V2Setup23i.exe

Extracting V2Setup32.exe

Installation progress

Install Cancel
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4. At the Welcome window, click Lynx Driver Install: Version 2.00 Build 23i X
Install.

Welcome to the Lynx Driver Installer.

This program will install the Lynx driver and assodated
files onto your computer. We recommend exiting any
other programs that are currently running before
continuing the installation process as a restart of the
computer may be necessary.

Your Lynx Audio Card should already be installed in a
slot inside your computer,

Press "Install” to proceed with the driver installation, or
select "Cancel” to quit.

Copyright © 1998-2017, Lynx Studio Technology, Inc. Install Cancel

5. When the process is complete, click  Lynx Driver Install: Version 2.00 Build 23i X
Restart.

The Installation menu appears again.
You can now install the security key
driver.

The driver installation is complete.

Copyright © 1998-2017, Lynx Studio Technology, Inc. » Restart
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B-1-3 Installing the Security Key Driver

After you install the application software, the audio device driver for CSL, and restart your computer, you
can install the security key driver.

1. Open File Explorer, navigate to your CD drive, and double-click autorun.exe.

2. At the Installation menu, click Install Security Key Driver.

Note Do not plug the security key into the computer’'s USB slot until you install the
driver.

PENTAX
MEDICAL

Computerized Speech Lab
Model 4500

' 6 er ErinE §0 Eware Ie anua '

nsta

nsta ecurity Key Driver

nsta uaio Device Driver

*

Version 4.0.0

Figure 32. CSL 4500b installation menu

3. The Preparing to Install window Sentinel Runtime - InstallShield Wizard

appears.
Preparing to Install...

Sentinel Runtime Setup is preparing the InstallShield Wizard,
which will guide you through the program setup process.
Please wait.

Extracting: HASP_Setup.msi

Cancel
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4. At the Sentinel Runtime Installation
Wizard window, click Next.

5. At the License Agreement window,
click the button to accept terms and
then click Next.

6. At the Ready to Install window, click
Next.

MUODO0000700
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# Sentinel Runtime Setup — X

@afeNet

Welcome to the Sentinel Runtime
Installation Wizard

Itis strongly recommended that you exit all Windows programs
before running this setup program.

Click Cancel to quit the setup program, then close any programs
you have running. Click Next to continue the installation.

WARNING: This program is protected by copyright law and
international treaties.

Unauthorized reproduction or distribution of this program, or any

portion of it, may result in severe civil and criminal penalties, and
will be prosecuted to the maximum extent possible under law.

InstallShield

# Sentinel Runtime Setup

“You must agree with the license agreement below to proceed.

SAFENET SENTINEL LDK PRODUCT END USER LICENSE
AGREEMENT

IMPORTANT INFORMATION - PLEASE READ THIS AGREEMENT
CAREFULLY BEFORE USING THE CONTENTS OF THE PACKAGE AND/OR
BEFORE DOWNLOADING OR INSTALLING THE SOFTWARE PRODUCT. ALL

ORDERS FOR AND USE OF THE SENTINEL® LDK PRODUCTS (including
without

Burnitntinm +ha Navalanade Vit Lheavine cdilidine dicladda- AN NDARA

@) | accept the license agreement
(O | do not accept the license agreement
InstallShield

Cancel

< Back WI Next > l \

Reset \

ﬁ Sentinel Runtime Setup

Click the Back button to reenter the installation information or click Cancel to exit
the wizard.
InstallShield
< Back ‘l Next > I | Cancel |
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7. When the process is complete, click | Sentinel Runtime Setup = X

Finish. Sentinel Runtime has been

@feNet successfully installed.

The Sentinel HASP Run-time Environment uses
port 1947 to communicate with local and remote
components. If you use a firewall, ensure that it
does not block this port.

Click the Finish button ta exit this installation.

InstallShield

< Back Cancel

8. At the CSL4500b installation menu,
click Exit. pENTAx
MEDICAL

Computerized Speech Lab
Model 4500

‘ GIEW; EI’IHE §0 Eware ieianua ’

nsta

nstall Security Key Driver

nsta udio Device Driver
' EXIE ’

Version 4.0.0

9. Remove disc from CD drive and reboot the PC to complete security key installation.
10. Plug the security key into an available USB port on the host computer.

Refer to Section 3, Installation and Loading, for additional information.
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B-2 Operational Qualification of Equipment

After you install software, ensure that the system is operating successfully:

1.
2.

© © N o 0 A~

Install the PCle sound card.

Install the Acoustic 4.0 Software on the PC as specified in Speech Products Software Installation
Instructions.

Connect the DB25 cable between the PCle sound card and the 4500b.

Ensure that the PC power is supplied through a 9175 Isolation Transformer, if provided.
Apply power to the 4500b.

Open the CSL 4500b main program.

Connect a microphone to an input channel.

Capture data on the channel you selected.

Play the sample.

If the data capture and playback are successful, the operational qualification is complete.
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Appendix C. Audio Cards

C-1

Introduction

Multi-Speech is a software product dependent on a host computer and audio card (purchased separately)
for many operations (i.e., input and output). Most of PENTAX Medical's other products are delivered with
the necessary peripheral hardware (e.g., CSL, Visi-Pitch, and Nasometer, etc.). Therefore, the quality of
the operation of the Multi-Speech is dependent on a third-party audio card, which is out of

PENTAX Medical's control. To compound this problem, most of the audio cards available have significant
operational and performance shortcomings when compared to professional-level hardware such as digital
recorders Visi-Pitch, and CSL. These similarities and differences are also discussed in Introduction.

Often the specifications for these cards are not described in the manufacturer's documentation typically
provided, or the specifications are idealized and rarely met when installed in typical computer
environments. There are many audio card manufacturers and quick turnover of models. Our challenge,
given the above difficulties, is to provide some guidance about using, evaluating, and selecting these
cards. As stated previously, PENTAX Medical recommends that, whenever possible, a professional-level
input system (e.g., digital recorder CSL, or Visi-Pitch) be used for input to ensure good quality recordings.

Table of Audio Card Cautions

Feature Caution
Hardware Your sound system may or may not include a microphone, speaker(s), or
Delivered headphones. Check delivered components and the quality of the components.

Overall Input Generic audio cards have input SNR of about 40-60dB depending on the audio card

Quality design, the location of the card in the computer, the noise level of the computer,
the microphone, and other considerations. As a frame of reference, note that CSL,
Model 4500b, and Visi-Pitch, Model 3950c, use professional-level components and
an external module to achieve input signal-to-noise ratios (SNR) above 91dB. The
difficulty in selecting a generic audio card is that few manufacturers specify the
input SNR, and when specified it is idealized. In reality, the specifications vary
depending on the installation in each computer. Even top grade generic audio cards
(e.g., Creative Lab’s top-of-the-line consumer card) are considered better quality
input systems but still have significantly more noise than professional components
designed for measurement (e.g., PENTAX Medical products) or studio music
applications.

Microphone Most audio cards include inexpensive, limited-frequency-response dynamic
microphones. Multi-Speech users should consider upgrading to a better microphone
if acquiring signals using the audio card. Note that a professional condenser-type
microphone is specified by the National Center for Voice and Speech
Recommendations for Voice Analysis. Microphones also vary in their output levels
and not all microphones are matched to the preamplifiers included with the board.
You can need to experiment with various microphones or external preamplifiers to
find a suitable combination for your sound board.
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Preamplifier

Few audio card manufacturers specify gain and SNR of their preamplifier. You can
wish to consider purchasing a separate external preamplifier, which is then
connected to the line-level input of the audio card, to improve the noise
performance. The preamplifier on your card can have insufficient gain or, if available,
the high-gain setting can introduce too much noise. Symptomatic of a low-gain
preamplifier is a subject having to speak loudly into the microphone to reach full
amplitude levels even when the gain for the audio card’s input sensitivity is on its
highest setting. Also, note that the audio card exhibits the highest DC offset and
noise when the input levels are set to their highest setting.

Input
Anti-aliasing
Filters

To accurately acquire signals (i.e., converting from an analog signal to a digital
representation), without aliasing higher frequency components to the frequency
range of interest, an anti-aliasing filter is required. These filters should adjust to the
sampling rates and have greater than 100dB/octave roll-off. With generic, low-cost
audio cards, the user should be aware of the characteristics of the anti-aliasing
filters, at which sampling rates they are used, and the capability (or lack thereof) to
automatically track the set sampling rate. This can be especially problematic when
high-frequency signals are present above the sampling rate of interest. For example,
computer monitors often generate high-frequency signals (about 15000 Hz) at the
flyback frequency that could inadvertently alias an improperly filtered signal sampled
at 44100 Hz. Tape recorders can also have signals above the listener’s hearing
range that will “mix” with the signal of interest during A/D conversion if not filtered.
Again, because audio card manufacturers do not provide these specifications, users
should test their input system before applying to serious work. If CSL or Visi-Pitch is
used for input, you will not need to test because Visi-Pitch and CSL have input anti-
aliasing filtering to fit the requirement noted above. CSL and Visi-Pitch filters
automatically adjust to the set sampling rate.

Noise

Noise is any unwanted signal mixed with the signal of interest. The section
following this table provides some guidance on noise measurement in your system.
Generic audio cards use a 16-bit A/D converter but often the bottom 7 to 8 bits of
the input range are corrupted by noise. Therefore, the theoretical resolution of the
system of 96dB is limited to about 40-60dB. Pick the best card, and evaluate it
carefully before using. If your applications (e.g., clinical measurements or research)
demand better input specifications, use a professional-level system for input. These
systems include CSL and Visi-Pitch available from PENTAX Medical and other
companies (e.g., Turtle Beach). Noise can also be aggravated by turning the AGC
on. During capture, turn AGC OFF when possible.

DC Drift

An alternating signal such as received from a vibrating microphone diaphragm
should produce voltages that vary around zero. The resultant digitization will
produce a signal with values varying around 0. If you plotted the waveform, the
center line should be 0. Electronic circuits can, unfortunately, drift so that the
signals do not vary around zero. This DC drift varies with temperature. A listener
cannot hear this DC drift. Measurements, however, can be affected by this drift.
Professional-level components are attentive to DC drifts and will autocalibrate to
eliminate drift. You can wish to use the test in this appendix (next section) to
measure the DC drift of your system at various levels of system warm-up.
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Output
Sampling
Rate

CSL and Visi-Pitch support a wide range of 1/O rates. Many audio cards do not. If
you play back a signal, which was acquired on CSL or Visi-Pitch, on a multimedia
audio card, that card cannot support the acquisition rate and the output will be
distorted. This is especially true with the rates higher than 44100 Hz and lower
than 11025 Hz rates. Multi-Speech users should not infer from this distorted
output that the stored signal is distorted. The Multi-Speech macros for playing out
signals at different sampling rates (i.e., SAMPLING.MAC) can be used to evaluate
the flexibility of the audio card. We have found that the higher-end Creative Labs
cards do the best job of supporting various output rates between 11025 Hz and
44100 Hz. No card will support all of the sampling rates used by CSL and Visi-
Pitch.

Output
Anti-aliasing
Filters

To eliminate sampling “noise”, a digital-to-analog conversion of signals should use
an adjustable filter appropriate to the I/O sampling rate. In generic audio cards,
these specifications for output filtering cannot be delineated in the audio card’s
documentation. You can be able to achieve the desired output sampling, but not
necessarily the correct output anti-aliasing. Users of generic audio cards should not
assume that a noisy or distorted output means that the stored signal is corrupted.
It could simply be an output problem.

Adjusting
Input
Sensitivity

With generic audio cards, you will need to repeatedly acquire, check levels of
signals, stop acquiring, evoke audio card controller program, adjust, go back to
Multi-Speech, and reacquire in order to set the input level correctly. The
awkwardness of this operation typically yields signals with more overloads or an
underutilization of the dynamic range (i.e., underloading). CSL and Visi-Pitch allow
the input sensitivity to be adjusted during input so that overloading is avoided and
the dynamic range of the input is used effectively.

Linearity

In a trade-off suitable for most applications, but unsuitable for measurement
applications, many audio cards allow the input amplifier to be overloaded without
warning flags before the A/D is overloaded. This is done to avoid the more aurally
unpleasing overloading of the A/D. However, users can be overloading and
distorting measurements of the system on the input amplifier without warning
because the A/D is still not fully utilized. As a result, the amplitude and spectral
accuracy of the signal is compromised. CSL and Visi-Pitch preserve linearity and
accuracy and match the input amplifier, A/D and warning flags to avoid overloads.

Adjusting
Output
Volume

The software setting for most audio cards requires you to stop playing to make
adjustments. If you are using an external speaker, you should be able to adjust the
output volume of the speaker without interrupting output. Multi-Speech users,
who use headphones, can wish to explore getting headphones with volume
adjustments.
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Flagging of Overloads (i.e., clipping) in digital systems can be disastrous for data analysis.
Overloaded Generic audio card software does not have the ability to identify overloaded
Input sample points during acquisition or even after the signal is acquired. The audio

card hardware does not have the ability to detect overloads at the A/D converter.
Multi-Speech software does flag suspected overload points after the signal is
acquired by showing a color change in the waveform display. It does this by
analyzing the signal characteristics. If you use these generic audio cards for input,
users should be careful to avoid overloading. Before analysis, you can note the
waveform display to see if the trace changes color. When overloads are detected,
color changes and a flat top appearance of the waveform occur at overloaded
sections of the waveform. Before analysis, you can want to look closely at the
waveform for overloaded segments.

Calibrated Generic audio cards do not have a calibrated input. Users cannot know the

Input absolute level of a signal. Therefore, all measurements are relative to other
portions of the signal. Even relative measurements are not possible if the AGC is
ON. AGC should always be set to OFF for any measurement task.

DC Coupling AC coupling is used for microphone signals, but DC coupling is used for
electroglottography, air flow, and other low-frequency content signals. Generic
audio cards do not typically include DC coupling and cannot, therefore, be used to
analyze low-frequency information reliably. If you need to analyze these types of
signals, use CSL, because this system includes the ability to set the input to either
DC or AC coupling.

Support Consult your audio card manual for support information. PENTAX Medical will
support Multi-Speech software, but PENTAX Medical cannot support the service
or operation of the third-party audio card.

C-3 How to Check the Input Signal-to-Noise Ratio of a Generic Audio Card System

As stated previously, few sound board manufacturers specify their input SNR. For those that do specify
it, our studies have shown that these specifications are idealized and are rarely met in the typical user’s
computer system. The specifications depend on the installation and the computer. Therefore, it is useful
to determine the SNR of the audio card in your system. CSL and Multi-Speech include analytical tools
that can be helpful in assessing the quality of your system’s input circuits. For example, by initiating
capturing with no signal attached, the resultant captured signal can represent some of the background
“noise” of the system. An understanding of how unwanted noise can be mixed with the signal of
interest will improve your ability to interpret the analysis of a signal compromised by noise. Noise is
generally taken to mean random fluctuations, added to or modulated with, a wanted signal. Here,
however, noise means any unwanted signal, periodic or not, existing with a desired signal.

When you use a multimedia card, you can unwittingly report analysis results (e.g., energy levels, jitter,
harmonic/noise ratios), which have been significantly altered by noise, added during signal acquisition.
You can be adding noise without realizing it. This problem is the reason why the National Center for
Voice and Speech recommends that the system you use to make voicing measurements should have an
input SNR of over 86dB and that it should include robust anti-aliasing filters to filter out unwanted
frequency components.
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Any method of acquiring and storing signals can affect the signal quality. Noise can be introduced during
signal acquisition in a number of ways. System components (e.g., microphone, cabling, preamplifier,
amplifier, anti-aliasing filters, and A/D) could be of poor quality. The CSL and Visi-Pitch models use
professional-level system components and careful design that minimize system-generated noise.
However, if you acquire with other products, you should evaluate their performance. Additionally, noise
sources (e.g., fan noise, electromagnetic signals from monitors or fluorescent light fixtures, power supply
hum) can inadvertently be acquired along with the signal when using the best equipment. Poor room
acoustics can also add noise.

When analog signals are converted to digital signals (and vice versa) on an audio card inside a computer,
the input and output circuitry can be affected by computer noise. To avoid this, most products for
professional sound applications (PENTAX Medical's CSL, Visi-Pitch, digital recorders, etc.) use an external
module, isolated from the noisy computer, to perform the analog-to-digital and digital-to-analog
conversion. Inherent in plug-in cards is their susceptibility to computer-generated noise. It is not a design
flaw of the audio card.

A digital storage system (e.g., computer acquisition, digital recorder) converts the incoming continuous
analog signal to a discrete digital signal. Converting an analog signal to a digital representation is
performed by an analog-to-digital converter (A/D converter). Most systems today use a 16-bit A/D
converter that produces a 16-bit binary number to represent the range of incoming values. A binary
number with 16 places has a range of 2% or 65536 possible values. This range of values equals 96dB of
possible signal level variation (20 log 65536). This is the maximum achievable range, also called the
dynamic range, with a 16-bit linear converter. The full 96dB range, however, is seldom achieved because
the associated electronics can rarely take advantage of the full dynamic range available. For example,
most audio cards, which plug into a computer, can lose half of the dynamic range to system noise and
large DC offsets. DC offset is characterized by signals not varying around 0. An AC-coupled microphone
signal needs to be centered about O for full peak-to-peak performance.

One simple way to perform a partial check of a recording system, without the need for test equipment, is
to acquire a signal exactly as you would during your work, except with the microphone turned OFF.
(Admittedly, this is only a partial check of the system because unbalance microphones can pick up noise,
which cannot be detected in this test.) Then, using Multi-Speech, analyze the acquired signal for noise by
pressing [F9] and checking the Level value in the Signal Information dialog box or by scrolling the cursor
along the waveform to note the cursor values. The waveform display cursor reads the waveform values
as a linear value (with values ranging from 0 to = 32768). Use the table that follows to correlate the linear
waveform value of the cursor with the noise level and SNR ratio. If you repeat the above test with the
microphone on (but quiet), you can separately measure the noise added by microphone pickup of
acoustic and electromagnetic signals. For example, if the values range -200 or +200, under either
condition, the eight or nine least significant bits (about 50dB) are corrupted by noise. The true dynamic
range of the 16-bit A/D has been reduced from 96dB to about 46dB. As another example, if no
microphone is attached and the values are 150 + 32 (i.e., values range from 118 to 182), there would be
almost 45dB of DC offset and 36dB of random noise. Please note that this is not a foolproof test because
the noise in the computer can be intermittent. For example, the hard drive (which could turn on if virtual
memory is used) could produce a noise spike only occasionally and cannot be detected in the above test.

For voice measurements, a useful dynamic range of above 85dB is recommended by the National Center
for Speech and Voice. This means that the noise should fall within the range of -2 to +2 using the tests
described above.
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Linear Waveform Affected Bit Noise Level SNR Ratio
Values for Noise
+ 1 16™ (least significant) 6dB 90dB
+2 15t 12dB 84dB
+4 14t 18dB 78dB
+8 13t 24dB 72dB
+ 16 12t 30dB 66dB
+ 32 11t 36dB 60dB
+ 64 10t 42dB 54dB
+ 128 gth 48dB 48dB
+ 256 gth 54dB 42dB
+ 512 7t 60dB 36dB
+ 1024 6t 66dB 30dB
+ 2048 5th 72dB 24dB
+ 4096 4th 78dB 18dB
+ 8192 31 84dB 12dB
+ 16384 2nd 90dB 6dB
+ 32768 15t (most significant ) 96dB none
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Conclusion

PENTAX Medical recommends that a professional system (e.g., CSL, Visi-Pitch) be used whenever
possible for reliable, high-quality input. In all cases, it would be useful to use the measurement
techniques recommended above to evaluate your system’s performance before use. If a professional
system is not available, use a USB-based microphone (e.g., Telex), a USB-based external box (Roland), or
an audio card from a company with a reputation for good quality input and with known specifications for
acoustic input. These include the best cards from Creative Labs with balanced input.

You can wish to consider connecting an external preamplifier (with XLR input), a better quality
microphone (XLR type), and an upgraded sound system to improve your system's performance. The use
of an external preamplifier helps protect the low-level microphone signal from corruption from computer
noise. The external preamplifier boosts the signal level to higher levels that are, therefore, less
susceptible to noise. Note that this is a help, not a cure.

Even if you can find an audio card and an operating environment with acceptable sound quality, you will
need to be cautious about overloading, because there will be no direct feedback of overload conditions,
particularly if the overloading is at the pre-amplifier.

Not all sampling rates are supported by audio cards. When possible, use standard multi-media rates
(11025, 22050, and 44100 Hz) for acquisition. These sampling rates are supported by most audio cards.
The Sound Blaster cards seem to do the best job of supporting the most sampling rates.

All audio cards are likely to have significant operating and performance weaknesses when compared to
professional-level hardware systems (e.g., CSL and Visi-Pitch). These performance tradeoffs are inherent
in their low-cost design and cannot be completely avoided. Users must, in all cases, proceed cautiously
in order to ensure good quality signal acquisition and output.
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D-1 CSL Model 4500b Specifications

Class: Class | Equipment

Type B Applied Parts
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Input Channels 1 & 2

Input Channels 3 & 4

Type Microphone and line Line

Connection XLR and 1/4" combo RCA

Coupling AC coupled AC coupled or DC coupled (hard switch
selectable)

Gain Range > 38 dB > 36 dB

Input Signal XLR: -52.8 dBu to -15.6 dBu (6 mVpp to 360 24.5 dBu to 12.3 dBu (130 mVpp to 9.0

Range (Full mVpp) Vpp)

Scale) 1/4": 24.5 dBu to 12.3 dBu (130 mVpp t0 9.0

Vpp)

Frequency (-3 dB): 20 Hz to 88 kHz AC Mode (-3 dB): 18 Hz to 88 kHz

Response DC Mode: Low-pass roll off at 88 kHz

DC Offset < 0.3% Digital F.S. < 5% Digital F.S.

THD+N <-90dB @-3dB FS (F.S. =12.3 dBu) THD+N: <-90dB@-3dB F.S. (F.S. =12.3
dBu)

Output Channels 1 (Left) & Auxiliary Output Headphone Outputs*
2 {(Right) Channels 3 & 4

Type Speaker and line Line 1/4" Phono jack

Connection RCA RCA —

Coupling AC coupled AC coupled

Gain Range > 38 dB (speaker outputs only) — >38 dB

Output Power

Frequency
Response

THD+N

Balance

3 watts per channel (speaker —
outputs only)

4 Hz to 88 kHz (3 dB) —

<-90 dB @ -3 dB Digital F.S. —
(measured on line output)

Not implemented in hardware —

*Qutputs are disabled when the headphones are in use. Warm-up time: 20 minutes
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Power Supply

Input Power

Fuses

Specialty Functions

Enclosure Type

Environmental

e Front panel on/off switch

e Type: Universal AC input

e Model: SRW-100-3002

e Manufacturer: Integrated Power Designs

e |nput: 85-264 VAC, 47 Hz- 63 Hz

e Qutputs: +5V DC/10A, +15VDC/3A, -15VDC/1A
o Weight: 1.0 Ibs.

e Expected Usage: 45 VA watts (max.)

100 - 240 VAC, 50 - 60 Hz, 60 VA
T2.0A/250V, Bmm x 20mm, Schurter 0034.3120 or

equivalent

VRP Mode:

e Variable gain of channels 1 & 2 disabled

e Channel 1 variable gain stage set to 30 dB +0.5 dB
e Channel 2 variable gain stage set to 3 dB +0.5 dB

e Channel 1 signal routed to channel 2 gain stage

Custom enclosure to include PENTAX Medical front and rear
bezels. Dimensions:

e length: 12.5"

e Width: 4"

e Height: 8.25"

o Weight: 4.75 Ibs.

Operating:

e Temperature: +10 °C to +40 °C

e Relative Humidity: 30% to 90% (non-condensing)
e Atmospheric Pressure: 700 mb to 1060 mb
Storage/Transportation:

e Temperature: +10 °C to +40 °C

e Relative Humidity: 30% to 90% (non-condensing)
e Atmospheric Pressure: 700 mb to 1060 mb
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Type
Analog 1/O

Analog Input Performance:
(measured in 24-bit mode with card
installed in computer)

Analog Output Performance:
(measured in 24-bit mode with card
installed in computer)

Connections

PCI EXPRESS (Lynx E44 Modified)
e Type: Four inputs/four outputs, electronically balanced
or unbalanced

e Level: +20dBu full scale or variable +8.23dBu to
+24dBu full scale jumper selectable - software
selectable in channel pairs

e A/D and D/A Type: 24-bit, multi-level, delta-sigma

e Sample Rates: 11.025 kHz, 22.05 kHz, 44.1 kHz, 88.2
kHz, 96.0 kHz, 176.4 kHz, 192.0 kHz

e Frequency Response: 20 Hz — 20 kHz, + 0.05 dB at 44.1
kHz sample rate

e Dynamic Range: 117 dB, A-wtd.

e Channel Crosstalk: <-120 dB, 1 kHz signal @ -1dBFS

e THD+N-111 dB (0.0003%) @ -1 dBFS, 1kHz signal
22Hz-22kHz BW

e Frequency Response: 20 Hz— 20 kHz, + 0.05 dB at 44.1
kHz sample rate

e Dynamic Range: 117 dB, A-wtd.

e Channel Crosstalk: <-120 dB, 1 kHz signal @ -1dBFS

e THD+N-108 dB (0.0004%) @ -1 dBFS, 1kHz signal
22Hz-22kHz BW

e Audio Port: Bracket-mounted 25-pin, female, D-sub
connector for analog audio input and output

e Sync Port: Bracket-mounted, 15-pin, high-density,
female, D-sub connector for digital input and output

Software e Windows Drivers: Windows 10: MME, ASIO 2.0, and
DirectSound
General o PCIEXPRESS Bus: x1 —x16
o Size:5.0" HX7.4" W X0.75" D (half-size PCI EXPRESS
card)
e  Shipping Weight: 3.25 Ibs. with cables
e Certifications: CE and FCC Class B
Cables e Analog I/O: 25-pin, D-sub male to female
¢ Female XLR to RCA on shielded twisted pair cabling
e Male XLR to RCA on shielded twisted pair cabling
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Appendix E. Troubleshooting

This section provides some tips and strategies for some of the problems you might encounter while
operating the program. Note that troubleshooting steps can be different when using CSL hardware,
Multi-Speech with a pre-amplifier, or Multi-Speech without a pre-amplifier.

Problem

Possible Solutions

When installing CSL or Visi-
Pitch, the host computer
does not have a free PClI
slot

You must remove one of the devices currently using a PCl slot (an audio card,
or a different computer.

When launching the
software, receive the
message Security key not
found” or “Command
unknown”

The security key is not inserted and/or the security key driver has not been
properly installed. Plug security key into an available USB port and ensure that a
red light appears on the USB key to show it is activated. If key is already
inserted or message still occurs, reload the security key driver.

When using CSL 4500b or
Visi-Pitch, “New Hardware
Found” dialog box
continues to display when
the system is turned on

The PCle sound card driver cannot be installed properly.

No data is captured when
using CSL 4500b or Visi-
Pitch, after selecting
Record

Check that the CSL or Visi-Pitch Hardware is powered on and properly
connected, and that the microphone is powered on and properly connected.
See the Computerized Speech Lab (CSL™) Hardware and Installation Manual
for hardware setup instructions.

If you have both a CSL 4500b and PAS connected to the same computer, check
that the switchbox has been turned to CSL. See the Computerized Speech Lab
(CSL™) Hardware and Installation Manual for instructions on proper installation
of the CSL with a switchbox.

No data is captured when
using Multi-Speech with a
pre-amplifier, after selecting
Record

Ensure that the preamplifier is powered on and properly connected. If using
PENTAX Medical model 3708 or 3710, see the Microphones and Preamps
Hardware Installation and Maintenance Manual for more information on proper
hardware connection.

Check that the microphone is powered on and properly connected. If you are
using the PENTAX Medical model 3706 microphone, ensure that a fresh battery
is inserted. See the Microphones and Preamps Hardware Installation and
Maintenance Manual for more information.
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Problem

Possible Solutions

No data is captured when
using Multi-Speech with a
pre-amplifier, after selecting
Record

Check that the default recording device and volume settings in the Sound
Options accessed through the Windows Control Panel are properly selected.
When using with a preamp such as PENTAX Medical model 3708, select “line
in” input. See Microphones and Preamps Hardware Installation and
Maintenance Manual for more information.

If using the Windows Vista Operating System, ensure the default recording
device has not been muted. Access the Sound control from the Control Panel.
Then click the Properties button on the Line Input device, and go to the
Levels Tab. Verify the device does not have a red No Sounds symbol, and the
levels are at a midway mark.

No data is captured when
using Multi-Speech with a
Microphone Input (no
preamplifier), after selecting
Record. Microphone Input
is not recommended.

Check that the microphone is powered on and properly connected. If you are
using the PENTAX Medical model 3706 microphone, ensure that a fresh battery
is inserted. See the Microphones and Preamps Hardware Installation and
Maintenance Manual for more information.

Check that the default recording device and volume settings in the Sound
Options accessed through the Windows Control Panel are properly selected.
When using with a standard audio card select “microphone.” See the
Microphones and Preamps Hardware Installation and Maintenance Manual for
more information.

Data dropouts occur during
capture or playback when
using CSL 4500b or Visi-
Pitch.

This can be caused by conflicts with other PCl devices. Remove all PCI devices
except the PENTAX Medical device (PCle sound card). Check to see if the
dropouts still occur. If not, re-install the PCI devices one at a time to find the
unfriendly card. If the dropout continues even with all other cards removed,
contact the PENTAX Medical product technical support.
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Appendix F. IPA Characters

F-1 Introduction

The CSL and Multi-Speech programs are capable of displaying characters of the International Phonetic
Alphabet (IPA Symbols) on a transcription screen, as a means of annotating, describing, and identifying a
speech waveform that appears on another display screen. The IPA transcription can also be printed along
with the other screens.

The IPA font for use with CSL and Multi-Speech consists of 193 symbols, including consonant and vowel
symbols, segmental diacritics, suprasegmental symbols, and transcription boundary markers. The basis
for the font is the International Phonetic Alphabet (revised in 1993) as published in the Journal of the
International Phonetic Association, Vol. 23, 1993. Key definitions have been assigned to 131 keyboard
positions as a “default” keyboard for the IPA font. This is the number of keys available for assignment
when using Multi-Speech or CSL in the “Key,” “Shift Key,” and “Alt Key” modes. Symbols, which have
not been given a keyboard definition in the “default” keyboard, can be reassigned by the user to
accommodate local convention, frequency of use of particular characters, preferred mnemonic
placement, or ease of typing. In "Key"” mode, 46 keys are available for assignment, excluding the
semicolon (;) key that is already assigned a definition in CSL and Multi-Speech. In “Shift Key"” mode, all
47 keys are available for assignment. In “Alt Key” mode, 38 keys are available for assignment. “Alt Key”
positions which have no definitions and which, therefore, cannot be used for the IPA font include the
back accent (" ~), comma (, <), period (. >), slash {/ ?), semicolon (; :), quotation mark (' "), left square
bracket ([ {), right square bracket (1}), and backslash (\|) keys.

All current IPA vowel symbols and consonant symbols have been given “Key” or “Shift Key” definitions,
and diacritics have been assigned largely to the “Alt Key” keyboard. This has been done by using the IPA
number of each symbol or diacritic as set out in the Journal of the International Phonetic Association, Vol.
20 (1), 1990, and assigning it a keyboard code in MS-DOS format. Modifications to the IPA keyboard for
use with Multi-Speech can also be made by referring to each IPA number symbol and replacing the
current, pre-assigned number with the number of the new, desired symbol using the “Define Key”
procedure. IPA symbols and their corresponding numbers and names, as well as their currently assigned
keyboard locations in Multi-Speech are listed in the accompanying tables.

Symbols not assigned a location in the “default” IPA keyboard include more recently approved IPA
symbols. Quite a few diacritics remain unassigned—tone marks, for instance—as their use (outside of a
core set) will depend largely on local convention and user preference. The set of keys already defined can
be altered or extended to include phonetic values required by the individual user. The one click symbol
which was left out, for example, could be easily reinserted in the keyboard definitions by assigning its
IPA number (178) to the “Shift 1" (1) key if the symbol now occupying that location is expendable.
Alternatively, many keys in the “Ctrl Key” mode can also be defined as IPA characters if the user wishes
to expand the set. In each symbol category, several non-IPA or former IPA characters have been included
in the IPA font. In all cases, these are characters which can be identified with an IPA number and
assigned a keyboard location if desired.
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F-2 Computer Coding of the IPA

The declaration of the workgroup on Computer Coding of IPA Symbols and Computer Representation of
Individual Languages recommends that a unique numerical equivalent and descriptive name be assigned
for reference purposes to every symbol or diacritic used in current or earlier versions of the IPA. The
logical phonetic organization of the IPA symbol chart is the basis for assigning the IPA number, the first
digit of which indicates the category of the symbol. The 1nn series includes consonant symbols from the
principal place-by-manner grid of the chart and from the Other Symbols section. The 2nn list includes
former or alternative IPA consonant symbols (beginning with 201), and non-IPA consonant symbols that
have been widely used in computer-coded systems (starting with 299 and working backwards). The 3nn
series specifies vowels, most of which appear in the vowel quadrilateral (beginning with 301), and with
former symbols numbered from 399 backwards. The 4nn series includes segmental diacritics (beginning
with 401), with formerly used diacritics that no longer appear on the chart numbered from 499
backwards. The bnn series includes suprasegmental symbols, from that section of the chart (beginning
with 501), with previously specified tone marks numbered from 599 backwards. The 6nn series is
reserved for assignment at a future date to symbols representing voice quality settings or pathological
speech; and 7nn-8nn are also reserved for future specification. The 9nn series specifies control
characters and escape sequences, designed to relate characters to each other in a string (for correct
placement of diacritics, for example). The intention of the IPA number chart is to parallel the IPA symbol
chart, making the locations and relationships of items explicit and unambiguous. For the present
purposes of review and evaluation of the numbering scheme, the presentation of the IPA number chart
and corresponding lists is intended to illustrate the relationships between symbols on the chart (and with
those not shown but also numbered), and where overlap between categories can occur.

Symbols can now be listed with reference to their IPA number, and cross-referenced to symbol name.
These reference lists can follow (1) chart order of appearance of the symbols, (2) quasi-alphabetical order
of the symbol shapes themselves and (3) alphabetical order of the names of the symbols. The IPA
number chart provides a visual map in chart order. The list of consonant/vowel symbols in chart/number
order summarizes this sequence and includes the listing of the 2nn series and items of the 3nn series
that are no longer on the chart. The list of consonant/vowel symbols in alphabetical order by symbol
reproduces the compilation in Pullum and Ladusaw'’s Phonetic Symbol Guide (1986). Some modifications
have been made to the names taken from the Guide as they appear here. It is the sentiment of the
Computer Workgroup that in order to have an explicit system for referring to each character
unambiguously, symbols need to be called something that is relatively nonphonetic in addition to having
a number. Diacritics are listed, with illustrations as to usage, according to chart order. In addition, it is
also possible to produce cross-referenced lists to consonant/vowel symbols and to diacritics according to
alphabetical order by symbol name. All of these listings are proposed to constitute a part of The IPA
Handbook.

Reference

Pullum, G.K. and W.A. Ladusaw, Phonetic Symbol Guide. Chicago: University of Chicago Press, 1986.
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F-3 Consonant/Vowel Symbols

IPA Description Glyph IPA Number Access Code
Lower-case P (m ] 101 112
Lower-case B & 102 098
Lower-case T ¢ 103 116
Lower-case D 2 104 100
Right-tail T N 105 255
Right-tail D A 106 234
Lower-case C X 107 099
Barred Dotless J @ 108 239
Lower-case K K 109 107
Lower-case G Yo 110 103
Lower-case Q a 111 113
Small Capital G ¢ 112 071
Glottal Stop <= 113 063
Lower-case M O 114 109
Left-tail M (at right) o 115 077
Lower-case N u 116 110
Right-tail N = 117 247
Left-tail N (at left) * 118 248
Eng 2 119 078
Small Capital N 9 120 178
Small Capital B R 121 245
Lower-case R a 122 114
Small Capital R o] 123 123
Fish-hook R o 124 082
Right-tail R & 125 125
Phi & 126 184
Beta & 127 066
Lower-case F X 128 102
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IPA Description Glyph IPA Number Access Code
Lower-case V R 129 118
Theta & 130 084
Eth $ 131 068
Lower-case S . 132 115
Lower-case Z 3* 133 122
Esh ) 134 083
Yogh € 135 090
Right-tail S (at left) . 136 167
Right-tail Z @ 137 189
C Cedilla 2] 138 067
Curly-tail J © 139 198
Lower-case X 140 120
Gamma T 141 196
Chi 3 142 088
Inverted Small Capital R 3] 143 210
Crossed H A 144 240
Reversed Glottal Stop Ve 145 192
Lower-case H h 146 104
Hooktop H P 147 250
Belted L P 148 194
L-Yogh Digraph ® 149 076
Cursive V d 150 086
Turned R a 151 168
Turned R, Right Tail Xl 152 211
Lower-case J er 153 106
Turned M, Right Leg 74 154 229
Lower-case L L4 155 108
Right-tail L = 156 241
Turned Y & 157 180
Small Capital L @) 158 059

MUODO0000700 160 Revision B



PENTAX

MEDICAL
IPA Description Glyph IPA Number Access Code
Hooktop B O 160 186
Hooktop D R 162 235
Hooktop Barred Dotless J o 164 215
Hooktop G % 166 169
Hooktop Small Capital G ” 168 253
Turned W @ 169 227
Lower-case W . 170 119
Turned H €« 171 231
Barred Glottal Stop x> 172 251
Small Capital H © 173 075
Barred Reversed Glottal Stop @ 174 185
Hooktop Heng k 175 238
Bull's Eye I 176 135
Exclamation Point 178 157
Turned Long-leg R q 181 228
Curly-tail C @ 182 254
Curly-tail Z & 183 252
Lower-case | Al 301 105
Lower-case E m 302 101
Epsilon = 303 069
Lower-case A s 304 097
Cursive A ] 305 065
Open O Fo 306 141
Lower-case O O 307 111
Lower-case U * 308 117
Lower-case Y 309 121
Slashed O R 310 079
O-E Digraph 311 191
Small Capital O-E Digraph %3 312 175
Turned Cursive A @ 313 129
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IPA Description Glyph IPA Number Access Code
Turned V @ 314 195
Ram’s Horns T 315 070
Turned M * 316 181
Barred | 0 317 246
Barred U 4 318 172
Small Capital | \VZ 319 073
Small Capital Y el 320 089
Upsilon s 321 085
Schwa * 322 171
Barred O @ 323 080
Turned A o 324 140
Ash digraph &, 325 081
Reversed Epsilon 2 326 206
Undotted | \V 394 034
Closed Reversed Epsilon ® 396 207
Reversed E ° 397 130
Dotless J — 190
Superior m ) 201
Superscript Eng ™ 212
Superscript left-tail N (at left) foa 203
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F-4 Segmental Diacritics

IPA Description IPA Number Access Code
Apostrophe 401 039
Under-ring (o-width) a2 402 056
Under ring (i-width) G 402 165
Over-ring (o-width) a 402 042
Over ring (i-width) I’G) 402 161
Subscript Wedge S 403 164
Superscript H 9 404 072
Subscript Umlaut (o-width) ® 405 045
Subscript Umlaut (i-width) ® 405 208
Subscript Tilde 406 188
Subscript Seagull \% 407 209
Subscript Bridge g 408 053
Inverted Subscript Bridge » 409 176
Subscript Square El 410 054
Subscript Plus (o-width) é 413 043
Subscript Plus (I-width) é 413 177
Under-bar (o-width) 414 061
Under-bar (i-width) 414 173
Umlaut 0 415 095
Over-cross (=] 416 126
Right Hook 0 419 213
Superscript W ¢ 420 087
Superscript J & 421 074
Superscript Gamma < 422 236
Superscript Reversed Glottal Stop M 423 179
Superscript Tilde (o-width) oo 424 041
Superscript Tilde (i-width) 424 226
Superscript N E 425 060
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IPA Description IPA Number Access Code
Superscript L ® 426 058
Corner i 427 124
Superimposed Tilde ~ 428 242
Raising Sign (o-width) O] 429 051
Raising Sign (i-width) O] 429 163
Lowering sign (o-width) g 430 052
Lowering sign (i-width) g 430 162
Syllabicity Mark ' 431 096
Subscript Arch (o-width) . 432 057
Subscript Arch (i-width) " 432 187
Top Tie Bar O 433 131
Comma 2 491 044
Vertical Stroke (Superior) < 501 200
Vertical Stroke (Inferior) IT 502 199
Length Mark a 503 249
Half-length Mark a 504 062
Breve (o-width) < 505 040
Breve (i-width) =y 505 225
Period . 506 046
Vertical Line ©3 507 150
Double Vertical Line @ 508 132
Bottom Tie Bar 509 237
Upward Diagonal Arrow o 510 204
Downward Diagonal Arrow 511 205
Double Acute Accent (o-width) bof 512 033
Double Acute Accent (i-width) bof 512 218
Double Acute Accent (high o-width) hof 512 136
Double Acute Accent (high i-width) hof 512 137
Acute Accent (o-width) & 513 064
Acute Accent (high o-width) e 513 219
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IPA Description IPA Number Access Code
Acute Accent (i-width) & 513 143
Acute Accent (high i-width) P 513 144
Macron (o-width) = 514 035
Macron (high o-width) an 514 220
Macron (i-width) = 514 147
Macron (high i-width) an 514 148
Grave Accent (o-width) ” 515 036
Grave Accent (high o-width) » 515 221
Grave Accent (i-width) ”? 515 152
Grave Accent (high i-width) » 515 1563
Double Grave Accent (o-width) (o3 516 037
Double Grave Accent (high o-width) (=3 516 222
Double Grave Accent (i-width) R 516 157
Double Grave Accent (high (=3 516 158
i-width)

Down Arrow %3 517 155
Up Arrow S 518 139
Extra-high Tone Bar ©) 519 138
High Tone Bar (5] 520 145
Mid Tone Bar (9] 521 149
Low Tone Bar ! 522 154
Extra-low tone Bar : 523 159
Wedge (o-width) e 596 038
Wedge (i-width) e 596 224
Wedge (high o-width) e 596 244
Wedge (high i-width) S 596 243
Circumflex (o-width) G 597 094
Circumflex (i-width) & 597 223
Circumflex (high o-width) & 597 233
Circumflex (high i-width) & 597 230
Left Square Bracket Q 901 091
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IPA Description IPA Number Access Code
Right Square Bracket & 902 093
Right Bar 15 © 232
Right Bar 51 (6] 134
Right Bar 35 . 216
Right Bar 13 1) 128
Right Bar 53 y 133
Right Bar 31 ey 217
Backward Slash \ 092
Forward Slash / 047
Hyphen Dash - 214
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This Appendix provides a complete list of the predefined keyboard combinations that can be used to
execute program operations.

Primary menu options are listed in bold, followed by a semicolon and submenu options.

Key Menu Item Description
F1 Help: Open Help Opens Help documentation.
F2 Window: Purge Active Clears the active window and removes
Window any associated data.
F3 Speak: All Data Starts audio output of all signal
associated with active window.
F4 Speak: Selected Data Starts audio output of signal associated
with selected region in active window.
F9 Window: Information on Displays summary information about the
Active Window most recent data placed in active.
F12 File: New (Record) Purges the active window and captures
a new signal.
Shift+F1 IPA: Load IPA Symbols to Configures keyboard for typing IPA
Keyboard symbols into window containing
waveform.
Shift+F2 IPA: Restore Keyboard to Removes the IPA keyboard
Normal configuration.
Alt+F4 File: Exit Exits back to Windows.
Alt+A View: All Data Displays all graphic data associated with
active window.
Alt+C View: Start to Cursor Displays graphic data from start of data
to cursor location in active window.
Alt+E View: Cursor to End Displays graphic data from cursor
location to end of data in active window.
Alt+L Window: Link Windows, Link Links cursor movement, selection and
to Source Window display in active window to source.
Alt+M View: Between Data Mark and Displays graphic data between green
Cursor marking cursor and red data cursor.
Alt+R Analysis: Produce Numerical Displays numerical results of last

Results

analysis in active, with print/save
options.

MUODO0000700

167

Revision B



PENTAX

MEDICAL

Key Menu Item Description
Alt+S Analysis: Compute Result Gets stats of last analysis results in
Statistics active, with print/save options.
Alt+T View: Between Tags Around Displays waveform from tag preceding
Cursor to tag following cursor in active window.
Alt+U Window: Link Windows, Unlinks active window from any other
Unlink Active Window windows it was previously linked to.
Alt+V View: Selected Data Displays graphic data in selected region
of active window.
Alt+W Window: Select Active Makes active window the signal source
Window as Source for subsequent analysis or editing.
Shift+Del Edit: Remove Selection Removes selection cursors from the
Cursors data in active and linked windows.
PgUp Window: Activate Next Activates the previous window in a list
Window of available windows.
PgDn Window: Activate Previous Activates the next window in a list of
Window available windows.
Ctrl+Home View: Put Previous Plot on Top If multiple plots in active, brings
previous plot to front.
Ctrl+End View: Remove Current (Top) If multiple analysis plots in active,
Plot deletes the plot that is on top.
Ctrl+A Edit: Select All Data Selects all data in active and linked
windows.
Ctrl+C Edit: Copy Signal to Clipboard Copies signal data in the active window
to the clipboard.
Ctrl+N Window: Open New Window Creates new window over active
window, with attributes of active.
Ctrl+O File: Open (Load) Purges the active window and loads
new waveform data from a file.
Ctrl+P File: Print/Save Graphic Accesses dialog box for sending graphic
Images, Print Full Screen image of the full screen to the selected
Image printer.
Ctrl+S File: Save Saves the waveform data in the active
window to a file.
Ctrl+V Edit: Paste Signal from Purges the active window and loads
Clipboard signal data from the clipboard.
Ctrl+Z Edit: Undo Last Edit in Active Undoes last edit made to the data in the

active window.
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Key Menu Item Description

Shift+Ctrl+P File: Print/Save Graphic Prints the image in the active window
Images, Print Active Window using the resolution of the selected
Image printer.

Shift+Ctrl+S File: Print/Save Graphic Saves the image in the active window

to a graphics file, with user-selectable
resolution.

Images, Save Active Window
Image

The second table lists the keyboard shortcuts that can be used to move the data cursor and perform

similar operations.

Key Description

Home Moves the data cursor in the active window to the start of the displayed
data.

End Moves the data cursor in the active window to the end of the displayed
data.

Left Moves the data cursor in the active window one pixel to the left.

Right Moves the data cursor in the active window one pixel to the right.

Ctrl+Left Moves the data cursor in the active window ten pixels to the left.

Ctrl+Right Moves the data cursor in the active window ten pixels to the right.

Up Moves data cross-hair up one pixel in spectrogram and formant displays.

Down Moves data cross-hair down one pixel in spectrogram and formant
displays.

Shift+Up Highlights next frame on z-axis in waterfall display.

Shift+Down Highlights previous frame on z-axis in waterfall display.

Ins Opens dialog box for defining keys to execute commands and for showing
current definitions.

Num+ Places a data mark at the current cursor location in the active window.

Num- Selects all data in active and linked windows.
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Appendix H. Mise en Garde et Precautions

JAN

Avertissement

Vous devriez lire et comprendre les directives comprises dans le présent manuel avant
d'exécuter toute intervention a l'aide du CSL et Multi-Speech. Tout manquement a cet effet
pourrait blesser le patient ou endommager I'instrument.

Avertissement

Des messages d'avertissement vous indiqueront quelles conditions pourraient entrainer des
blessures graves, voire la mort.

Avertissement

Pour éviter les risques de choc électrique, connecter cet équipement a une source d'alimentation
protégée par une mise a la terre.

Avertissement

Pour réduire le risque d'incendie et de choc électrique, ne pas exposer I'équipement électrique a
I'humidité et a la poussiere.

Avertissement

Cet équipement ne doit pas étre utilisé en présence d'un mélange d'anesthésique inflammable et
d'air, d'oxygéne ou d'oxyde nitreux.

Avertissement

[l est recommandé de porter de I'équipement de protection approprié (gants, vétements
imperméables souples, masque et protection respiratoire) pendant I'exécution des interventions
de retraitement.

Mise en garde

Les messages de mise en garde vous indiquent des problemes pouvant entrainer des blessures
mineures ou modérées ou des dommages.

Mise en garde
Ne pas modifier cet équipement sans avoir l'autorisation du fabricant a cet effet.

Mise en garde
Ce produit ne contient aucune piéce pouvant étre réparée. Ne pas démonter |'unité.

>b B> B B B BB P

Mise en garde

Les accessoires branchés au port USB doivent étre homologués selon la norme |IEC 60950-1
Equipement informatique — Sécurité — Partie 1 : Exigences générales pour I'équipement de
traitement des données et IEC 60601-1 Equipement médical électrique - Partie 1 : Exigences
générales pour la sécurité pour I'équipement médical.
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